Welcome to discussions

Quick Suggestions

  • UNSOLVED [PC] After TU 1.1.0, I am experiencing FPS drops / low CPU and GPU utilisation | POST HERE

    64 Likes/1290 Replies/41794 Views
    peterlaub
    Original poster 66 posts

    @Voidolt I just need to understant it correctly, you have not installed 3 party files, but only "updated" windos, and now valhalla is running as before?

  • petek
    72 posts

    Sadly still appalling on my PC with the .dll and latest windows update

  • peterlaub
    Original poster 66 posts

    Oh, I just wastede 2 hours downloading Valhalla, just to delete it againg.. I dont know why i triede... I still runs at 30 FPS.

  • petek
    72 posts

    @peterlaub I feel you mate - doesn't bode well for sales for next years expansion on PC does it? How to take a perfectly functioning game at release and then shaft all those on PC who bought it.... ridiculous...

  • longjohn119
    723 posts

    @peterlaub I was going to download it and give it a try for the first time since April or May but their servers are so slow I said forget about it ..... I have 500 mb/s fiber and was only getting between 80 and 90mb/s download speeds ..... Steam gives me over 400 mb/s and GOG is even faster

  • peterlaub
    Original poster 66 posts

    @longjohn119 I will save you the trouble. Dont download it. Nothing has changed!

  • Voidolt
    32 posts

    @peterlaub Yes I have installed optional windows update weeks ago and now i haven't experienced this issue anymore.(after few mins or alt tab or fast travel that I was stuttering from 40 fps to 10 fps)
    I don't have 3rd party file.

  • CrimsonWolf-YT
    40 posts

    @longjohn119 hmmm usually for me ubisoft has fastest servers ngl XD its consistant around 50megabytes while i have 500megabits internet xD

  • CrimsonWolf-YT
    40 posts

    I tried to set resolution scale at 200% it resulted with 80-100 gpu usage but cpu still hangs around 50 and less. And fps is again very low, i mean before setting at 200scale it was 30 and after it was 30 again xD which is impossible.

  • STRELATS
    14 posts

    @longjohn119 Ubisoft Server are one of the fastest, I have also 500 optic fiber and when i download/update a game I reach the maximum bandwidth of my internet connection so I think that you have a problem with you internet connection and its better to call your ISP😊

  • longjohn119
    723 posts

    @strelats There is nothing wrong with my ISP, I tried several other sites with Speedtest and they were all over 500 mbs up and 500 mbs down (symmetrical) .... It was plenty fast back in February (last time I downloaded and tested the game) but the other day it was just slow ... I didn't plan on doing anything but some testing because regardless of the performance the Aim Assist remains completely broken and I flat out refuse to play it until it is fixed nor will I buy any other Ubisoft games until it is fixed .... which is looking a lot like never ... I wasn't willing to wait an hour and a half just to test the game out for 15 -30 minutes to see it it crashed for me

    Past performance never indicates present or future results ....



  • STRELATS
    14 posts

    @longjohn119 I totally got you, I was in your position till I apply a third party fix for CPU utilization, and now I m enjoying a stable FPS, I already posted about the fix it is working perfectly for me and for others just google "Assassin's Creed Valhalla CPU utilization fix v2"
    Enjoy 😊

  • Zarael1721
    96 posts

    @strelats

    @peterlaub


    HOLYY CRAP i am here after like two months again and obviously from side of ubisoft nothing changed but that amateur fix who made someone to download WORKS!!!!!! before in village 35 fps now 55 !!!!!!!!!!!!!!!!!!!!!!!!!!! [censored] ubisoft didnt care about that fix so someone had to fix it alone thank to that guy who cared about solve that problem actually ... That fix even when i didnt believe works! Maybe ubi idiots could watch whats inside and copy it into next patch omg...

  • Snt.Grem
    34 posts

    I tried this fix, absolutely no change. The processor is just idle in this game, and of course [censored] does not see this ...

  • peterlaub
    Original poster 66 posts

    @snt-grem Did you remember to unpack the file?

  • Snt.Grem
    34 posts

    @peterlaub, of course! No effect on fps or component loading in my case. Actually, it shouldn't have been, I don't believe that some extraneous .dll file can fix the curvature of the programmers of this studio of scammers.

  • peterlaub
    Original poster 66 posts

    @snt-grem Yup, I am not buying a UBISOFT game again.!

  • Woodverine
    1 posts

    Maybe this will help someone.
    I had an issue with CPU utilization being 35% at most and stuttering/FPS dropping while playing AC Valhalla, after the solution I provided below it went up to 80% if game needed it in certain areas.

    So what I did was:

    1) Press Win+R to open "Run command" window
    2) Enter msconfig.exe
    3) Go to "Boot" tab
    4) Click "Advanced options..."
    5) Tick the box "Number of proccessors" and set it to the number of threads your CPU have ( eg. I have Ryzen 3700x so I chose "8" )
    6) Restart PC

    Hope that helps.

  • longjohn119
    723 posts
    Maybe this will help someone.
    I had an issue with CPU utilization being 35% at most and stuttering/FPS dropping while playing AC Valhalla, after the solution I provided below it went up to 80% if game needed it in certain areas.

    So what I did was:

    1) Press Win+R to open "Run command" window
    2) Enter msconfig.exe
    3) Go to "Boot" tab
    4) Click "Advanced options..."
    5) Tick the box "Number of proccessors" and set it to the number of threads your CPU have ( eg. I have Ryzen 3700x so I chose "8" )
    6) Restart PC

    Hope that helps.


    Actually you set it to the number of cores you have (which is what you did) .... the 3700X is 8 cores/16 threads with SMT turned on in the BIOS which is the default .....

  • Snt.Grem
    34 posts

    I changed the processor and I can now continue my game. But the funny thing is that I still get much lower FPS than the old 8 year old processor before 1.1.0 update. How it was possible to screw up the game like that, only [censored] knows...

Suggested Topics