ubisoft discussions

Quick Suggestions

  • Locked Solved [RESOLVED] [PC] After TU 1.1.0, I am experiencing FPS drops / low CPU and GPU utilisation | POST HERE

    64 Likes/1327 Replies/49832 Views
    Zarael1721
    96 posts

    Its not necessary this thread is already like mountain between all threads here if you look on views , likes and posts in relatively short time... there are threads what were not serious issues like this one and had not even half of views and posts or likes as this one and were somehow solved... I guess the problem is deeper and ubisoft for uknown reason doesnt want accept the mountain is here...

  • Slevexz
    79 posts

    The funny thing is that they have staff online in other topics
    @UbiExcellent

  • Slevexz
    79 posts
  • Zarael1721
    96 posts

    @slevexz

    Yes because we are like that one scary girl what you dont like and are afraid of so you better put her into invisible mode 😄

  • Slevexz
    79 posts

    @zarael1721 Oh i see... So that is their technique, clever from Ubi

  • Slevexz
    79 posts

    @Ubi-Woofer

  • master_ring
    41 posts

    I havent played since patch and wont play probably till next pacth. Hoped they fixed it but nope, they dont even bother answering and admittng a problem.

    FPS is horrible, Intel cpu two cores works at 60-80 percent, other two at 30 max.

    Its 3 weeks now.

  • forever0075
    2 posts

    I dont believe that they don't reply here regularly to calm down the atmosphere. It should be the number one priority for them, because WE CANT EVEN PLAY the game that we've bought!
    How dare they? Imagine buying laptop that works pretty bad and after "fix" its completely useless for 3 weeks without any explanation (?!). It should be reported somewhere!

  • Slevexz
    79 posts

    @forever0075 I also think we should report this somewhere else

  • Sparhawk122
    80 posts

    @forever0075

    This is what happens when game companies get too big and confident. They become lazy and complacent. Very slow to respond to issues and rectifying them. Just like Bethesda and not fixing bugs that are years old, that also make it into their new games. Ubisoft's problem that makes it into their games is CPU utilization. Common theme for all their games and this latest patch changed CPU utilization for the worse. So much so that some of us are losing 20-30 FPS in comparison to the framerates we were get pre patch 1.1.0

  • Oresp94
    13 posts

    I'm just wondering with my small mind,if the fix for us is just to roll back to the previous patch why aren't we able to,after 20 days?I'm not an expert or anything,but is it really so difficult?

  • Slevexz
    79 posts

    @oresp94 That is too hard for ubisoft

  • FierceJeopardy
    10 posts

    @oresp94

    Also, the problem was already there before... It just didn't happen to that many people.
    I for one encountered this problem within the first week, and had to learn how to play "around" it... 😥

  • Bob.Ross_
    4 posts

    Hello guys, so I just spoke with support staff in live chat and I told him/her what's going on in this forum thread and with this issue in general and he/she told me that they know about the issue and is as she/he said high priority. I also asked them if we can expect an answer from them soon but he/she told me that they still don't have an estimated time for the resolution but they assured me that they are working to resolve this issue so all I can say guys is to have more patience and stay strong. Peace.

  • RyanHalevyX
    14 posts

    Like the previous post, I also spoke with the support team. Tried to get a refund because the game is just sitting in my library unopened since the FPS drop issues began. They told me that the team is working on it but the details are very vague. A new or consistent official update/announcement/acknowledgement from Ubisoft is needed--that's the least they can do rather than just keep us aimlessly waiting.

    I'm not a software person, but I really want to understand how is it so difficult to issue a performance hotfix? The issue was basically a non-issue before the 1.1.0 update for us. We practically waited for an update that would ruin the game playability? Go figure.

  • AllianceStuck
    156 posts
    This post is deleted!
  • Rinorifa
    2 posts

    @bob-ross_ first we just wait till the next patch coming maybe mid january or end of january idk, and see this issue still appear or not.

    if next patch the problem still happen let's report on this thread or maybe create a new thread again.

  • dodokjv
    22 posts

    @bob-ross_ That's awesome. Thank you for chatting with them.

  • Zarael1721
    96 posts

    @Bob-Ross_

    Thats nice to hear that they didnt ignore you actually but would be even nicer if she / he (if you dont know if its she or he there is new gender not racist expression - IT so u can use it next time lol) gave some answer straight into this thread. You know the thread if you click on GAMEPLAY section and then TOP is at this moment rank 3 not resolved gameplay issue (if you dont mind AC Valhalla seems to be very unifinished which is not an issue actually.. ) and rank 4 at section of Technical issues i think it could deserve some official statement finally because things like i was talking to one of them are better than nothing for sure but still seems to be only dead end of the street without an offcial statement.

  • xXdouglasXx8036
    15 posts

    The game is unplayable on Series S after this yule update, the console cant even reach 25 FPS in towns on PERFORMANCE mode and stuttering ALL over the place what Ubisoft did with this update?????? the game was good on performance before this update

Suggested Topics