ubisoft discussions

Quick Suggestions

  • Locked Solved [RESOLVED] [PC] After TU 1.1.0, I am experiencing FPS drops / low CPU and GPU utilisation | POST HERE

    64 Likes/1327 Replies/50328 Views
    kvsh88
    49 posts

    @ubi-orion please provide atleast some help to us so that we could breathe easy. We have paid money for a product that should be playable at the very least.

  • yrkmn28
    3 posts

    @kvsh88 Yeah, but before I did the rollback I was at like 30 fps. idk what's going on.

  • kvsh88
    49 posts

    @yrkmn28 yeah maybe that mightve helped. Atleast ubi should give the option to roll back the game update.

  • dodokjv
    22 posts

    I have the same problem as everyone in this thread. Low cpu usage. I hope they fix it in the next 10 days, otherwise im getting a refund and will never buy another game from ubisoft. This is unacceptable.

  • mescalito12
    7 posts

    Hey ubisoft, did u figure out yet what is the cause of the fps drop?

  • T1GFX
    39 posts

    @kvsh88 44% usage across 8 cores and 16 threads, where is the issue? Their GPU is being used fine unlike on Intel CPUs. If they had a stronger GPU and left framerate uncapped at the same settings, the CPU usage would be higher. Common sense.

  • T1GFX
    39 posts

    @mescalito12 Holiday frenzy combined with a rushed update.

  • Jormommy
    27 posts

    Yeah, same for me. Used to get 45-60 FPS, now my GPU and CPU utilisation are hovering around 50 percent and my FPS is atrocious. FPS is only terrible during gameplay - the game utilises my GPU and CPU properly during loading screens.

  • TyranusVader
    121 posts

    @kvsh88 as long as his GPU usage is 95 - 100%, then low CPU usage is fine. In fact, it's ideal because you always want to be GPU limited.

    The issue is when you have low CPU usage AND low GPU usage. Then it's a problem, unless you're deliberately capping the frame rate.

  • Smiley_ie
    6 posts

    Bought the game yesterday benchmark 26% - 31% CPU usage GPU is fine 90s%

  • kvsh88
    49 posts

    @tyranusvader Ohh okay but what about the spikes on the graph it shoudnt be so erratic as well right?

  • Surtr-Destroyer
    45 posts

    @tyranusvader well cpu and gpu aint high in usage

  • Ckau
    1 posts

    i5-4690, gtx970 after patch i cant play in game, have 10-15fps, before patch i have 45fps. Thx for сhristmas....

  • Slevexz
    79 posts

    How hard can be to fix a problem they create?
    This post was made 15/12 and nothing so far

  • Zarael1721
    96 posts
    This post is deleted!
  • Zarael1721
    96 posts

    @slevexz

    Obvisously so hard that they decided ignore all pages of reports and pretend everything is fine 😄 That sucks so much i am so disapointed how the things are i was always fine with Ubisoft but this is too much feels like spit into face for now because we all bought full game and most of us even dlcs for sure and cant play..

  • kvsh88
    49 posts

    @zarael1721 Well I mean they have responded in this thread. So we just have to wait and see if the next fix helps on this .

  • Zarael1721
    96 posts

    @kvsh88 they did respond last time few days ago that they will try fix the game till Christmas what obviously will be not fixed... They also responded they will keep us informated what they dont do too... it gives me vibes that if they give at least half of the time as they give to design new items and mounts for helix points we could already play the game again...

    btw.... Its weird to see new reports on players support with same issue as we have and the report replied by same ubisoft person as replied on here but with the diference that he says to person with obviously same issue as we have "try clean pc or some trouble steps.. thats ridicoulus isnt that?

  • TyranusVader
    121 posts

    @kvsh88 The spikes should not be frequent like the game is having a heart attack that's for certain. It's either a driver issue or a game optimization issue. Considering that this is happening on both AMD and Nvidia GPUs, I lean towards the later. Ideally, the frame time graph should be a straight horizontal line with the occasional spikes due to game resources loading in the background.

  • TyranusVader
    121 posts

    @smiley_ie If that's your case, then something is definitely wrong. When I play, I get 25-30% CPU usage and 95% to 100% GPU usage. I play on 4k Ultra High preset with a resolution modifier set to 70% while using the Special K mod. The game is smooth. Of course, I would rather not resort to third party mods to fix a AAA game. It's getting silly.

Suggested Topics