ubisoft discussions

Quick Suggestions

  • Locked Solved [RESOLVED] [PC] After TU 1.1.0, I am experiencing FPS drops / low CPU and GPU utilisation | POST HERE

    64 Likes/1327 Replies/50536 Views
    Surtr-Destroyer
    45 posts

    @longjohn119 Yea, my cpu is now around 90% and gpu consistently 95-100
    I have i54460 and gtx 1060 its back to how it was before 1.1.0

  • petek
    106 posts

    @longjohn119 hi noticed slight improvement FPS wise even before the patch - still often stuttering /slow downs in fights etc... Thanks

  • dodokjv
    22 posts

    I cant believe they really fix this!! I can now play at almost 60 fps instead of 30 like before. On my poor 1060 3GB. The only issue I have is with huge spikes and fps drops but when i play offline its good. Finally!
    Now im an idiot and will probably give ubisoft more money for season pass dlcs and far cry 6...

  • Surtr-Destroyer
    45 posts

    @petek How much fps u had before 1.1.0?
    Cuz for me it worked 🙂
    Ur gpu is maxed.

  • petek
    106 posts

    @surtr-destroyer Hiya - it was more that I had a stable 50-60 FPS with no slow downs even is assaults and other AI heavy situations. Although FPS is better in benchmark still crawls to single digits in some fights.... I have to admit I've kind of given up.... Thanks

  • Surtr-Destroyer
    45 posts

    @petek yes, i know. I have unstable game aswell but at least its 60+fps and not 30 hahaha but its not always unstable. It's usually first time I ran the game in the day its unstable.

  • petek
    106 posts

    @surtr-destroyer Hiya - for me it's most fights (and also pretty random!) Just pisses me off that it worked fine before the patch. Ubisoft really don't seem to go with the "if it ain't broke don't fix it" on this game (mounted combat, transmog etc..) Cheers

  • Ubi-Borealis
    Ubisoft Support Staff 6075 posts

    Hello there,

    I apologise for the delayed response. Thank you for continuing to share your reports regarding FPS drops and low CPU / GPU utilisation within this thread. I'm glad to hear that this issue has been alleviated for a number of you following the release of TU 1.4.0! 😄

    If you are still experiencing FPS drops and low CPU / GPU utilisation after the release of TU 1.4.0, I'd like to reassure you that the development team are still investigating this issue further. To assist with the ongoing investigation, if you have not already, please can you provide us with the following information:

    • A screenshot of your graphical settings in-game
    • A video that demonstrates the FPS drop you're encountering in-game. Additionally, please can you show the usage percentage of your GPU and CPU while running the benchmark on the settings that you are using


    I'd recommend uploading this video to a sharing platform, such as YouTube or Google Drive, as this will allow you to post a shareable link within this thread. Once you have provided us with this information, we will also open up a support ticket for you so we can collect a copy of your system's DxDiag. This system file will be helpful for further investigation.

    Thanks! 😊

    Official Response
  • GreySnakes
    6 posts

    Greetings,

    I have just started playing the game recently (1.5.2 on PC) and I'm facing the stuttering problem as well.

    It happens mostly clearly when I turn the camera around while exploring on foot. Almost not at all if I'm simply running straight.

    Also, bafflingly, it doesn't happen at all while commanding the ship. It becomes super smooth without a single dip in frame rate.

    I have tried many recommendations to no avail, such as closing all other programs, going offline, disabling any and all overlays, disabling full screen optimization, switching to controller only input, memory clearing, etc.

    This is what it looks like when I simply rotate the camera while standing still (limiting at 60 FPS):

  • longjohn119
    1340 posts

    @greysnakes Use Exclusive Full Screen (Borderless Windowed with or without Full Screen Optimizations is broken right now) limit the FPS to 60 and turn on V-sync. It's the only way I can get the game stable and not crashing and/or stuttering all the time. I suspect there is a problem in the DX12 Swap Chain Frame Buffer APIs

    Note that Full Screen Optimizations only applies in Windowed or Borderless Windowed modes and what it does is try to simulate Exclusive Full Screen so you don't lose a few FPS (At least in most games) If a game is properly programmed then you see little to no difference in performance (FPS and stuttering) between Exclusive Full Screen and Borderless Windowed with Full Screen Optimizations .... Odyssey is an example where you see no difference at all in performance between the two modes, at least the last time I benchmarked which was before the December update

  • GreySnakes
    6 posts

    Thanks for the suggestions.
    Just tried them, but unfortunately no change.
    I've even been testing different nVidia drivers, desperate for a solution.
    And also overclocking CPU/GPU to no avail.
    Nothing seems to be helping with the stutters when the camera turns. Be it in game or in the benchmark.

  • GreySnakes
    6 posts

    After further testing, I noticed that the frame rate dips and stutters occur specifically when there is ready access by the game from the drive.

    The game is installed on a NVMe SSD, and I have 32GB of RAM, with around 20GB free.

    Is there a way to minimize the read access from the drive? I'm suspecting it is causing the stutters.

    I've tried totally disabling paging, but no change.

  • UbiSushiVamp
    Community Representative 1138 posts

    @greysnakes Greetings! Apologies for the delayed reply. Just to check, is Ubisoft Connect and Valhalla installed on the same drive? Also, is the drive an internal drive or an external drive?

    Official Response
  • GreySnakes
    6 posts

    Hello,

    Yes, they're installed on the same SSD, which is internal and hosts Windows 10, as well.

    I have just installed Windows 11, in dual boot, on the secondary drive (HDD, which is so slow), and Ubi Connect is installed on the HDD in this W11 instance, while launching the game from same SSD installation, and the problem has gone away.

    It is worth noting that I have noticed the CPU utilization in the game is much higher in W11 than in W10. No idea if this is OS-related, mind, just how my observations are going.

    Furthermore, my CPU isn't officially supported by W11, but a clean install doesn't care.

    It may have worked just as well with a clean W10, but I'm not going to waste my time doing that just for this one game, and I'll be going back to my original W10 installation once I'm done with this game.

    Tl;dr: clean W11 install fixed the issue by having the game utilize more of the CPU.

  • potlu
    5 posts

    hi, i just started playing the game and i am having very poor performance. i think i am also suffering from the low cpu issue. my cpu sits at 60% usage while gpu is fully utilized at 98%. i am getting around 40-45 fps which is horrible for my system. i easily got 60 fps with odyssey.

    my system specs:
    zotac gtx 1070
    i7 7700K
    16 GB RAM
    Win 10

    i believe that combo should easily get near 60 fps. culprit seems to be under utilized cpu. can you please suggest a fix? thanks!

  • longjohn119
    1340 posts

    @potlu You are GPU bound and since the GPU is fully utilized the CPU only needs 60% usage ..... The CPU will only go as fast as the GPU demands from it and once the GPU is at full usage the CPU isn't go to work any harder. Try lowering the anti-aliasing to medium and turning off Depth of Field because those are the two things that stress the GPU the most in Valhalla. Odyssey was DX11 so it's going to perform different from Valhalla which is DX12

    You may also find this video helpful in tuning the graphics settings for the best performance without lowering the graphics quality too much

  • potlu
    5 posts

    @longjohn119 hey! i already did try lowering those settings & even the other ones like shadows, environment, texture, etc but still dont see any improvement. i see YT videos with same config as i have easily getting around 60 fps on mostly high so i dont understand why i am having this issue.

    any other suggestions?

  • potlu
    5 posts

    here is my config:

    [Language]
    Client=en-US
    Text=en-US
    Sound=en-US
    Subtitles=en-US
    [Graphics]
    AdapterVendorID=4318
    AdapterDeviceID=7041
    MonitorDesc=
    DisplayIndex=0
    WindowPosX=0
    WindowPosY=0
    FullscreenWidth=1920
    FullscreenHeight=1080
    WindowedWidth=0
    WindowedHeight=0
    WindowMaximised=0
    RefreshRate=144
    WindowMode=3
    VSyncMode=0
    MaxFPS=30
    IsFpsLimitEnabled=0
    PixelDensity=1.00000
    LastUsedFullscreenMode=0
    KeepStandardAspect=0
    HDREnabled=0
    Freesync2Enabled=0
    UpsampleType=0
    FSRQuality=0
    AdaptiveQuality=0
    Antialiasing=2
    Bloom=1
    Character=2
    CharacterTexture=2
    Cloud=0
    Clutter=2
    CrowdDensity=0
    Culling=0
    DOF=1
    Environment=2
    Fog=2
    Lighting=0
    MotionBlur=0
    Rain=2
    Reflection=1
    Shadow=2
    SSAO=2
    Terrain=0
    Tessellation=2
    Texture=2
    TextureFiltering=2
    Water=2
    [Startup]
    StickyKeys=2
    ToggleKeys=2
    FilterKeys=2
    [LightingDevices]
    Config=[{"id":"MSI MysticLight SDK","enabled":true,"config":{"ip":"localhost","port":1462,"ambientPort":14621,"authToken":""}}]
    Enabled=0
    [VoiceInput]
    InputMode=1
    [Options]
    TobiiEnabled=1
    TobiiExtendedViewEnabled=1
    TobiiAimAtGazeEnabled=1
    TobiiMarkAtGazeEnabled=1
    TobiiInteractAtGazeEnabled=1
    TobiiLockTargetAtGazeEnabled=1
    TobiiDynamicLightAdaptationEnabled=1
    TobiiSunEffectsEnabled=1
    TobiiHeadTrackingAutoResetEnabled=1
    TobiiExtendedViewSensitivity=50
    TobiiExtendedViewResponsiveness=50
    TobiiEyeVsHeadTrackingRatio=80
    Controller Feedback=4294967295
    WideAspectStretchedHUDMode=1
    KeyboardHighlightingMode=dynamic
    FOVScale=1.00000
    AutoFOV=0
    LockCursorToTheWindow=0
    AlwaysShowCursor=0
    [Input]
    InputSourcesSelectorMode=1

  • GreySnakes
    6 posts

    @potlu
    Having spent countless hours trying to improve the performance on Windows 10 to no avail, the only thing I can recommend is trying Windows 11.

    That's the only thing that worked for me flawlessly without needing to adjust anything at all.

    I recommend making a full backup first before trying, or creating a dual boot if you can. (Dual boot with clean Windows 11 install is what I did.)

    I'm curious to see if this resolves the problem for anyone else.

  • Xenoaxle
    2 posts

    Same lag spikes for me on a 1080ti. Turned the settings right down and seems to happed every other few seconds.

    Cant upgrade to Windows 11 as CPU is unsupported.

    Any thoughts on this?

    Valhalla works great on my AMD 4800u (Aya Neo) and used to work really well on my 1080ti.



    Thank you

Suggested Topics