Continue your odyssey

Welcome to discussion

Quick Suggestions

Hello! These new forums are an open beta and we welcome your feedback in this section.
  • EpicJackson95
    5 posts

    @frame1983j I shouldn't have to do that to fix the game. Ubisoft should be able to release a AAA £50 game that works on release without having to jump through hoops to fix. Ive already spent many hours more than i should of trying to fix this game.

  • NuToTz
    6 posts

    @pale_rider_tv yeah it's sad really, very disappointing. I am tech support for a world leading accountancy software and it's very strange that there only real reply is go through troubleshooting steps (generic ones at that) completey acceptable if its a hand full of cases, but this is quite clearly a bigger issue with the file structure or permissions on files. I will be sitting down tonight because i will have hours to kill if i find a fix for it i will be back. Thank god i didn't buy this game outright.

  • beez_trees
    8 posts

    Same as every other post on here that Ubi has failed to acknowledge as an issue on their end. When I attempt to launch the game I get a quick splash screen with the creed symbol followed by an immediate crash. I have tried all the suggested remedies to no avail. Both Ubisoft Connect and my game files were uninstalled and reinstalled on my primary drive. All 9 other games I have downloaded through Ubisoft connect (AC Odyssey) run with no problems.. Hoping there are enough people facing these issues to warrant a quick patch but I am not holding my breathe.

  • HawkSE
    9 posts

    Same here. I've submitted a Support Ticket.

    There was a suggestion that if you're using Microsoft Storage Spaces (Or Pool) for SSDs, this can cause problems. I am not using this, and still cannot get past the splash screen.

  • drdeath12-uk
    7 posts

    @beez_trees same problem been waiting since midnight no patch no word from Ubisoft regarding this

  • NuToTz
    6 posts

    So anyone havung this issue post some things in response to this post please it may help them get it working, rather than specs because we have seen its both amd and nvidia gpu and cpu having the problem, any things like valorant installed on peoples pc? because that has some deep level of permissions. Also what type of AV are people using, im on avg. Also ive seen this mentioned on a few people talking about different drives, is anyone still having the issue with both the launcher and the game on the same drive?

  • Fi_NoAppendx
    3 posts

    Same here. Tried reinstalling, drivers all updated, windows updated, clean booted, verified files, ran as admin, uninstalled and reinstalled uplay, tried booting in safe mode, ... Whatever you can think of I tried. Just immediately crashes. Real shame, I got excited for an AC for the first time in forever, but the hype died down as fast as it got build up.

  • Bennemus
    1 posts

    I had the same issue with attempting to launch the game, and then being stuck at the splash image, without the game launching.

    After going through countless of posts, I figured there's an issue mainly with people who's installed it on an M.2 storage device (which I had as well). I copied the gamefiles to my other SSD (not M.2), uninstalled the game on the uplay launcher, then located the game files I've copied. Then I launched the game and my computer restarted itself for some reason, which was kind of odd. I tried launching the game again after that, and the splash image came up.. waited about 30 seconds to 1 minute, and it launched. Hope this works for you guys as well!

  • Pale_Rider_TV
    20 posts

    @nutotz I have a all AMD build. Ive done all basic trouble shooting. both launcher and game are on the same SSD. ive reverted my GPU drivers and did a full wipe and install with new drivers. booted in safe mode and in between all of these ive tried to open the game. i got nothing

  • UbiKoality
    Ubisoft Support Staff 440 posts

    Hey everyone! I sincerely apologize for the inconvenience and frustration that this problem has caused. As our team is looking further into this, can you please upload your DxDiag file in a case at Afterward, please let me know your case numbers. I would be glad to check over them from there. Thank you!

    Official Response
  • beez_trees
    8 posts

    @ubikoality Case #: 13179152

  • NuToTz
    6 posts

    @pale_rider_tv hmm, do you have valorant installed? I ask because that has bricked peoples pcs and operates at kernal level, might be worth running a SFC scan now to check for violations

  • BFire13
    2 posts

    @ubi-baron So I'm using the storage spaces on my computer and moved the game install from my D to C drive (ubisoft connect is still installed on D:) and it worked. Before I had tried everything that was recommended before. Moving the install to the same drive, uninstalling/reinstalling, disabling afterburner and nothing worked except for that.

  • Fi_NoAppendx
    3 posts

    @ubikoality As soon as I give in the right fields required, I lose the option to submit a case..

  • CagierGlobe1761
    1 posts

    I fixed this by closing MSI afterburner which had a gpu overclock and also closing RIVA statistics tuner. only when closing both did the game launch.

  • SeniiliSika
    8 posts

    @ubikoality I am unable to send support request as the send button is always greyed out. As in not available at this time. Whatever it means

  • The_Unicorn69
    1 posts

    @ubikoality Case #13174326 I have tried literally every fix at this point and nothing works. Feels great to spend $100+ on a screensaver

  • Shyrik408
    1 posts

    @sixpounder85 Dude, i installed it on HDD(second of 2 my HDD and 2 others SSD)), and it worked) (at first i tried install it on SSD, unsuccessfully)

  • MrNebuIa
    1 posts

    Same here I got in at first then the game crashed and now every time I try to launch it I get the splash screen and then the game crashes thanks Ubisoft

  • Jutzukan
    14 posts

    Same issues as everyone. Did all the suggested troubleshooting. Submitted ticket.

Suggested topics

Community details