Welcome to discussions

Quick Suggestions

  • AmiDreAm
    9 posts

    @UBI-SPUD need attention!!!!

  • Ubi-Borealis
    Ubisoft Support Staff 2877 posts
    Best Answer

    Hello there!

    I'm sorry to hear that you're encountering trouble when launching Assassin's Creed: Valhalla, and that the game freezes on the splash screen. This issue was marked as resolved by the development team following TU 1.1.1. Thanks to those who have taken the time to share how they were able to resolve their freeze-on-launch issues in this thread!

    If you are still encountering issues when launching the game, please ensure that you have first tried these basic PC troubleshooting steps, as these help to resolve common issues behind freezing and crashing. Please note that there can be multiple causes behind a crash or freeze, so we would recommend trying all of these steps as a first step.

    Additionally, if you have the game installed on a Microsoft Storage Space Drive, we would recommend moving the game to an alternative ha soft Storage Space Drives, and we recommend installing the game on a hard drive that also has the OS installed. rd drive (ideally the same drive that your OS is installed on). It is important to note that most of our games do not support Microsoft Storage Space Drives, and this can cause problems when launching the game.

    If the issue still persists after trying these steps, please can you open a support ticket so our team can take a closer look at your system files. You can open a support ticket via the Ubisoft Support website or by starting a live chat. When opening a support ticket, please have the following ready to include in your support ticket:

    • An MSinfo and a DxDiag
    • The troubleshooting steps you have already tried
    • If this issue has persisted since installing the game, or if it only started after a specific event (such as a game update or a system update)


    If you purchased the game from the Ubisoft Store and would like to seek a refund, you are also welcome to open a support ticket to submit a refund request. These requests are considered against our digital and physical refund policies on a case-by-case basis. If you do not meet the eligible criteria, we are unable to guarantee that a refund will be granted.

    @Thunderchild_UK - Apologies for the delayed response. Thanks for sharing what troubleshooting steps you have already tried. I'm glad to hear that you've been able to resolve the issue. Thanks for sharing what worked for you!

    @skyhawg - I understand that you've been able to resolve this issue after opening a support ticket. If you're still encountering trouble with crashes/freezes, please don't hesitate to update us so we can take a closer look.

    Thanks! 😊

    Official Response
  • Ubi-Mark.
    Ubisoft Support Staff 996 posts

    @lupi86 Thank you for sharing this!

    Running the application with Administrator rights is always a good thing, as you allow the application to perform changes within your hard drive, such as, creating save games and overwrite the existing ones.

    Official Response
  • pixxle85
    2 posts

    Same issue for me...bump this up and
    @Ubisoft get this fixed please

  • RaptrSquad20
    2 posts

    @amidream my game won’t open either, I’ve pre ordered a digital copy on Xbox One S( current gen) but @Ubisoft aren’t doing anything to fix it

  • Ubi-Swaggins
    Ubisoft Support Staff 348 posts

    I am sorry to hear that you had trouble with the launch of Assassin's Creed Valhalla. Have you had any trouble with this issue since then?

    Official Response
  • Ubi-Swaggins
    Ubisoft Support Staff 348 posts

    Hey folks,

    Are you all still having issues with this or have you been able to launch the game?

    Official Response
  • lokardarkblade
    7 posts

    @crazydonkey88 still nothing on this?

  • AmiDreAm
    9 posts

    Hello. I am facing a problem loading Assassin's Creed VALHALLA game. I pre-ordered it, preloaded the game. At release, the game downloaded somewhere around 600+ MB. patch and I calmly played it for a couple of days. Passed somewhere 3% of the plot. Last night, sometime after 12:00 Moscow time, I launched it again and it just stopped opening. The little initial window with the game logo is loading, and then it just doesn't open. In this case, the game installed nearby (Watch Dog's 3) starts without problems. Assassin's Creed ODYSSEY doesn't work either. It also closes after the initial window (see screenshot). I have the latest video card drivers installed, I tried to check and reinstall the game. I ran it as administrator (both the game and the store), nothing helps. The forum has similar problems for people, even in other earlier games. I beg you to help solve this problem. Thanks a lot in advance!undefined

  • UbiKoality
    Community Manager 440 posts

    Hey everybody! I'm extremely sorry for the delayed response and for the initial inconvenience that this problem may have caused each of you. I fully understand how disappointing it may be to not be able to launch a new game you purchased. Moving forward, please make sure that you have completed all the steps listed in our technical troubleshooting guide! Those steps are quick to complete and have helped other players in similar situations. Then, if those steps do not help, please upload your MSinfo file in a case at support.ubi.com. Our technical team would be more than happy to help get this resolved so that you're able to play the game!

    Official Response
  • UbiKoality
    Community Manager 440 posts

    @aronor Hello there! My apologies for the delayed response. I'm also extremely sorry for any inconvenience that may have been caused by Assassin's Creed Valhalla failing to launch! My first recommendation would be to complete everything listed here. Our technical troubleshooting guide contains some quick and easy steps, such as verifying the game's files, that tend to help resolve various technical problems while also improving game performance. Then, if those steps do not make any improvements, please submit your MSinfo file in a case at support.ubi.com. Our technical team would be more than happy to provide additional assistance for you! Thanks for your patience.

    Official Response
  • UbiKoality
    Community Manager 440 posts

    @strawberrynim Hello! I sincerely apologize for the delayed response. I'm also terribly sorry for any inconvenience and frustration that may have been caused by Assassin's Creed Valhalla failing to launch and perform properly. I understand where you are coming from in the sense that you shouldn't have to worry about problems like these with a new game, but it would be helpful to complete some troubleshooting to get this resolved! My first recommendation would be to complete our technical troubleshooting guide in full. Those steps are quick to complete and should help get you past this splash screen! However, if those steps do not make any improvements, please upload your MSinfo file in a ticket at support.ubi.com. Our team would be more than happy to investigate this further with you and provide more specialized assistance. Thanks for your patience!

    Official Response
  • Ubi-Spud
    Ubisoft Support Staff 700 posts

    @shiftys Hi there! I'm sorry that the game is taking so long to load. Is it on the same SSD as your OS? If so, please perform a clean boot and test again - might be some background apps causing this. If the issue persists, please run through the rest of this guide.

    Official Response
  • bienio123455
    1 posts

    hey guys, try this metod it helped me at the same error in ac origins



  • Medved_Nbg
    18 posts

    And the loading symbol appears in the bottom right corner; Only solution is Alt+F4, but the game's process keeps hanging in background and cannot be killed. Restarting Ubisoft Connect does not help, for then the game does not launch at all, showing only empty "Ubisoft connect" window with splash screen.

  • Ubi-Swaggins
    Ubisoft Support Staff 348 posts

    @seniilisika I am sorry to hear that you have been encountering a splash screen crash.

    Are you still having problems with this? If so, can you check where the game is installed?

    Official Response
  • Lomig_1983
    8 posts

    No news at all from the support team in days... Is there a patch likely to be made about this issue ? Do we have to ask for a refund ?

  • AmiDreAm
    9 posts

    Hello. I am facing a problem loading Assassin's Creed VALHALLA game. I pre-ordered it, preloaded the game. At release, the game downloaded somewhere around 600+ MB. patch and I calmly played it for a couple of days. Passed somewhere 3% of the plot. Last night (11.12.2020), sometime after 12:00 Moscow time, I launched it again and it just stopped opening. The little initial window with the game logo is loading, and then it just doesn't open. In this case, the game installed nearby (Watch Dog's 3) starts without problems. Assassin's Creed ODYSSEY doesn't work either. It also closes after the initial window (see screenshot). I have the latest video card drivers installed, I tried to check and reinstall the game. I ran it as administrator (both the game and the store), nothing helps. The forum has similar problems for people, even in other earlier games. I beg you to help solve this problem. Thanks a lot in advance!
    undefined

  • krvpt.
    63 posts

    @bienio123455 tried this one already, actually you might be able to see my comment on there haha. i just want to be able to start the game this is nuts

  • Clumpybug
    6 posts

    Trying to play AC Valhalla on my PC through Ubisoft Connect. When I try to launch the game, the green splash screen window with the AC logo pops up and stays there on the desktop for about 5 seconds, then disappears, and that's all that happens.

    In the task manager, I can see ACValhalla.exe running, but that disappears when the green AC logo screen disappears.

    Both Ubisoft Connect and AC Valhalla are installed on my C drive, which is a SSD.

    Just wanna play my game.

    Sad day.

  • TheRealGNider
    1 posts

    Hello all,

    I purchased the game earlier today through the Epic Games Launcher, and have also installed Ubisoft Connect. I can't even play the game for some reason. I click play, then it brings up the screen with the logo on it and then stays like that. I've been working on it all day to try and figure what the problem is. All my drivers and stuff should be up to date, and my system more than meets the reqs for the game. Any help would be great!!

    Thanks!

Suggested Topics

Community Details

110
Online
141.3k
Users
24.9k
Topics
129.4k
Posts