Welcome to discussions

Quick Suggestions

  • 0 Likes/1211 Replies/15070 Views
    Aaron-J21321
    2 posts





    undefined

    Can't enter the game, stop at this interface for more than an hour. The integrity of the game has been verified, downloaded from Ubisoft connect, the system is win10 home, GPU nvdia 2080 CPU intel 9800x, i need tech support help me

  • Aaron-J21321
    2 posts

    By the way, I used GeForce experience to scan the game completely, but I couldn't recognize the game. I think the game should have some program problems.

  • krvpt.
    63 posts

    @aaron-j21321 yeah ive had this since the 5th bro.. good luck with having them help you

  • Ubi-Litten
    Ubisoft Support Staff 178 posts

    Sorry to hear you were still unable to get this resolved after completing these troubleshooting steps, if possible could I ask you to contact us directly with your system reports as advised in the FAQs below :

    Generating a DirectX Diagnostic Report

    Generating a Microsoft System Information Report

    Official Response
  • RED-SPIRIT-K
    3 posts

    @il-cirozse none of us have had any luck yet. ive tried everything to fix mine.

  • lupi86
    2 posts

    okay today i get the ubisoft connecting bug, it's stuck ther and the game dont wana load ........

  • knightfire55
    2 posts

    Re: [AC Valhalla wont load past splash screen.](/topic/77083/ac-valhalla-wont-load-past-splash-screen)

    So Ive done alot of things, even all the list of things Ubisoft support sent me to do, But nothing fixed it, UNTIL I moved the entire game folders to my windows drive 😄 , kinda BS, but it worked for me...

  • alexito392
    1 posts

    Same here, actually, it was working for me Thursday to Saturday and then suddenly I was unable to start up the game. I've been looking into the launcher log files and they just let the process die... there are not much to do with the information they print there... My guess is that we will need to wait.

  • UbiKoality
    Community Manager 440 posts

    Hello there! I'm terribly sorry for the delayed reply. I also apologize for the inconvenience that the initial loading screen may have caused as you were trying to play Assassin's Creed Valhalla. If you're still experiencing this at this time, please first start by completing our technical troubleshooting guide in full. Those steps are quick to complete and tend to resolve various technical problems while also improving game performance! Then, please open a case at support.ubi.com to receive further assistance from our technical support team. They would be glad to help! Thanks for your patience.

    Official Response
  • Unit921980
    3 posts

    My problem was being on the Windows Insider Dev Channel.
    I have resolved this for me after trying everything listed here.

    • Updated windows
    • Updated Graphics Drivers (RTX2080)
    • Removed epic games/ubisoft/assasins creed and deleted all the residual files including appdata/local folders.
    • Older version Geforce experience/Newer version of Geforce experience
    • Changed Firewall rules
    • New versions of VCredist(though i have these anyway for Visual Studio development work)
    • Rebuilding Windows media services, adjusting file permissions (admin user etc)


    It turns out that the latest release of Windows Insider changed some memory addresses relevant to the way Ubisoft loader calls Assasins Creed Valhalla, I had to roll back 2 versions of Windows Insider.

    It's under settings -> Recovery -> Go back to the previous version of Windows 10.

    This worked for me. YMMV

  • Mrrodeoman74
    3 posts

    I have tried several work arounds and nothing is working. This is very frustrating. I am able to play Odyssey with no issues. Almost to the point of saying FU and requesting a refund.

  • AmiDreAm
    9 posts

    Hello. I am facing a problem loading Assassin's Creed VALHALLA game. I pre-ordered it, preloaded the game. At release, the game downloaded somewhere around 600+ MB. patch and I calmly played it for a couple of days. Passed somewhere 3% of the plot. Last night, sometime after 12:00 Moscow time, I launched it again and it just stopped opening. The little initial window with the game logo is loading, and then it just doesn't open. In this case, the game installed nearby (Watch Dog's 3) starts without problems. Assassin's Creed ODYSSEY doesn't work either. It also closes after the initial window (see screenshot). I have the latest video card drivers installed, I tried to check and reinstall the game. I ran it as administrator (both the game and the store), nothing helps. The forum has similar problems for people, even in other earlier games. I beg you to help solve this problem. Thanks a lot in advance!undefined

  • NeytiriNytsngr
    1 posts

    After the newest update, which I just finished downloading, the game will no longer start. After hitting play all it does is bring up the small window and stay stuck there. This is a new behavior for me and never happened before this update. Id like to be playing the game I spent 120$ on so please tell me either how to fix this or better yet, please check your updates BEFORE you launch them so they don't cause issues like this. Having an update make a game unplayable is both embarrassing and frankly unprofessional. Bug testing exists for a reason, and myself and other gamers are NOT your bug testers.

  • Aloninor
    94 posts

    @neytirinytsngr
    This is most likely not the standard and the game probably still works for most people. But of course this is crazy annoying. My recommendation would be, instead of venting here, to contact the Ubisoft support, you probably already have. Here I mean a direct support ticket and not the forum. Good luck - fingers crossed that you asap can go a Viking again!

  • onigiri03
    2 posts

    mine just randomly freezes all my game file integrity seems fine, tried increasing my page file as well nothing works

  • Monster-1973
    4 posts

    @neytirinytsngr same my game würk nptjing and i have dp anythink what i can do but nothing and this problem have so many people at release and the do nothing thats upisoft i have many games here but thats is under a alpha version the most alpha versions have not so many problems

  • lupi86
    2 posts

    oka i get a fix for infinity loading on ubisoft connect!!!
    Go to assassins creed valhalla exe file and unchek the administrator. somehow the ubisoft don't like when u vana lauch te game like administrator. this is helped and i can play now 🙂

  • AmiDreAm
    9 posts

    @UBI-SPUD need attention!!!!

  • Ubi-Mark.
    Ubisoft Support Staff 1553 posts

    @lupi86 Thank you for sharing this!

    Running the application with Administrator rights is always a good thing, as you allow the application to perform changes within your hard drive, such as, creating save games and overwrite the existing ones.

    Official Response
  • pixxle85
    2 posts

    Same issue for me...bump this up and
    @Ubisoft get this fixed please

Suggested Topics

Community Details

109
Online
220.3k
Users
37.2k
Topics
184.6k
Posts