Welcome to discussions

Quick Suggestions

  • 0 Likes/1211 Replies/15986 Views
    RaptrSquad20
    2 posts

    @amidream my game won’t open either, I’ve pre ordered a digital copy on Xbox One S( current gen) but @Ubisoft aren’t doing anything to fix it

  • Ubi-Swaggins
    Community Manager 429 posts

    I am sorry to hear that you had trouble with the launch of Assassin's Creed Valhalla. Have you had any trouble with this issue since then?

    Official Response
  • Ubi-Swaggins
    Community Manager 429 posts

    Hey folks,

    Are you all still having issues with this or have you been able to launch the game?

    Official Response
  • lokardarkblade
    7 posts

    @crazydonkey88 still nothing on this?

  • Daleth42
    3 posts

    Ok, I spoke with a support tech, and they had me update a setting in the NVIDIA control panel to use the high-performance NVIDIA processor instead of letting windows determine which processor to use (integrated vs high performance). If you are using a laptop with multiple GPUs, windows may be choosing the integrated one by default. To check (for NVIDIA users), go to NVIDIA Control Panel (available via right clicking on the desktop) and click on "Manage 3D settings", you can either update the global settings to always prefer the high performance one or click the "Program Settings" tab and add Valhalla and tell it to use the high performance processor.

    Note, this worked for my issue and may not be a fix for everyone, but for those who have run out of things to try it might be worth it.

  • Jutzukan
    14 posts

    Same boat since launch. Frustrating AF. As many of us that seem to be reporting this it's not listed as a technical issue in the top pinned post on this sub. Why release a broken game??? Take a cue from CDProjekt and delay until it's worth releasing.

  • RadhikalZ
    1 posts

    I'm having the same or at least a similar issue on my end. It's initial start up is a bit slow, then it goes through the opening fine enough, then when I tried the game - it's slooww as all get up, the graphics keeps spazzing and having flashing bars or random lines then eventually freezes to a black screen where the sounds are still there, but I can't see or do anything. The farthest I've gotten is slightly past when the kid talks to his dad and is ready to go talk to the king, then nothing and black screen.
    I've made sure my system has been all updated, attempted to change the graphics to medium, low, all that jazz and yaah.. nothing. Even uninstalled other games to make sure I had room or they weren't blocking the game from running well.
    I've got a
    Intel(R) Core(TM) i7-9750H CPU @ 2.60GHz  2.59 GHz
    which I thought would be fine - who knows maybe that's the problem

  • arnonie
    5 posts

    same my game just keeps freezing after 2-3 minutes it has been like this since launch not a single response

  • AmiDreAm
    9 posts

    Hello. I am facing a problem loading Assassin's Creed VALHALLA game. I pre-ordered it, preloaded the game. At release, the game downloaded somewhere around 600+ MB. patch and I calmly played it for a couple of days. Passed somewhere 3% of the plot. Last night, sometime after 12:00 Moscow time, I launched it again and it just stopped opening. The little initial window with the game logo is loading, and then it just doesn't open. In this case, the game installed nearby (Watch Dog's 3) starts without problems. Assassin's Creed ODYSSEY doesn't work either. It also closes after the initial window (see screenshot). I have the latest video card drivers installed, I tried to check and reinstall the game. I ran it as administrator (both the game and the store), nothing helps. The forum has similar problems for people, even in other earlier games. I beg you to help solve this problem. Thanks a lot in advance!undefined

  • UbiKoality
    Community Manager 445 posts

    Hey everybody! I'm extremely sorry for the delayed response and for the initial inconvenience that this problem may have caused each of you. I fully understand how disappointing it may be to not be able to launch a new game you purchased. Moving forward, please make sure that you have completed all the steps listed in our technical troubleshooting guide! Those steps are quick to complete and have helped other players in similar situations. Then, if those steps do not help, please upload your MSinfo file in a case at support.ubi.com. Our technical team would be more than happy to help get this resolved so that you're able to play the game!

    Official Response
  • UbiKoality
    Community Manager 445 posts

    @aronor Hello there! My apologies for the delayed response. I'm also extremely sorry for any inconvenience that may have been caused by Assassin's Creed Valhalla failing to launch! My first recommendation would be to complete everything listed here. Our technical troubleshooting guide contains some quick and easy steps, such as verifying the game's files, that tend to help resolve various technical problems while also improving game performance. Then, if those steps do not make any improvements, please submit your MSinfo file in a case at support.ubi.com. Our technical team would be more than happy to provide additional assistance for you! Thanks for your patience.

    Official Response
  • UbiKoality
    Community Manager 445 posts

    @strawberrynim Hello! I sincerely apologize for the delayed response. I'm also terribly sorry for any inconvenience and frustration that may have been caused by Assassin's Creed Valhalla failing to launch and perform properly. I understand where you are coming from in the sense that you shouldn't have to worry about problems like these with a new game, but it would be helpful to complete some troubleshooting to get this resolved! My first recommendation would be to complete our technical troubleshooting guide in full. Those steps are quick to complete and should help get you past this splash screen! However, if those steps do not make any improvements, please upload your MSinfo file in a ticket at support.ubi.com. Our team would be more than happy to investigate this further with you and provide more specialized assistance. Thanks for your patience!

    Official Response
  • Ubi-Spud
    Ubisoft Support Staff 702 posts

    @shiftys Hi there! I'm sorry that the game is taking so long to load. Is it on the same SSD as your OS? If so, please perform a clean boot and test again - might be some background apps causing this. If the issue persists, please run through the rest of this guide.

    Official Response
  • bienio123455
    1 posts

    hey guys, try this metod it helped me at the same error in ac origins



  • gnowitzki
    2 posts

    I was relieved that there was a player with the same symptoms as me.
    Support just asks for Dxdiag and Msinfo and doesn't admit any bugs.

  • topchip35
    1 posts

    Happens on xbox series x aswell don't think its a hardware issue as lots of people are being impacted across all platforms, needs fixing as it makes the game unplayable.

  • Medved_Nbg
    18 posts

    And the loading symbol appears in the bottom right corner; Only solution is Alt+F4, but the game's process keeps hanging in background and cannot be killed. Restarting Ubisoft Connect does not help, for then the game does not launch at all, showing only empty "Ubisoft connect" window with splash screen.

  • Skinfaxe_DK
    5 posts

    @onigiri03 Same for me - freezes every now and again - think it has to do with the adaptive settings during graphic-intense moments/areas. Switching them off seems to help?

  • Ubi-Swaggins
    Community Manager 429 posts

    @seniilisika I am sorry to hear that you have been encountering a splash screen crash.

    Are you still having problems with this? If so, can you check where the game is installed?

    Official Response
  • Lomig_1983
    8 posts

    No news at all from the support team in days... Is there a patch likely to be made about this issue ? Do we have to ask for a refund ?

Suggested Topics