Welcome to discussions

Quick Suggestions

  • trolsopol
    31 posts

    @demonicarcher and don't forget, we've paid money for nothing. I've requested a refund 2 weeks ago and still nothing... 100% the last time i spend money with ubisoft

  • Ubi-Borealis
    Ubisoft Support Staff 3625 posts
    Best Answer

    Hello there!

    I'm sorry to hear that you're encountering trouble when launching Assassin's Creed: Valhalla, and that the game freezes on the splash screen. This issue was marked as resolved by the development team following TU 1.1.1. Thanks to those who have taken the time to share how they were able to resolve their freeze-on-launch issues in this thread!

    If you are still encountering issues when launching the game, please ensure that you have first tried these basic PC troubleshooting steps, as these help to resolve common issues behind freezing and crashing. Please note that there can be multiple causes behind a crash or freeze, so we would recommend trying all of these steps as a first step.

    Additionally, if you have the game installed on a Microsoft Storage Space Drive, we would recommend moving the game to an alternative ha soft Storage Space Drives, and we recommend installing the game on a hard drive that also has the OS installed. rd drive (ideally the same drive that your OS is installed on). It is important to note that most of our games do not support Microsoft Storage Space Drives, and this can cause problems when launching the game.

    If the issue still persists after trying these steps, please can you open a support ticket so our team can take a closer look at your system files. You can open a support ticket via the Ubisoft Support website or by starting a live chat. When opening a support ticket, please have the following ready to include in your support ticket:

    • An MSinfo and a DxDiag
    • The troubleshooting steps you have already tried
    • If this issue has persisted since installing the game, or if it only started after a specific event (such as a game update or a system update)


    If you purchased the game from the Ubisoft Store and would like to seek a refund, you are also welcome to open a support ticket to submit a refund request. These requests are considered against our digital and physical refund policies on a case-by-case basis. If you do not meet the eligible criteria, we are unable to guarantee that a refund will be granted.

    @Thunderchild_UK - Apologies for the delayed response. Thanks for sharing what troubleshooting steps you have already tried. I'm glad to hear that you've been able to resolve the issue. Thanks for sharing what worked for you!

    @skyhawg - I understand that you've been able to resolve this issue after opening a support ticket. If you're still encountering trouble with crashes/freezes, please don't hesitate to update us so we can take a closer look.

    Thanks! 😊

    Official Response
  • carlosj.1982
    4 posts

    @cptulfhednar Some fix??? I have the same problem =(

  • carlosj.1982
    4 posts

    @lemerkur7 Ubi... in ubisupport tell me that steps are the answer but it isn't... so... do you found a fix??

  • MissMDee
    4 posts

    Same for me except I’m on PS4. It freezes every time I try to start the game now. I can’t play at all.

  • snaazex
    2 posts

    Same here for me on a PC.

    Starting the game just ends up in a permanent popup just after launch, then nothing else happens no matter how long I wait. Issue registered with support, no life signs from the company at all. Frustrating to wait this long without being able to use the product you've bought.

  • scottyusceaser1
    34 posts

    ok guys try this..

    Delete 'AcValhalla config setting' in 'Documents - Assassins Creed Valhalla.

    IF you've been using Reforge for mods, make sure it's open before starting the game.

    Then go to your games '.exe' folder and make sure you're not starting it with the 'ACValhalla_Plus' ONLY open it with 'ACValhalla'.

    This worked for me and it doesn't get stuck at the logo screen, and to even make it load faster I deleted some video clips in the 'Video' folder so when it starts it loads straight away... To do this go to 'Video folder' in your games '.exe' and delete

    'ANVIL_Logo'

    'BlackScreen'

    'PC_AMD_RYZEN'

    'Ubisoft Logo'


    Than go to the folder that supports the language you are playing the game in for me its 'en' and inside it has:

    'PC_WarningSaving'

    'Warning Disclaimer'

    'Epilepsy'

    Delete them too... and your good. 🙂

    Hope this helps.

  • Abhi_TheGamer
    7 posts

    Looks like the 1.0.4 patch does nothing for me and still have issue. Same config, Ryzen 7 2700X, GTX 1060 6 GB Version, game is installed in a SSD in exFat file format.

  • HayBai
    4 posts

    Update

    New update came, 1.04. I believe, and again game didn't even start. So new sound/video files was added and had to do hardlinks for those files too & it started to work again.

    Ubi, pls can you fix the issue...?

  • krvpt.
    63 posts

    i am extremely dissapointed in ubisoft, in fact im furious. i bought this game on the 8th of this month excited for it to come out, only to have the game not launch for me and get stuck on the splash screen and just closes.
    i talked to ubi support for 15 DAYS and i've decided that i would wait for the next title update to see if they fix the issue. spoiler alert (they [censored] didn't) so now i have to go without playing assassins creed, a game i paid $60 for and meet all requirements for.
    ubisoft, i WILL be getting my refund because you don't know how to release an unbroken game and obviously dont know how to fix this issue either.
    CPU- RYZEN 7 2700-MEETS REQUIREMENTS
    GPU- RTX 2070 SUPER- MEETS REQUIREMENTS
    RAM-16GB-MEETS REQUIREMENTS
    all drivers updated and windows as well. ubi, you just lost a customer, ill be getting my money back and buying a game worth actually waiting for, cyberpunk 2077.

  • Redlight-
    6 posts

    If you have this bug after the update, Ubisoft add somes sound files, don't forget to move them to your new repertory and make news symbolics links.

  • KubiiTron
    2 posts

    @judgethane01 I still have this problem and new patches doesnt fix

  • KubiiTron
    2 posts

    @bienio123455 I found it few days ago nad it's working but with new patches i have to do it again 😞

  • Pizz4n4t0r
    1 posts

    I'm trying to launch the game, I click play in the ubisoft connect launcher it opens the application but stops doing anything. I've made sure my os and graphics drivers are up to date and that my pc is up to spec but nothing seams to work.undefined

  • carlosj.1982
    4 posts

    @clumpybug any suggestion to fix the problem?? have you fixed it?? Thanks

  • jaanarasanen
    1 posts

    I finally was able to get the game and was excited to start playing but mine keeps crashing also.
    I have a bit of an older PC but I've had lot's of games without issues in the past year and for this I even went the extra mile and got a separate cooling pad to keep the PC cool.
    My specs
    Processor Intel (R) Core(TM) i5-7300HQ CPU @ 2.50GHz
    RAM 8.00GB

    I also had to download an update for it but looks like it did nothing to help fix the issue.
    I can't get anywhere from the first black screen with epilepsy warning.

  • ScorpionDK27
    14 posts
  • Ubi-Baron
    Ubisoft Support Staff 788 posts

    @carlosj-1982 We would advise continuing to speak with the Support Team, they should be able to look into that further for you.

    Do you have a Case Id for you contact?

    Official Response
  • PrimalStrike65
    11 posts

    @UBISOFT

    I was wondering WHEN is the game going to be fixed so that those of us that STILL have the splash screen problem can play it??? I mean it’s REALLY important to keep bringing out those new packs so you can make all the dollars you can as opposed to actually fixing any issues that the customer may still be having after the WORTHLESS update (1.04) patch! I’ve patiently (for the most part...lol) waited (almost) 2 weeks now (checking the game sometimes 3-4 times a day) to see if it’s fixed or not. We’ve not even gotten any kind of reason as to WHY the splash screen issue wasn’t even addressed in patch 1.04 (and yes, I actually read the patch notes).
    So, again, I’d like to know when your going to let me play my $120+ Game???
    And before you tell me to do this that and the other thing, try going back and reading my first post!!! I’ve done everything you would suggest to the letter. So, short of begging, PLEASE FIX THE DARN GAME!!!! (lol)

  • arnonie
    5 posts

    @gnowitzki they dont even respond to the messages

  • R6.Shadow
    1 posts

    hello all,
    i just recently bought valhalla and every time i try launching the game it refuses to launch. i tried uninstalling it and reinstalling along with verifying the files and nothing will work.

Suggested Topics

Community Details

51
Online
193.2k
Users
32.6k
Topics
163.1k
Posts