ubisoft discussions

quick-suggestions

  • locked topic_solved [RESOLVED] [PC] After launching the game, it freezes on the splash screen | POST HERE

    0 likes/1212 replies/22993 views
    Redlight-
    ubisoft:x-posts, 6

    If you have this bug after the update, Ubisoft add somes sound files, don't forget to move them to your new repertory and make news symbolics links.

  • KubiiTron
    ubisoft:x-posts, 2

    @judgethane01 I still have this problem and new patches doesnt fix

  • KubiiTron
    ubisoft:x-posts, 2

    @bienio123455 I found it few days ago nad it's working but with new patches i have to do it again 😞

  • Pizz4n4t0r
    ubisoft:x-posts, 1

    I'm trying to launch the game, I click play in the ubisoft connect launcher it opens the application but stops doing anything. I've made sure my os and graphics drivers are up to date and that my pc is up to spec but nothing seams to work.undefined

  • carlosj.1982
    ubisoft:x-posts, 4

    @clumpybug any suggestion to fix the problem?? have you fixed it?? Thanks

  • jaanarasanen
    ubisoft:x-posts, 1

    I finally was able to get the game and was excited to start playing but mine keeps crashing also.
    I have a bit of an older PC but I've had lot's of games without issues in the past year and for this I even went the extra mile and got a separate cooling pad to keep the PC cool.
    My specs
    Processor Intel (R) Core(TM) i5-7300HQ CPU @ 2.50GHz
    RAM 8.00GB

    I also had to download an update for it but looks like it did nothing to help fix the issue.
    I can't get anywhere from the first black screen with epilepsy warning.

  • ScorpionDK27
    ubisoft:x-posts, 14
  • Ubi-Baron
    Ubisoft Support Staff ubisoft:x-posts, 798

    @carlosj-1982 We would advise continuing to speak with the Support Team, they should be able to look into that further for you.

    Do you have a Case Id for you contact?

    official-response
  • PrimalStrike65
    ubisoft:x-posts, 11

    @UBISOFT

    I was wondering WHEN is the game going to be fixed so that those of us that STILL have the splash screen problem can play it??? I mean it’s REALLY important to keep bringing out those new packs so you can make all the dollars you can as opposed to actually fixing any issues that the customer may still be having after the WORTHLESS update (1.04) patch! I’ve patiently (for the most part...lol) waited (almost) 2 weeks now (checking the game sometimes 3-4 times a day) to see if it’s fixed or not. We’ve not even gotten any kind of reason as to WHY the splash screen issue wasn’t even addressed in patch 1.04 (and yes, I actually read the patch notes).
    So, again, I’d like to know when your going to let me play my $120+ Game???
    And before you tell me to do this that and the other thing, try going back and reading my first post!!! I’ve done everything you would suggest to the letter. So, short of begging, PLEASE FIX THE DARN GAME!!!! (lol)

  • arnonie
    ubisoft:x-posts, 5

    @gnowitzki they dont even respond to the messages

  • R6.Shadow
    ubisoft:x-posts, 1

    hello all,
    i just recently bought valhalla and every time i try launching the game it refuses to launch. i tried uninstalling it and reinstalling along with verifying the files and nothing will work.

  • crusaderofblood
    ubisoft:x-posts, 5

    @r6-shadow i still haven't been able to even launch the game since they released it on my pc and support won't get back to me.

  • Ubi-Baron
    Ubisoft Support Staff ubisoft:x-posts, 798

    @r6-shadow
    @crusaderofblood We're sorry to hear that's been occurring.

    Do you get to the Splash Screen and then get stuck or does it not open anything at all?

    Do you meet the minimum requirements to run the game listed here?

    We would also advise you to run through the full steps in our troubleshooting guide here.

    official-response
  • snaazex
    ubisoft:x-posts, 2

    @crusaderofblood

    Hi.

    There are quite a few of us who has the exact same problem. I've been waiting since release, done all the support steps in the link above, registered a ticket, waited but nothing so far.

    I have no solution to offer I'm afraid....

  • Miree23
    ubisoft:x-posts, 1

    I know it has been posted already, with no actual help other than, "check these steps!".
    I have checked all steps, used the troubleshoot guide, downloaded drivers, downloaded Driver Easy, nothing is working at all.
    I either don't load in past the initial loading screen with the assassins creed logo on it, or, I get past that and get to the games main loading screen, where everything goes black and I have to use task manager to get out of it.

  • crusaderofblood
    ubisoft:x-posts, 5

    @ubi-baron i have done everything and they told me a response would be received in 24-48 hours and since then nothing.

  • GERGO11224
    ubisoft:x-posts, 1

    Idk if you've fixed it ,but if nothing works try to use an older GPU driver. The game said i should update it, i did and then it stopped working. Tried everything , nothing fixed it. I just went back to the previous version of Radeon softvare and now it works again. Might work with Nvidia aswell.
    And after u do it, you need to go into AC Valhalla/Suppor/Software/VCRedist/ and download/repair that file. If it says error write the name of it in widows search and delete it, than try again.
    After this it works for me.

  • Breakabletie
    ubisoft:x-posts, 6

    i just bought AC valhalla and downloaded it and am very excited to play but when I click the desktop icon or 'play' in the uplay launcher i see the AC logo and it never starts like it freezes. i have reinstalled it, no change. I have internet connection. I even double checked that unbisoft has taken my money so i know that i payed for it. Any ideas that might help other wise I will have to refund it.

  • tpme06
    ubisoft:x-posts, 1

    I'm having the same issue after doing an update tonight. Had been playing previous nights.

  • Breakabletie
    ubisoft:x-posts, 6

    i installed the latest drivers for my graphics card. restarted my computer several times and even let it sit and 'load' for 20+ min.

Suggested Topics