Welcome to discussions

Quick Suggestions

  • R6.Shadow
    1 posts

    hello all,
    i just recently bought valhalla and every time i try launching the game it refuses to launch. i tried uninstalling it and reinstalling along with verifying the files and nothing will work.

  • Ubi-Borealis
    Ubisoft Support Staff 3616 posts
    Best Answer

    Hello there!

    I'm sorry to hear that you're encountering trouble when launching Assassin's Creed: Valhalla, and that the game freezes on the splash screen. This issue was marked as resolved by the development team following TU 1.1.1. Thanks to those who have taken the time to share how they were able to resolve their freeze-on-launch issues in this thread!

    If you are still encountering issues when launching the game, please ensure that you have first tried these basic PC troubleshooting steps, as these help to resolve common issues behind freezing and crashing. Please note that there can be multiple causes behind a crash or freeze, so we would recommend trying all of these steps as a first step.

    Additionally, if you have the game installed on a Microsoft Storage Space Drive, we would recommend moving the game to an alternative ha soft Storage Space Drives, and we recommend installing the game on a hard drive that also has the OS installed. rd drive (ideally the same drive that your OS is installed on). It is important to note that most of our games do not support Microsoft Storage Space Drives, and this can cause problems when launching the game.

    If the issue still persists after trying these steps, please can you open a support ticket so our team can take a closer look at your system files. You can open a support ticket via the Ubisoft Support website or by starting a live chat. When opening a support ticket, please have the following ready to include in your support ticket:

    • An MSinfo and a DxDiag
    • The troubleshooting steps you have already tried
    • If this issue has persisted since installing the game, or if it only started after a specific event (such as a game update or a system update)

    If you purchased the game from the Ubisoft Store and would like to seek a refund, you are also welcome to open a support ticket to submit a refund request. These requests are considered against our digital and physical refund policies on a case-by-case basis. If you do not meet the eligible criteria, we are unable to guarantee that a refund will be granted.

    @Thunderchild_UK - Apologies for the delayed response. Thanks for sharing what troubleshooting steps you have already tried. I'm glad to hear that you've been able to resolve the issue. Thanks for sharing what worked for you!

    @skyhawg - I understand that you've been able to resolve this issue after opening a support ticket. If you're still encountering trouble with crashes/freezes, please don't hesitate to update us so we can take a closer look.

    Thanks! 😊

    Official Response
  • crusaderofblood
    5 posts

    @r6-shadow i still haven't been able to even launch the game since they released it on my pc and support won't get back to me.

  • Ubi-Baron
    Ubisoft Support Staff 788 posts

    @crusaderofblood We're sorry to hear that's been occurring.

    Do you get to the Splash Screen and then get stuck or does it not open anything at all?

    Do you meet the minimum requirements to run the game listed here?

    We would also advise you to run through the full steps in our troubleshooting guide here.

    Official Response
  • snaazex
    2 posts



    There are quite a few of us who has the exact same problem. I've been waiting since release, done all the support steps in the link above, registered a ticket, waited but nothing so far.

    I have no solution to offer I'm afraid....

  • Miree23
    1 posts

    I know it has been posted already, with no actual help other than, "check these steps!".
    I have checked all steps, used the troubleshoot guide, downloaded drivers, downloaded Driver Easy, nothing is working at all.
    I either don't load in past the initial loading screen with the assassins creed logo on it, or, I get past that and get to the games main loading screen, where everything goes black and I have to use task manager to get out of it.

  • crusaderofblood
    5 posts

    @ubi-baron i have done everything and they told me a response would be received in 24-48 hours and since then nothing.

  • GERGO11224
    1 posts

    Idk if you've fixed it ,but if nothing works try to use an older GPU driver. The game said i should update it, i did and then it stopped working. Tried everything , nothing fixed it. I just went back to the previous version of Radeon softvare and now it works again. Might work with Nvidia aswell.
    And after u do it, you need to go into AC Valhalla/Suppor/Software/VCRedist/ and download/repair that file. If it says error write the name of it in widows search and delete it, than try again.
    After this it works for me.

  • Breakabletie
    6 posts

    i just bought AC valhalla and downloaded it and am very excited to play but when I click the desktop icon or 'play' in the uplay launcher i see the AC logo and it never starts like it freezes. i have reinstalled it, no change. I have internet connection. I even double checked that unbisoft has taken my money so i know that i payed for it. Any ideas that might help other wise I will have to refund it.

  • tpme06
    1 posts

    I'm having the same issue after doing an update tonight. Had been playing previous nights.

  • Breakabletie
    6 posts

    i installed the latest drivers for my graphics card. restarted my computer several times and even let it sit and 'load' for 20+ min.

  • UbiKoality
    Community Manager 440 posts

    @primalstrike65 Hello there. I sincerely apologize for the inconvenience and frustration that has been caused by this problem in Assassin's Creed Valhalla. Your disappointment is completely understandable considering you have not been able to play a game you spent money on. I would feel the exact same way in your shoes! With that being said, have you uploaded your MSinfo and DxDiag files in a case at support.ubi.com? If not, I would highly suggest doing so. I did look over your former posts, but did not see a case number. Please reply back with your ticket reference number once it has been created. Thank you so much!

    Official Response
  • PrimalStrike65
    11 posts

    @ubikoality The problems I’m having are on the XB1S not PC.

  • PrimalStrike65
    11 posts

    @ubikoality I forgot to mention I cannot submit a ‘ticket’ through the game (XB1S) because it freezes (the cursor will not move) once it gets to the ‘Continue’ screen.
    The only thing I can do is push the ‘X’ button to close the game. You can however look for my original post regarding this matter. The post name is “Can’t play at all now...” (posted Nov. 22, 2020, 10:46PM). I have since I posted original post uninstalled ACV again with no effect.
    Thank you for your reply and any further help in getting this great game working for me.

  • RedIndianRobin
    186 posts

    @primalstrike65 Lmao to the support guy. I feel sorry for you because Ubisoft are notorious to never fix issues. Their last patch 1.0.4 didn't had half the fixes they claimed in the patch notes.

  • krvpt.
    63 posts

    i have the splash screen issue and every work around doesn't work for me. i noticed ubisoft put the issue into the "known issues" post, and that it will be addressed in a future update, but when? how long do i have to wait to play a game that i paid $60 for? some people even spent more and have the same problem! its been 21 days and i'm starting to get REALLY annoyed.

  • Borb98
    6 posts

    @krvpt Hello, if you did not try the Ubi support i recommend to do so the will send you some steps to follow. It helped me with crashes. Try re-installing Microsoft Visual Studio C++ redistributables (2010, 2012, 2013, 2015; and IF and only IF your windows Build is greater than or equal to 18362 - install Microsoft Visual Studio C++ 2015/2017/2019 Bundle) After this hit win update that will download .NET and that should do it.

  • Ubi-Baron
    Ubisoft Support Staff 788 posts

    At what point are you getting stuck? Is it at the Splash Screen? Do you get an errors?

    Official Response
  • crusaderofblood
    5 posts
    • @ubi-baron splash screen here is my case number as well 13180189

  • AmiDreAm
    9 posts

    that is big problem for many people. case № 13326448
    need patch!!!

  • krvpt.
    63 posts

    @borb98 ive done that already, doesn’t fix it for me.

Suggested Topics

Community Details