Welcome to discussions

Quick Suggestions

  • 0 Likes/1211 Replies/15930 Views
    Lathby
    5 posts

    @krvpt at least we've got cyberpunk soon 😕

  • krvpt.
    63 posts

    @lathby haha yep! ubisoft really dropped the ball with this one, ill get to assassins creed once i finish my 3 playthroughs of cyberpunk

  • Exaudio
    19 posts

    A bunch of us still waiting to get past the splash screen. A clean install of windows fixed the problem for most of the users that tried everything else. I am not doing all that job just to play the game. Cyberpunk to the rescue soon

  • Breakabletie
    6 posts

    same here i try to launch the game but it freezes on the launch screen i have submitted a support cases and they told me to disable all of my starting apps and then go 1 by 1 turning them on to find what is causing the issue but i tried to launch the game with no starting apps enabled and it still does not work

    i bought AC valhalla through the ubisoft store

  • DigMeaHole1
    1 posts

    You just can't make this crap up! I couldn't get to game past the splash screen and its installed on 😄 drive where os is. Tried all internet fixes, none worked. Guess what did? moving it to another spare drive d::. LOL! they are that dumb!! Hope this helps!

  • ODALLO
    1 posts

    Cleard Ubi soft cache

    I played the game for almost 9 hours, after that the game not working what so ever I have tried everything, even I formatted the laptop and re-install the game and still I get the same error "Oh no, it crashed!"

    Is my laptop too old to paly the game ?

    Asus ROG Strix GL703GS
    Processor: Intel(R) Core(TM) i7-8750H CPU @ 2.20GHz 2.21 GHz
    NVIDIA GeForce GTX 1070
    RAM: 16.0 GM
    System type: 64-bit operating system, x64-based processor
    Windows 10 Home Single Language

  • arnonie
    5 posts

    @breakabletie they havent told me anything i have the game since launch and they didnt respond then still dont now

  • Breakabletie
    6 posts

    @arnonie i submitted a ticket and they are currently responding to me but i have had 4 different people respond and of all the instructions they have given me (update windows/graphics drivers, delete temp files, disable antivirus & start up apps, and uninstall/reinstall Microsoft visual studio c++ redistributables(several things). and of all these things (and they asked me to do some of these things several times) have not worked. after every step they give me i try to open my game but the valhalla launcher freezes as soon as it appears on screen

    i feel like i am getting nowhere with the support team and am going in circles. at this point i just want my money back because this is ridiculous

    also because i have 'launched' the game from the ubisoft connect i cant request a refund from my end.... i am posting a message on my support case notifying ubisoft of this forum page and the lack of support to those who have posted here. i am also requesting that i get someone with the authority to grant me my refund

  • Plan3tCrackr
    46 posts

    @jaanarasanen I had a similar problem when I initially installed the game on the drive that contains all my other Ubisoft games, including Odyssey. One or maybe all of the following steps got the game to finally launch for me, I am playing with the Ubisoft+ subscription service and did not outright purchase just the lone game (this is my first experience with both Ubisoft Connect that replaced UPlay and the Ubisoft+ subscription service):

    My PC has 5 drives, boot/OS NVME(SSD), 2 SSDs and 2 HDDs. My fix to get to the actual start screen to access options, benchmark and new game and finally play the game was to uninstall and reinstall Ubisoft Connect, install the game on the C : OS boot drive in the default Ubisoft Connect location while also renaming the game's folder from "Asassin's Creed Valhalla" to "ACV" as some users claim the apostrophe can cause problems, not sure if true. Also, I am in online mode, not offline, as playing Ubisoft+ version of games requires constant online connection. I am using Ryzen 2700X CPU and 5700 XT Nitro+ GPU and get intermittent game freezes requiring a force close of game using task manager but those can occur anywhere from 5min to 3+ hours of game time and seem to occur on not just PC but other systems too; freezes beat not fully launching.

    Pic of install location and folder rename:
    undefined

  • Exaudio
    19 posts

    I actually got the game working now after trying everything stated on this forum and else where, and the fix is not as frustrating as a clean boot of win 10.
    I downloaded the "Windows USB/DVD Download Tool" and choose to reinstall win 10 but KEEP personal files and apps. It took about 20 min to reinstall and everything was as before after the install with all my apps etc.
    And now the game starts !!!!!!!! Hallelujah

  • oGhosti
    3 posts

    Is this still not fixed?! I've been taking a break for weeks now. I've done literally every thing I can find to maybe fix the game, but no.
    I played it perfectly fine for like 70hrs or something like that, then they just had to FORCE an update on this game and now I can't get past the initial splash screen w/ the AC logo.

    This is beyond ridiculous. It's nothing more than a $60 virtual paperweight at this point.
    I'm not buying another Ubisoft game after this, that's for sure. Idc how good the game is, if I can't play it and there's 0 support then I'm out.

    All I've seen them do is copy/paste the same stupid "troubleshooting steps" bull****. That NEVER works for any game.
    I'm really tired of the lifeless support these companies give when it comes to them being incompetent.

    "○ Reinstall the game.
    ○ Verify files.
    ○ Shut off programs that literally will never cause issues with games launching, ever. (Synapse, SSE, etc.)
    ○ etc, etc."

    Also, my rig is good. I can run it on high settings no problem, it's not my PC; nor the other thousands of people having the same exact issue.
    So dumb. /rant over.

  • Exaudio
    19 posts

    I actually got the game working now after trying everything stated on this forum and else where, and the fix is not as frustrating as a clean boot of win 10.
    I downloaded the "Windows USB/DVD Download Tool" and choose to reinstall win 10 but KEEP personal files and apps. It took about 20 min to reinstall and everything was as before after the install with all my apps etc.
    And now the game starts !!!!!!!! Hallelujah

  • ALHITCH87
    19 posts

    @drdeath12-uk Its been weeks for me with this issue now and still no fix in sight

  • krvpt.
    63 posts

    @alhitch87 its been about a month for me

  • oGhosti
    3 posts

    @exaudio Yeah, I'm not resetting my PC again just because Ubisoft can't fix it themselves. Thanks though.

  • Mo-Lest
    1 posts

    Game stopping after gaming logos play, turns out all I need to do was plug my HDMI cord straight into the graphics card port

  • Ubi-Baron
    Ubisoft Support Staff 789 posts

    @mo-lest Thank you for reporting this to us, glad to hear you were able to get around that.

    Just to confirm, if you have the HDMI plugged into the motherboard, it would not be using your Graphics card rather it would use the onboard one with the Processer which is much weaker.

    Official Response
  • oGhosti
    3 posts

    ○ I've tried reinstalling from Z Drive to C drive.
    ○ Updated my Nvidia Drivers to the latest.
    ○ Verified game files multiple times on all platforms.
    ○ Uninstalled Ubisoft Connect.
    ○ Deleted the Registry files for Valhalla and Ubisoft Connect.
    ○ No background applications are the issue.
    ○ OS is up to date.

    My hardware is not the issue.
    I ran at 80+ FPS constant on High settings, no stutters, no serious issues. Minus the tons of bugs in this game of course...

    I played the game for 50+ hours until an update dropped around Nov. I haven't played the game for weeks now, I've tried everything. I am NOT resetting my PC to fix something Ubisoft should be capable of fixing.

    Tons of players are experiencing this issue, and that's the only consistent fix the community has found.
    If anyone has any other ideas, I'd greatly appreciate it. I've looked everywhere, so maybe I missed something.
    I really just want to play this to pass the time for CP2077 at this point, I was loving this game but this is ridiculous that it's been unplayable for weeks now.








    Guess I'll wait for the copy/paste reply from Ubisoft Support.

  • TheDefiled777
    1 posts

    My game won't load past the splash screen, it just gets stuck with the small rectangle. I have verified files, redownloaded and installed the game, restarted my desktop, done a fresh install of Connect and put it onto the same SSD as my game.

    I have tried other games on connect and my Div2 loads up just fine and so do any other games from Ubi+, so this seems to be isolated directly to ACV.

    If anyone has any suggestions or come across this error before please help!

  • s7101
    1 posts

    @bienio123455 This method does NOT work. It will get you into the game, but then it will be stuck at the UbiSoft logo.

    I am also facing this, with AC beeing installed on a NVMe SSD. However I was able to solve this, by moving the installation to my 😄 drive (which is a SATA SSD), and then selecting the installation on 😄 within the ubisoft launcher. After that, it launches without issues.

    Thank you @Ubi-Spud for no help whatsoever for a newly launched AAA-full price title with the same issues already known in at least AC unity.

Suggested Topics