Welcome to discussions

Quick Suggestions

  • 0 Likes/1212 Replies/16685 Views
    8 posts

    @acdcwrocker Hey! Thanks for clarifying, and thank you @Redlight for providing a possible solution! I'm curious, when you launch the game after completing this setup, what is on the screen? And do you launch from the folder as administrator, or do you just press play in the Ubisoft client? I just get the Ubisoft connect, with the rainbow colors as a background. No sign of the AC logo if I only press "Play".

  • Dx2.LFT
    38 posts

    even re-downloaded game and re-installed on same drive where is uplay/ubisoft connect and still stuck in small screen of valhalla logo

  • Max-_-33
    13 posts

    i can not see pick link sorce

  • kardeon77
    5 posts

    Same problem here. 'My game get's stuck on the splash art screen which pops up when the game tries to load'.
    I have tried everything but i have not found a solution.
    All my assassin creed games launch correctly. Only Valhalla crashs

  • kardeon77
    5 posts

    @captain_kayn AMD or Nvidia gpu ?
    I have AMD with the last drivers 20.11.1

  • HayBai
    8 posts

    @Acdcwrocker & @Redlight

    Thank you, this guide fixed the game!

    Ubisoft: Get your freaking games working at launches (Didn't even start..). I'm not specially good at playing/modifying/making hardlinks etc. for files... Its embarrassing that you haven't made any note for people how/when this problem would be fixed by update or even publishing official how-to-fix guide.

    Luckily we have good people in community that knows how to tweak stuff & share the knowledge!

  • Captain_Kayn
    3 posts


    Nvidia GPU

    Also with the latest update

  • ManMakingSteak
    1 posts

    Idk why, but I cant start the game. If I open the new Uplay-things and press play I wait for a bit until I get the splash-art and then a black and white screen for about five seconds until I the game closes by itself and the button of play goes back to normal so I can redo this over and over and over again.

    I've tried:
    deleting and installing new
    Changing from HDD to SSD
    Running with administrative-rights
    running via the .exe
    Checking the files
    Deactivating anti-virus for a bit
    Updating software of graphicscard

    Nothing helped. Still get the same result. Help would be greatly appreciated.

  • BlazingZook
    4 posts

    Same issue. I've contact support and I'll let you know if I'm able to get it working

  • kardeon77
    5 posts

    same here. i have tried everything and still .....

  • Spcy.LTDD
    2 posts

    Same here. tried everything.

    • downgrade nvidia drivers,
    • reinstall ubisoft connect
    • and the game.

    Still same problem... 97 Mo freeze in task manager

  • S-T-R-l-K-E-R
    6 posts

    there was a fix posted in one of the threads im gonna try it

  • GoennungsBoi
    1 posts

    Same issue by me...

  • Spcy.LTDD
    2 posts

    Thank you man for the tip ! that's working really good.

    Ubibug : take my money and please do something to improve some skills.

  • Max-_-33
    13 posts

    i did this and still did not work please help i did step by step and read over it 3 time and checked 4 times to see if i did it right

  • S-T-R-l-K-E-R
    6 posts

    @acdcwrocker whats the diff between junction and symbolic link?
    so do i junction each item in the vid folder? and symbolic link the PC folder in the sound?

  • troykt76
    4 posts

    we should not have to do this. Its should work. How is it that so many of us have this problem and the only fix is an exercise in intermediate windows skills. Also you cant even put in a customer service ticket.

  • fraMe1983j
    8 posts

    same Problem - waited now 2h lol ^ nothing happens

  • jkcrazy2000
    5 posts

    i manage to get past the first bit of diologue where the seer is talking, then i have been stuck in the loading screen for the start of the prologue for 4 hours and it has not worked?

  • M1nDTr1cK2020
    21 posts

    The procedure entry point_uncaught_exceptions could not be located in the dynamic link library api-ms-win-crt-private-l1-1-0.dll. [censored]?!

Suggested Topics