Welcome to discussions

Quick Suggestions

  • oqzhnylmz
    4 posts

    @raptrsquad20 that's a tragedy .I verified the game , deleted and download it again but doesn't work .

  • oqzhnylmz
    4 posts

    @oqzhnylmz I was download game different disk.I am trying now Download C :disk .

    İf it works , i will share information again

  • emmaj95
    66 posts

    @ubi-raziel I just went through that article you linked and the only thing I had not tried was the "disabling background apps" step, which I just tried. Still crashing on the splash screen 😞

  • dalton0012369
    1 posts

    i’ve had this same issue but actually have made it to England now in my campaign but it crashed at one point and continue to do so in the title screen once again. uninstalled finally and when the game was able to be played, it loaded up perfect 3 times in a row now bugs without any crashing just couldn’t continue bc of progressing to England. now it continues to crash again without letting me play.

  • Andrepisa89
    9 posts

    same issue in Italy

  • emmaj95
    66 posts

    @emmaj95

    Replying to boost this post and to add some information. My case number is 13182165 and I have been trying to keep it updated with the things I have tried. Since creating this post, I have:

    • Tried disabling background apps
    • Deleted registry files before reinstalling
    • Checked windows defender settings
    • Completely reinstalled nvidia drivers
    • Installed a brand new SSD and reinstalled there
    • Updated CPU drivers just in case?


    I've pretty much had this forum up for four days straight, refreshing and trying every suggestion that comes up, and nothing has fixed it. Every time I click "play" in Ubi Connect or try to run the game directly from the .exe, it gets to the splash screen, and almost immediately gives me an "oh no, it crashed". Any and all guidance is super appreciated.

  • Ubi-Raziel
    Ubisoft Support Staff 197 posts

    @jsjordache1

    Hello! I'm sorry to read you're facing a crash issue, I will do my best to help.

    We are of course listening to our players; our support platforms are currently extremely busy however we are doing everything we can to answer everyone.

    Can you please describe your issue in more detail?

    • Do you get an error message?
    • Are you stuck on the splash screen?
    • What troubleshooting steps have you tried?


    In the meantime, this support article may help.

    All the best!

    Official Response
  • assassin4EVERS
    4 posts

    @ubi-ginge I have uninstalled and reinstalled drivers and this has gotten me only to the first screen with text
    (I have i7 core and a GTX 1660 Ti)

  • DankPurpbudX420
    1 posts

    played 1 day then i got a crash and not the game won't open to the main menu starts to then crashes

  • MrFactorX
    2 posts

    Update:

    @ryanhowls @emmaj95

    I was able to contact support for a refund and they actually took care me after explaining the situation for a full refund to my credit card used, all within an hour. I am still interested in playing the game. I may try back in 6 months or so.
    Good luck guys.

  • assassin4EVERS
    4 posts

    @ubi-ginge should it be using GPU on start up? looking at task manager, the game is running at 12-13% CPU and 0 GPU. This may be an error on my system if this is the case...

  • Andrepisa89
    9 posts

    @mrgausser

    So the vhd must be in bootcamp? I also play with bootcamp. I try

  • Ubi-Spud
    Ubisoft Support Staff 699 posts

    Hey there, we are still looking into this but have identified that it can happen due to the game being installed on a Microsoft Storage Space Device. Please see this FAQ to resolve. If it isn't on one of these drives, please go through this guide. Thanks for your patience!

    Official Response
  • AdamMayhem
    1 posts

    @vihu123 The solution to the problem is to update Windows to the latest version

  • Ubi-Spud
    Ubisoft Support Staff 699 posts

    Hey folks, we're looking into this at the moment, however some have gotten around this by installing the game on the same drive as their OS, and disabling MSI Afterburner if installed. Thank you for your patience!

    Official Response
  • ScorpionDK27
    14 posts

    @ubi-raziel i dont get an error message im just stuck at the splash screen and when i look in the task manager the game does nothing. i tried every troubleshooting step and reinstalled the game several times but nothing works

  • ScorpionDK27
    14 posts

    @ubi-spud will there be an update or a patch for this issue because its unlikely that thousands of players have problems with their pc

  • ScorpionDK27
    14 posts

    @adammayhem i did it but it still doesnt work

  • narot23
    7 posts

    @crazydonkey88 Simply go to NVIDIA's website, download the prior driver (it will show on the list), then run the installer, select Custom Installation, tick Clean Installation, and you should be good to go. One caveat, it will remove any custom settings you've made in NVIDIA Control Panel or GeForce Experience.

  • narot23
    7 posts

    @narot23 EDIT AND NOTE: I was able to resolve the issue by reverting to NVIDIA Driver 457.09... I'm not sure why but the "Game Ready" driver was causing the issue on my PC.

Suggested Topics

Community Details

114
Online
139.7k
Users
24.6k
Topics
127.4k
Posts