Welcome to discussions

Quick Suggestions

  • GazdaStajp
    2 posts

    @JabukeGrada Well this did it for me, i thank you very much sir on this solution.

  • Ubi-Borealis
    Ubisoft Support Staff 3529 posts
    Best Answer

    Hello there!

    I'm sorry to hear that you're encountering trouble when launching Assassin's Creed: Valhalla, and that the game freezes on the splash screen. This issue was marked as resolved by the development team following TU 1.1.1. Thanks to those who have taken the time to share how they were able to resolve their freeze-on-launch issues in this thread!

    If you are still encountering issues when launching the game, please ensure that you have first tried these basic PC troubleshooting steps, as these help to resolve common issues behind freezing and crashing. Please note that there can be multiple causes behind a crash or freeze, so we would recommend trying all of these steps as a first step.

    Additionally, if you have the game installed on a Microsoft Storage Space Drive, we would recommend moving the game to an alternative ha soft Storage Space Drives, and we recommend installing the game on a hard drive that also has the OS installed. rd drive (ideally the same drive that your OS is installed on). It is important to note that most of our games do not support Microsoft Storage Space Drives, and this can cause problems when launching the game.

    If the issue still persists after trying these steps, please can you open a support ticket so our team can take a closer look at your system files. You can open a support ticket via the Ubisoft Support website or by starting a live chat. When opening a support ticket, please have the following ready to include in your support ticket:

    • An MSinfo and a DxDiag
    • The troubleshooting steps you have already tried
    • If this issue has persisted since installing the game, or if it only started after a specific event (such as a game update or a system update)


    If you purchased the game from the Ubisoft Store and would like to seek a refund, you are also welcome to open a support ticket to submit a refund request. These requests are considered against our digital and physical refund policies on a case-by-case basis. If you do not meet the eligible criteria, we are unable to guarantee that a refund will be granted.

    @Thunderchild_UK - Apologies for the delayed response. Thanks for sharing what troubleshooting steps you have already tried. I'm glad to hear that you've been able to resolve the issue. Thanks for sharing what worked for you!

    @skyhawg - I understand that you've been able to resolve this issue after opening a support ticket. If you're still encountering trouble with crashes/freezes, please don't hesitate to update us so we can take a closer look.

    Thanks! 😊

    Official Response
  • Mirkostar236
    1 posts

    @Acdcwrocker
    i cant do a junction link with the files from the videos folder

  • ShenoXDfug
    15 posts

    verified the game files, reinstalled the game, run as administrator, disabled anti cheat, reinstalled supporting software included in de AC folder but nothing helped so far.
    I only have one hard drive C : where also Ubisoft is installed. I also figured out the game is not even trying to start. In the task manager my gpu and ram is not even going 1% up while stucking in the splash screen.

  • franzbertbua
    1 posts

    My game on my PC is not starting.
    I have the Day-One-Patch, my Windows 10 is up to date and I also have the newest version of my Nvidia GTX1070 card.
    But when i start the game I just see the little picture and then nothing.

    I also checked the files on my storage and disabled my security program.

  • ShenoXDfug
    15 posts

    @ubi-baron verified the game files, reinstalled the game, run as administrator, disabled anti cheat, reinstalled supporting software included in de AC folder but nothing helped so far.
    I only have one hard drive C : where also Ubisoft is installed. I also figured out the game is not even trying to start. In the task manager my gpu and ram is not even going 1% up while stucking in the splash screen.

  • Lucifer_Savage
    1 posts

    Having the same problem

  • Redlight-
    6 posts

    @acdcwrocker Thanks for the guide bro. I was too tired to make better what I did.

    I hope it will help people.

  • laranina
    2 posts

    same here

  • Primawesi
    4 posts

    @jabukegrada I did this and it works

  • Redlight-
    6 posts

    @s-t-r-l-k-e-r Symbolic link is for files, junction is for repertory. If you make junction you didn't need to make symbolic link for files inside. I use both of them because it was more simple for me.

  • Swifty__
    13 posts

    @JabukeGrada

    Worked for me dude, thanks!

  • SixpoundeR85
    11 posts

    @reddevilx_1

    And no word from ubisoft about this. No word for a fix or anything. So nice... I would love to play this game but I can´t

  • Kaphalor
    3 posts

    @shenoxdfug
    same problem here
    taskmanager shows no processor usage
    after an hour of letting it be, the ram usage went from 92 Mb to 1.9Mb

    Let's see if i can reach 0Mb

  • SeniiliSika
    8 posts

    same problem here

  • SeniiliSika
    8 posts

    same problem here

  • Skams.
    2 posts

    Reinstalling directly on 😄 worked for me. Fixed it.

  • TheoMLG
    1 posts

    Over 12 hours since release and the game still wont start. What a [censored] joke. I took the day off for this and it has been a complete waste. Ubisoft you never fail to amaze me by just how wack a company you are - atleast I got the game through ubisoft+, I would have been so mad if I had paid full price for this PoS.

  • Lulzez
    1 posts

    Hi guys! I had the same problem as you. Stuck on splash screen. Tried everything from installing it to my windows drive C, reinstalling, run as admin and reinstalling visual C++ redist. What got it to finally work for me was disabling the G-sync in NVIDIA-settings.

  • patrickmaart
    1 posts

    @dichtebanana Does this still happen for you?

  • ShenoXDfug
    15 posts

    @lulzez i am running a AMD GPU so this wont work for me

Suggested Topics

Community Details

128
Online
190.6k
Users
31.7k
Topics
160.3k
Posts