ubisoft discussions

Quick Suggestions

  • 0 Likes/1212 Replies/19691 Views
    15 posts

    @ziener89 i dont think they will fix it because i think the majority can play
    @captainben1996 what should u do if you have only C : and installed it already there?

  • Rogue-Reaper13
    13 posts

    @shenoxdfug same. And I have reinstalled valhalla 4 times. Ubisoft connect 3. I've been trying to get this working for almost 9 hours now. At this point I'm just saying [censored] it and demanding a refund.

  • VictusKristus
    8 posts

    @jabukegrada It's weird, I can't see your option no. 2. Your option no 3 is my option no 2

  • TheAngryFriend
    4 posts

    @ubi-baron Hi, I would like to attach my dxdiag and msinfo 32, but the website tells me i don't have permission to do so.
    In the meanwhile I'll just write down some basic information here. let me know if you need anything else.

    Operating System: Windows 10 Home 64-bit (10.0, Build 18362) (18362.19h1_release.190318-1202)
    System Model(Motherboard): X570 AORUS PRO
    Processor: AMD Ryzen 7 3800X 8-Core Processor       (16 CPUs), ~3.9GHz
    Memory: 32718MB RAM
        Available OS Memory: 32718MB RAM
    DirectX Version: DirectX 12
    GPU: NVIDIA GeForce RTX 2070 SUPER

  • Captainben96
    4 posts

    @shenoxdfug super strange then. It definitely solved the problem after full DL, I'll try it with Origins as well, as I had the same issue last week when wanting to run it on my new rig. I'll edit this post if I manage to reproduce this miracle. Also make sure the directory is the default one (setting > downloads > default game intallation location > default) and not manually set, maybe that can help.

  • Ubi-Swaggins
    Community Manager 437 posts

    Hey folks,

    Thank you all for sharing workarounds for this issue.

    If you are still continuing to have problems launching the game, please raise a support ticket to our team and include your MSinfo and DXDiag, so we can take a closer look.

    Official Response
  • Ubi-Spud
    Ubisoft Support Staff 703 posts

    Hey there, I'm sorry the game isn't launching! If you have performed all of the steps in this guide, please get in touch with us and submit your system files. We've had some reports of this issue and are investigating, and these files will help us pinpoint and fix the cause. Thank you for your continued patience.

    Official Response
  • Pale_Rider_TV
    20 posts

    @ubi-spud is there any word on a soon patch? woke up still having issues and verified files again this morning after I woke up. i see big time streamers playing this game and you know there on PC so whats the issue with the other 70% of PC players

  • sancho17.
    6 posts

    @ubi-swaggins Hello,The game came out but I still don't have the opportunity to play. On my account just stay (Preload) Which that is allready done. Im from EU and i'm pretty nervous about this issue, Please! Purchased via Epic Store but preload on Ubisoft and still not playable! (PC)

  • Veders
    3 posts
  • Dx2..
    38 posts

    ubisoft is doing release stream on ubisoft nordic in twitch, all go to spam there mby they start to take this issue seriously and trying to even fix it

  • XRTC-
    3 posts

    Same only get the small valhalla box for hours.....First Game since Years tha doesnt even Start properly lulz.....
    Win 10 Prozessor
    AMD Ryzen 5 1600X
    RTX 2070 Super
    RAM 16GB

    Launched with Adminperm.
    Cleard Ubi soft cache
    wrote Support

    Nothing happend im sad.

  • Dx2..
    38 posts

    ubisoft is doing release stream on ubisoft nordic in twitch, all go to spam there mby they start to take this issue seriously and trying to even fix it

  • FiightBlue
    1 posts

    le jeu ne se lance pas il ouvre la fenêtre de luncher puis plus rien en sachant qu'il n'y a AUCUNE raison pour que cela ne fonctionne pas AUCUNE

  • Rogue-Reaper13
    13 posts

    @ubi-baron well I have spent the last 10 hours trying everything that I have seen you all suggest. Nothing has worked. Even reinstalled the game and connect 4 times now. I'll take a refund now.

  • Dx2..
    38 posts
    This post is deleted!
  • drdeath12-uk
    7 posts

    @ubi-swaggins i think the game needs a patch or looking at again for the pc rather than everyone submitting tickets every other game in my library and guessing most peoples is working Valhalla is the only one that is not

  • johnethan01
    7 posts

    @kymodoke me two after the first cinematic it wont load in

  • ZeydrakTV
    1 posts

    really [censored] me off payed a lot of the gold editions of the game counted the day to play and cant even play it i fell like i trow money over the window

  • Captainben96
    4 posts

    EDIT: Ok so I managed to reproduce that with AC Origins and I discovered the issue was also true for Unity and AC3 Remastered. The games do need to be on Uplay's default game folder. I don't know how on earth something like this can still happen today on games that obviously require loads of storage, and why only on the AC series (all other licenses seem to work just fine) and only on tower PC (no problem on my laptop no matter the drive)?

    => To be tried however: install the launcher on the storage drive

Suggested Topics