ubisoft discussions

Quick Suggestions

  • 0 Likes/1212 Replies/20315 Views
    6 posts

    @nicolino977 In the official picture, the release time on the epic store for the EU is between 4 and 5pm, I'll wait another 30 minutes and if it's not available I'll contact both supports (Ubisoft and Epic) ! This is really rude, I paid € 100 gold edition and I have to [censored] with this nonsense. @Ubi-Swaggins

  • qwertzy7
    3 posts

    @shenoxdfug Just wondering since I am having the same issue but recognize some of your specs, are you running in bootcamp on a Mac? I wonder if that could be causing some sort of issue because I am also getting stuck.

  • Veders
    3 posts

    @see-otter See my post above, may help - it sorted it out for me.

  • SeniiliSika
    8 posts


    I tried this because I've tried everything else but,

    I installed to HDD instead of SSD and it fixed the problem

    Neither Windows or Ubisoft Connect are on my HDD, it is basically my trash drive.

    Funny how specs recommend to use SSD. Irony huh...

  • Ziener89
    6 posts

    @ubi-baron Im having the same problems as the others.

    My Specs:
    RTX 2070 Super.
    i9-9900 3.60Ghz
    64 Bit.
    32G RAM.

  • RTQC-Ecko
    4 posts

    Same issue, I tried every solution I saw in here... It's really pathetic, I've been noticing all the Spoiler Brat twitcher playing the game for a week+ without issue and finaly the game release and it wont launch for a bunch of people... No excuse, you had at least a week of free publicity and testing and cant even manage to fix/find a game breaking bug this big ? You really are pushing people toward cracking your game and not buying them...

  • See-Otter
    3 posts

    Possible fix that worked for me---on desktop right click and go to display settings scroll all the way down to graphic settings. Click on browse and add Valhalla.exe, afterwards right click on the game icon and select high performance mode then launch the game. Hope this works for you guys since ubisoft wont help us!

  • GRCarlos_05
    3 posts

    @seniilisika I'll try then this..
    AC black flag have the same problem. in SSD splash and crash. HHD work fine.

  • Nolkdizzle
    1 posts

    So it is stuck on the read first screen. I did everything on this list and my computer specs are more than adequate. I just tried to Uninstall the game and it won't complete and now its not even searchable but won't let me reinstall.

  • Sir_Aonarch
    2 posts

    Installing the game on my C:/ drive (Where Windows is) fixed the issue.

    I'm pretty annoyed. I have a Raid 0 Gen 4 nvme setup for my games... So once this issue is fixed I'll have to reinstall the game again. 4th time.

  • RTQC-Ecko
    4 posts

    @sir_aonarch Yeah, it's ridiculous... I guess that's what happen when you spend more on marketing than programmers...

  • Pale_Rider_TV
    20 posts

    @cad3nzvstobii yeah i just did this forgot about doing a clean driver....... Still doesn't load past launch Splash screen

  • shadow_destiiny
    1 posts

    @arch3r94 i still cant play it sadly

  • Pale_Rider_TV
    20 posts

    i just cant believe this is going on 20HRS!! with minimal effort and communication from UBI... come on ubi I've been with you for almost 10 years. Can you please just fix it already 20hrs is ridiculous for a hot fix patch most devs would push in 45min to a hour after Launch!

  • Uncle_Sneep
    5 posts

    @ubi-baron I have all my games installed on a M.2 NVMe drive. All games run fine with the exception of Valhalla which gets stuck at the splash screen.

  • RTQC-Ecko
    4 posts

    Is it too much to ask that the game we paid for work the day it's coming out, without having to go out of our way to install this or that, remove this of that, change this setting or that one !

    I mean, my computer is well above the spec for the game, I don't really have any problem with any other game/software, everything is up to date... Yet all the response I've seen so far from Ubisoft on the splash screen bug is about Us somehow being the problem and not their Game not working as intended... Yet at some point (sooner than later I hope) they will relase a patch that will fix the issue without anyone of us having to change anything in our system...

    Stop being hypocrite and admit that you screw up...

  • Uncle_Sneep
    5 posts

    @seniilisika I refuse to cripple my gameplay by installing on a HDD in lieu of SSD.. mikght as well have thrown my money out the window instead of buying the SSD.

  • TheCyberHunter9
    2 posts

    @etain44 i tride dis and it seemt to work but it did not i think there is a bug i hear 3sec of sound and than it just stops also it takes realy long to start the game i see the logo for like 2min

  • Cyrus_WongKh
    3 posts

    im crying, i try everything still cant start that [censored]

  • Mr.Sn0wBaaalL
    2 posts

    i uninstalled it runs terrible! feels like a terrible console port! cant even maintain 100 fps on 4k, TD2 i can easily get 120 plus!

    thoughts from my discord channel, i will delete the naughty words as per forum rules

    assassins creed valhalla 
    so this game is:
    not optimised
    runs like ****
    looks like **** for next gen game
    controls like ***
    full of bugs
    is painful to play

    dont buy it untill they patch it

    my thoughts was rushed for series x release!

Suggested Topics