Welcome to discussions

Quick Suggestions

  • 0 Likes/1211 Replies/16011 Views
    2 posts

    What i did that worked was I have Epic Games launcher and i had the same problem. I downloaded Ubisoft Connect and after that i right clicked the game on my computer and opend it, The ubisoft connect will update it and restart my computer and it should work after that. Let me know if that helped you.

  • OGSithLrdMalgus
    26 posts

    well 9 hours later still the same problem the game wont launch even after the update the game had..........

  • OGSithLrdMalgus
    26 posts


             AMD Ryzen 7 2700X
            34gb RAM
    got game through ubisoft
    9 hours since lauch still cant launch

  • Xyrella
    18 posts

    @senpai_dejw None that I can see so far.

  • JackFrostKing
    2 posts

    @sancho17 Check my first post and tell me if that helps

  • w_weasle
    2 posts

    Same issue. Unable to launch the game at all. Little box pops up with the axes as the A and nothing happens. Uninstalled game, reinstalled, verified my files. Nothing works. About to demand a refund and just not play this.

  • Kaolin87
    1 posts

    @sixpounder85 Staring at the AC logo, same issue.

  • Twix1210
    3 posts

    @sixpounder85 same here to 😞

  • OGSithLrdMalgus
    26 posts

    @w_weasle ive had the same screen for 9 hours now ive put in to support and have not gotten anything back so much for spending 110 bucks in February for a failed launch

  • Frostizy
    2 posts

    The following solution worked for me, found on reddit:

    Basically, you need to try the old fix that works for Origins: https://steamcommunity.com/app/582160/discussions/0/1483235412214825118/

    But for audio (Assassin's Creed Valhalla\sounddata\PC) AND video files (Assassin's Creed Valhalla/video).

    So you need to copy across your .pck and video .webm to where your windows OS is installed. Then with https://schinagl.priv.at/nt/hardlinkshellext/linkshellextension.html create a symbolic link for each file and junction for repertory.

    The whole thing only takes a handful of GB and takes about 10 mins for those who are still unsure here is a step by step.

    • Download and install Link Shell Extension
    • In your OS drive (usually your 😄 drive) create two folders one for the videos and one for the sound files.
    • Open the ACV folder and keep them next to each other.
    • Drag all the files and folders from the video and sound folder in the corresponding 😄 folder (cut and paste don't copy them.)
    • Right-click the sound folders and select "pick link source" then in the empty original ACV folders right click and "Drop as" - "Symbolic Link" (make sure you do this for every file, and yes you can batch it by selecting all the files.)
    • Do the same again with the files in the video folder. Note Do not try to batch link the folders as it won't work and you have to do each one individually but instead, select "drop as" - "Junction"
    • You can delete any language files you don't want in order to save some space.

    If you make a mistake don't worry just delete the .sym file or the junction and do it again.

    Launch the game and give it a min or two and you should be good to go. 📷

    Want to give credit to redlight on the Ubisoft forum for the original help. I'm gonna put on a brew now. Got a long night ahead!

    I hope this will help!


  • SeniiliSika
    8 posts

    @uncle_sneep I know what you mean. Even if I found possible solution I'm formatting my SSD to see if it helps

    EDIT: Formating or reinstallind SSD did not fix the problem

  • beez_trees
    8 posts
  • w_weasle
    2 posts

    @ogsithlrdmalgus They have sent me to change my Microsoft Storage Space to a standard hard drive disk and there's a whole thing to go through for it. https://support.ubisoft.com/en-gb/faqs/26541/Game-crashes-with-Microsoft-Storage-Space-Device/

    Instead I'm attempting to install the game on my SSD and see if that fixes the issue. They say they are "working on a fix" right now.

  • Brian3602020
    1 posts

    I actually played the game, predownloaded and everything, turn it off, turn it on to play again then the "to play this, you will need to buy it"message. I already bought the game.... idk what to do

  • overencumbered1
    1 posts

    I couldn't get past the opening cinematic and after messing around a bunch I used the GEFORCE EXPERIENCE app on my laptop to dl the newest driver (released yesterday) that says it's specifically for COD/Valhalla. Also selected the option to let the app auto-configure my games on launch going forward.

    It changed my in-game settings back from the lowest (which I had done to see if it would help) back up to medium and it seems to be working now.

    Updating the driver through Windows didn't work (when has it ever?) - but the GEFORCE app seems to have done the trick. Time will tell if it keeps working...

    Hope that helps some folks.

  • Pale_Rider_TV
    20 posts

    @w_weasle yeah still there better be something for us worst game launch i have ever seen from a major Developer

  • IamCadenz3090
    6 posts

    @pale_rider_tv I can't even see the game in my library man. I feel i could get it working if i had it. Try rollback on GPU Drivers. Like super far back if you can, run in compatibility mode...Try running the game in SAFE MODE. hmmm.

  • Leelany85
    2 posts

    Nothing is working for me either.
    Everything is up to date, but the game won't launch.

    My boyfriend installed it on his PC, NOT on c:/, and it worked.
    I can only install it on my other drive since my c:/ doesn't have space for another ~64 gb game.
    Every other game works without being installed there.

    RTX 2060
    Intel Core i5-9600K 3.70Ghz
    16GB RAM

  • Dichtebanana
    4 posts

    @patrickmaart Yes i still have the loading picture

  • beez_trees
    8 posts

    @ubi-spud This is ridiculous. 12 hrs and we cannot even get past a splash screen.

Suggested Topics