Welcome to discussions

Quick Suggestions

  • w_weasle
    2 posts

    @ogsithlrdmalgus They have sent me to change my Microsoft Storage Space to a standard hard drive disk and there's a whole thing to go through for it. https://support.ubisoft.com/en-gb/faqs/26541/Game-crashes-with-Microsoft-Storage-Space-Device/

    Instead I'm attempting to install the game on my SSD and see if that fixes the issue. They say they are "working on a fix" right now.

  • Ubi-Borealis
    Ubisoft Support Staff 3625 posts
    Best Answer

    Hello there!

    I'm sorry to hear that you're encountering trouble when launching Assassin's Creed: Valhalla, and that the game freezes on the splash screen. This issue was marked as resolved by the development team following TU 1.1.1. Thanks to those who have taken the time to share how they were able to resolve their freeze-on-launch issues in this thread!

    If you are still encountering issues when launching the game, please ensure that you have first tried these basic PC troubleshooting steps, as these help to resolve common issues behind freezing and crashing. Please note that there can be multiple causes behind a crash or freeze, so we would recommend trying all of these steps as a first step.

    Additionally, if you have the game installed on a Microsoft Storage Space Drive, we would recommend moving the game to an alternative ha soft Storage Space Drives, and we recommend installing the game on a hard drive that also has the OS installed. rd drive (ideally the same drive that your OS is installed on). It is important to note that most of our games do not support Microsoft Storage Space Drives, and this can cause problems when launching the game.

    If the issue still persists after trying these steps, please can you open a support ticket so our team can take a closer look at your system files. You can open a support ticket via the Ubisoft Support website or by starting a live chat. When opening a support ticket, please have the following ready to include in your support ticket:

    • An MSinfo and a DxDiag
    • The troubleshooting steps you have already tried
    • If this issue has persisted since installing the game, or if it only started after a specific event (such as a game update or a system update)

    If you purchased the game from the Ubisoft Store and would like to seek a refund, you are also welcome to open a support ticket to submit a refund request. These requests are considered against our digital and physical refund policies on a case-by-case basis. If you do not meet the eligible criteria, we are unable to guarantee that a refund will be granted.

    @Thunderchild_UK - Apologies for the delayed response. Thanks for sharing what troubleshooting steps you have already tried. I'm glad to hear that you've been able to resolve the issue. Thanks for sharing what worked for you!

    @skyhawg - I understand that you've been able to resolve this issue after opening a support ticket. If you're still encountering trouble with crashes/freezes, please don't hesitate to update us so we can take a closer look.

    Thanks! 😊

    Official Response
  • Brian3602020
    1 posts

    I actually played the game, predownloaded and everything, turn it off, turn it on to play again then the "to play this, you will need to buy it"message. I already bought the game.... idk what to do

  • overencumbered1
    1 posts

    I couldn't get past the opening cinematic and after messing around a bunch I used the GEFORCE EXPERIENCE app on my laptop to dl the newest driver (released yesterday) that says it's specifically for COD/Valhalla. Also selected the option to let the app auto-configure my games on launch going forward.

    It changed my in-game settings back from the lowest (which I had done to see if it would help) back up to medium and it seems to be working now.

    Updating the driver through Windows didn't work (when has it ever?) - but the GEFORCE app seems to have done the trick. Time will tell if it keeps working...

    Hope that helps some folks.

  • Pale_Rider_TV
    20 posts

    @w_weasle yeah still there better be something for us worst game launch i have ever seen from a major Developer

  • IamCadenz3090
    6 posts

    @pale_rider_tv I can't even see the game in my library man. I feel i could get it working if i had it. Try rollback on GPU Drivers. Like super far back if you can, run in compatibility mode...Try running the game in SAFE MODE. hmmm.

  • Leelany85
    2 posts

    Nothing is working for me either.
    Everything is up to date, but the game won't launch.

    My boyfriend installed it on his PC, NOT on c:/, and it worked.
    I can only install it on my other drive since my c:/ doesn't have space for another ~64 gb game.
    Every other game works without being installed there.

    RTX 2060
    Intel Core i5-9600K 3.70Ghz
    16GB RAM

  • Dichtebanana
    4 posts

    @patrickmaart Yes i still have the loading picture

  • beez_trees
    8 posts

    @ubi-spud This is ridiculous. 12 hrs and we cannot even get past a splash screen.

  • Pale_Rider_TV
    20 posts

    @iamcadenz3090 im doing once again another reinstall if a patch didnt push as a update for some reason IDK but afterwards I will try safemode and let you know

  • EfeTozan
    6 posts

    @pale_rider_tv is it in your hdd or ssd?

  • Pale_Rider_TV
    20 posts

    @efetozan m.2, my OS is on SSD no HDD on my PC

  • EfeTozan
    6 posts

    @pale_rider_tv okay, coz it doesn't work in hdd when you have ssd.

  • proxyonemusic
    2 posts

    I get about as far as pressing "New Game," and then it immediately crashes.

  • Pale_Rider_TV
    20 posts

    @proxyonemusic yeah i just want to get past the splash screen after pressing play. looks like all i got was temporary 400x600 wallpaper.......pff

  • Agent_Ting-TTV-
    2 posts

    12hrs later, still can't launch the game.

    1. Reinstalled Ubisoft Connect
    2. Reinstalled the Game
    3. Updated Nvidia Drivers
    4. Set the game to run as admin
    5. tried adding both ACvalhalla and ACVahalla_Plus to High Performance in Nvidia Settings
    6. Not running a Microsoft Storage Space
    7. Installed to default location on the SSD C Drive.

    Nothing gets the game past the Splash Screen

    This feels like a DRM issue if I've ever seen one. I almost want to uninstall/refund and wait for a proper CODEX patch 🤣

  • PascalJansen
    4 posts

    Assassins Creed Valhalla Startet nicht habe es bereits 2mal neu instaliert aber sobald ich auf spiel starten drücke öffnet sich nur das UBISOFT CONNECT Fenster und weiter passiert nix

  • GRCarlos_05
    3 posts

    I delete from SSD and put to the HDD and work now.

  • iBenM24
    2 posts

    @pascaljansen Bei mir startet es auch nicht!

  • chewbaccat_
    1 posts

    It is indeed a problem with windows storage spaces drives.
    If you can install the game on a non windows storage spaces drive. If you cant you can try this solution from 5 years ago: https://forums.ubisoft.com/showthread.php/1259451-SOLUTION-AC-games-won-t-launch-when-installed-on-Windows-Storage-Spaces-Forums

    This is what worked for me. I had to create directory junctions for the sounddata and videos folders

  • royalretro87
    4 posts

    Game won't launch beyond splash screen. All other games from Ubisoft works on same drive. This is a QA issue and it is embarrassing to see for a company asking for $100+ pre orders. Villains of the industry.

Suggested Topics

Community Details