Welcome to discussions

Quick Suggestions

  • Dichtebanana
    4 posts
  • Ubi-Borealis
    Ubisoft Support Staff 3571 posts
    Best Answer

    Hello there!

    I'm sorry to hear that you're encountering trouble when launching Assassin's Creed: Valhalla, and that the game freezes on the splash screen. This issue was marked as resolved by the development team following TU 1.1.1. Thanks to those who have taken the time to share how they were able to resolve their freeze-on-launch issues in this thread!

    If you are still encountering issues when launching the game, please ensure that you have first tried these basic PC troubleshooting steps, as these help to resolve common issues behind freezing and crashing. Please note that there can be multiple causes behind a crash or freeze, so we would recommend trying all of these steps as a first step.

    Additionally, if you have the game installed on a Microsoft Storage Space Drive, we would recommend moving the game to an alternative ha soft Storage Space Drives, and we recommend installing the game on a hard drive that also has the OS installed. rd drive (ideally the same drive that your OS is installed on). It is important to note that most of our games do not support Microsoft Storage Space Drives, and this can cause problems when launching the game.

    If the issue still persists after trying these steps, please can you open a support ticket so our team can take a closer look at your system files. You can open a support ticket via the Ubisoft Support website or by starting a live chat. When opening a support ticket, please have the following ready to include in your support ticket:

    • An MSinfo and a DxDiag
    • The troubleshooting steps you have already tried
    • If this issue has persisted since installing the game, or if it only started after a specific event (such as a game update or a system update)


    If you purchased the game from the Ubisoft Store and would like to seek a refund, you are also welcome to open a support ticket to submit a refund request. These requests are considered against our digital and physical refund policies on a case-by-case basis. If you do not meet the eligible criteria, we are unable to guarantee that a refund will be granted.

    @Thunderchild_UK - Apologies for the delayed response. Thanks for sharing what troubleshooting steps you have already tried. I'm glad to hear that you've been able to resolve the issue. Thanks for sharing what worked for you!

    @skyhawg - I understand that you've been able to resolve this issue after opening a support ticket. If you're still encountering trouble with crashes/freezes, please don't hesitate to update us so we can take a closer look.

    Thanks! 😊

    Official Response
  • thomazks
    1 posts

    Same here - was the same story with Origins. Had to have Steam and the game installed on the same drive. Didnt help here though..

  • Kymodoke
    2 posts

    Game is stuck in the Intro -loading screen...great ! 👎

  • MadNack
    2 posts

    @dichtebanana
    I have to wait like 3-5 mins till it gets in. The best part is when I got in I got stuck at Warning before play screen again lmao

  • Dichtebanana
    4 posts

    @madnack Wonderful even after 10 Minutes nothing happens. Why i always buy games before release...

  • ShenoXDfug
    15 posts

    @dichtebanana same problem...

  • RulerOfTheSlobs
    2 posts

    Same problem. Tried reinstalling on other drives to no avail.

  • sotomek
    1 posts

    same problem 😞

  • Max-_-33
    13 posts

    Same here i get stuck on warning what do i do?

  • GhostEagle95
    5 posts

    Mine was starting fine but was lagging really badly while my specs was good enough to run on high, i lowered the settings and black screens appeared, then i lowered the resolution and decided to restart the game and now it's not starting and giving me the same issue as you guys.

  • Max-_-33
    13 posts

    @ghosteagle95 when u getting stuck like what part

  • rmazz84
    1 posts

    same thing is happening to me 😞

  • TheAngryFriend
    4 posts

    Exactly what the title says. I try to launch the game, It shows the splash art and then it does nothing. I far exceed the minimum requirements, have tried to reinstall both uplay and Valhalla several times, nothing works.

  • PrimalKingAmit
    1 posts

    @theangryfriend

    me too.

  • theonlyskates
    2 posts

    Most likely because the game isn't available for another4 hrs and 45 minutes

  • Ketapan420
    1 posts

    same .... happens to me 😡

  • TheAngryFriend
    4 posts

    @theonlyskates for you maybe. mine unlocked over an hour ago.

  • Finomfalat
    1 posts

    @theangryfriend Same problem

  • lukas..at
    3 posts

    Game dont open .. the little Loading Screen is there for ever

  • RidahMike.
    1 posts

    i have the same pb why ?

Suggested Topics

Community Details

66
Online
191.8k
Users
32.2k
Topics
161.5k
Posts