Welcome to discussions

Quick Suggestions

  • 0 Likes/1212 Replies/16811 Views
    18 posts

    My problem came down to my antivirus blocking the process wrongly. Check and or disable your antivirus to see if it helps anyone reading this. You have to do it through msconfig to really see if disabling it helps. If it does help uninstall it and get something else like I did.

  • mileslewis9237
    2 posts

    @hisn I have 4 drives, just moved it from one to another and it worked, tried moving it back and the game stopped working again. I have no space on C so that was never an option. its clear there is a fault with Ubisoft connect and not the game.

  • Thesoet
    1 posts

    Boleto de soporte de Ubisoft: 13169197

  • HawkSE
    9 posts

    Ubisoft Support Ticket: 13171086 for me

  • Joesomebody1515
    1 posts

    @craggy424 how do you do that

  • Agent_Ting-TTV-
    2 posts
  • serdar2chbat
    1 posts

    @pale_rider_tv i did every think in internet but try this this did work for me i did uninstall the game 4 time and last time i did download the client and the game in the same SSD At (D) did not work but now i did download the client and the game in M.2 (C) it work i Hobe i will work with u

  • Calosfere
    2 posts

    Whenever I press play, the game pops up the logo for the game, then it just stays there and nothing happens, ive updated every driver and stuff i have and i even looked into verifying the games files. the only way for me to remove the logo from my screen is to restart my computer.

  • Dzhei_Di_Si
    2 posts


  • SergeThePenguin
    1 posts

    @calosfere I have been having the same exact problem please tell me if you have figured out a way to fix it!

  • Dzhei_Di_Si
    2 posts


  • SASkievua
    4 posts

    I was stuck after splash as many here and tried everything - verify, reinstall, repair VC, moving game or video-sound to C:, disable security or game bar - nothing helps.
    After 4 hours I tried simply to close MSI Afterburner - and that's it! Game finally runs! ))
    Pls consider to try disabling specific monitoring software such afterburner or fraps if your have problems with game launch.

  • DarthVrees
    1 posts

    Same here! I tried updating drive again, ran as admin, deleted some game files and 'fixed' the game, still nothing.

    Going to try setting my graphics driver back one update.

  • jvillaraza
    1 posts

    Mine is a little strange at least some are getting the Valhalla logo I get some box that open when I click the Valhalla.exe, a box that is part of Ubisoft synchronizing then it disappears and nothing happens.

    Uninstalled and reinstalled same thing

  • SeniiliSika
    8 posts

    Well I finally fixed it. The fault is in Windows storage devices.

    Basically I formatted the SSD drive.
    Then removed the drive from windows storage reserve.
    Then reformatted it using 3rd party tool.
    And now it works.

  • hawking1822
    1 posts

    @redlight This resolved my issue! Thank you a lot, master!

  • murphymst
    1 posts

    I got it to work. Here's what I did. I opened the installation folder. Mine was in G/Epic Library/AssassinsCreedValhalla. I double clicked ACValhalla. That started a couple Ubisoft software installations. I think it was Uplay and Ubisoft Connect. Let it install whatever it needed. You will get to a point where it asks you to install AC Valhalla. Just click cancel. From there, go back to Epic Library and Launch the game. Should work. I had to sign into Uplay at some point during this process and update some stuff.

  • neilchart
    3 posts

    @ubikoality Same issues as everyone here - stuck on splash screen. Case #13178848. Submitted with DXDiag and MSInfo.

  • Celgirin
    6 posts

    The contact form on the site can’t be sent and there’s no reply on Facebook. But thanks anyway.

  • Trazzer1
    1 posts

    Had the same problem.. Tried a lot of different things, but the one that worked was moving the game to my main harddrive. (same as Windows is installed on)

Suggested Topics