Welcome to discussions

Quick Suggestions

  • 0 Likes/1211 Replies/14803 Views
    Xyrella
    18 posts

    @sora546 My issue came down to my antivirus killing the process. Others have fixed the issue updating visual c++ as well as making sure the game isn't installed on a Microsoft storage space device https://support.ubisoft.com/en-gb/faqs/26541/Game-crashes-with-Microsoft-Storage-Space-Device

  • ScizorKikN
    3 posts

    @sora546 not that I know of. i dont get an error. My system isn't the greatest, but its not bad enough to not run this game. Its definitely on the games end. I know for me when I go to end the process in task manager, it is showing CPU at 0% for AC. It feels like it isn't even trying to start the game and I don't know why.

  • Xyrella
    18 posts

    @regime_kin My issue came down to my antivirus killing the process. Others have fixed the issue updating visual c++ as well as making sure the game isn't installed on a Microsoft storage space device https://support.ubisoft.com/en-gb/faqs/26541/Game-crashes-with-Microsoft-Storage-Space-Device

  • ScizorKikN
    3 posts

    @xyrella none of these things worked for me. I am not sure what to do. it doesn't make sense that I can run Watchdogs perfectly fine but can't load in AC. This is so annoying.

  • Cyrus_WongKh
    3 posts

    Hello!
    im losing up to 72 hours of gameplay because i still stuck on loading screen , i have paid hkd800 to buy Ultimate and i cant get in , whats wrong with you? can get any support to your customer ?
    never see the game store could be like this ,
    dont tell me re-install ,checking file or reboot , i do this over four times , in asia date 11/11/2020 , where is your Customer service , where is your support?
    my
    CPU: Intel Core I7-7900KF
    GPU: ROG STRIX GeForce RTX2060 O6G GAMING
    and using SSD
    just finish playing watchdog so Hardware is not the problem ,
    not the best but enough

  • Yukiyoroi
    9 posts

    In my case, I discovered a solution that made my game work:

    1. Uninstall game from any hard drive managed by Microsoft Storage Spaces.
    2. Create an Ubisoft directory on 😄 drive (even if it's an SSD) OUTSIDE OF PROGRAM FILES.
    3. Install game in the Ubisoft directory you just created.


    This both avoids the game's incompatibility with Microsoft Storage Spaces and the well-known problem with WIndows and games installed in the Program Files directory.

    No, I do not know why any modern game would be designed to be incompatible with Microsoft Storage Spaces, but @Ubi-Woofer recommended this as a solution, and when I tried it, it worked.

  • Cyrus_WongKh
    3 posts
    I very Disappointed 


  • Regime_Kin
    2 posts

    @scizorkikn Honestly, I'm just uninstalling the game and am gonna wait a week or two, even though it's gonna kill me knowing I can't play the game.

  • Uncle_Sneep
    5 posts

    @sora546 mine was the microsoft storage space issue.. converted my ssd to a normal drive and its now working.. never even heard of a storage space until today..

  • sora546
    5 posts

    @uncle_sneep Same. never knew it could be a issue till now. Currently downloaded the game to my 3rd storage space after making sure it was a Microsoft storage space to see if that fixes it.

  • sora546
    5 posts

    Ok so after checking all my storages spaces to see what ones was and wasn't microsoft storage. I started downloading the game from ubi connect instead of epic games to my 3rd storage space. when it became available to open I tested it and the game opened after about 4 seconds.

  • LiviuAndreiDan
    1 posts

    @sora546 I checked my storage space and it isn't a Microsoft storage so I have no idea why it won't run.

  • SoCalSoldier21
    2 posts

    doesn't surprise me. Highly anticipated games always have issues on launch day. I bought The first division game. Stood in line to get it at game stop and once it was finished downloading, the game was unplayable. Ubisoft really needs to fix all these launch issues and release a stable game.

  • sora546
    5 posts

    @liviuandreidan I wish I could tell you why it worked for me. from what iv seen around reddit and forms it seems to work for some people and others it doesn't do anything. I did end up moving ubi connect to another storage space as well so its possible that has something to do with it. Either way this isn't something that should be happening. Seeing as its happened before with AC Orgins so you would expect the problem to have been resolved.

  • sora546
    5 posts

    @socalsoldier21 They really do. Its bizarre and a bit sad that so many of their games tend to have some kind of issue that's worse then a just a few bugs on day one.

  • Rogue-Reaper13
    13 posts

    @ubi-baron it's been 24 hours. I have tried every possible "fix" that I have seen. I have installed 5 times now and nothing works. I can't install on C drive because it doesn't have room. I want a refund.

  • RabidWerevegan
    1 posts

    @ubi-baron

    I have run into this issue, and I have installed the game on a Microsoft Storage Space Device.

  • Pneumot
    1 posts

    @see-otter It actually worked for me. Thanks!

  • SixpoundeR85
    11 posts

    I got the game to work by installing it to one of my HDD drives. It seems that the game does not like SSDs. So you can try if that helps you... Still waiting for a patch to fix this. I would like to play this on an ssd for sure...

  • readarainbow
    2 posts

    @readarainbow I found a fix! I went to Display settings —> Graphics settings —> pick classic app from dropdown —> browse —> added valhalla .exe file —> changed options to “High Performance” instead of System Default. Hope this helps someone else.

Suggested Topics

Community Details

91
Online
194.0k
Users
32.8k
Topics
164.0k
Posts