Welcome to discussions

Quick Suggestions

  • death6ft
    4 posts

    @death6ft i tried it did not work

  • Ubi-Borealis
    Ubisoft Support Staff 3626 posts
    Best Answer

    Hello there!

    I'm sorry to hear that you're encountering trouble when launching Assassin's Creed: Valhalla, and that the game freezes on the splash screen. This issue was marked as resolved by the development team following TU 1.1.1. Thanks to those who have taken the time to share how they were able to resolve their freeze-on-launch issues in this thread!

    If you are still encountering issues when launching the game, please ensure that you have first tried these basic PC troubleshooting steps, as these help to resolve common issues behind freezing and crashing. Please note that there can be multiple causes behind a crash or freeze, so we would recommend trying all of these steps as a first step.

    Additionally, if you have the game installed on a Microsoft Storage Space Drive, we would recommend moving the game to an alternative ha soft Storage Space Drives, and we recommend installing the game on a hard drive that also has the OS installed. rd drive (ideally the same drive that your OS is installed on). It is important to note that most of our games do not support Microsoft Storage Space Drives, and this can cause problems when launching the game.

    If the issue still persists after trying these steps, please can you open a support ticket so our team can take a closer look at your system files. You can open a support ticket via the Ubisoft Support website or by starting a live chat. When opening a support ticket, please have the following ready to include in your support ticket:

    • An MSinfo and a DxDiag
    • The troubleshooting steps you have already tried
    • If this issue has persisted since installing the game, or if it only started after a specific event (such as a game update or a system update)

    If you purchased the game from the Ubisoft Store and would like to seek a refund, you are also welcome to open a support ticket to submit a refund request. These requests are considered against our digital and physical refund policies on a case-by-case basis. If you do not meet the eligible criteria, we are unable to guarantee that a refund will be granted.

    @Thunderchild_UK - Apologies for the delayed response. Thanks for sharing what troubleshooting steps you have already tried. I'm glad to hear that you've been able to resolve the issue. Thanks for sharing what worked for you!

    @skyhawg - I understand that you've been able to resolve this issue after opening a support ticket. If you're still encountering trouble with crashes/freezes, please don't hesitate to update us so we can take a closer look.

    Thanks! 😊

    Official Response
  • Ubi-Spud
    Ubisoft Support Staff 702 posts

    Hey folks, apologies if you feel there has been no acknowledgement of this issue. We are indeed aware of the issue and are looking in to it. As mentioned above, if you have another drive, try moving your files over and testing again. I appreciate that this is just a workaround and we appreciate your patience while we look into this.

    Official Response
  • Ubi-Spud
    Ubisoft Support Staff 702 posts

    Hey folks, I'm sorry you're all experiencing this. We are investigating the issue at the moment. As mentioned above, please ensure the game is installed on the same drive as your OS and test again for now. Thank you all for your continued patience!

    Official Response
  • Rixxaw
    2 posts


    Are you FREAKING kidding me Who puts games on their WINDOWS Drive? Normies put games on the C Drive... What Dev put a hook in that checks what DRIVE its installed on?

  • Tomzu88
    4 posts

    It would be great to be able actually get past splash screen! When do we get update to fix launch?

  • Rixxaw
    2 posts


    I moved it to my C : Drive and its still pops up the splash screen which is literally a JPG stored in the Valhalla directory, and has a process with 0% cpu doing nothing ... I"m looking at Resource monitor ... it is doing nothing. I am going to try verifying my files and then if that doesn't work uninstall - reinstall on c:drive this time... There is an error log that says it can't write to the registry so this is probably something to do with Windows making a change to security that borked how ValHalla works on PC...

  • Svesse.
    1 posts

    @frame1983j worket fot me thx

  • Ubi-Spud
    Ubisoft Support Staff 702 posts

    Hey there, thank you for providing a solution that worked for you! I will update the issue on our end with the developers, so hopefully this works for others as well. Rest assured, we are still investigating this and it remains a priority!

    Official Response
  • Ubi-Spud
    Ubisoft Support Staff 702 posts

    Hey folks, we are aware of this issue and are looking into it at the moment! Some players have gotten around this by ensuring they have the game installed on the same drive as their OS. Others have disabled MSI Afterburner which fixed it. I appreciate these are workarounds and not solutions. Your patience is really appreciated!

    Official Response
  • HawkSE
    9 posts
    In my case, I discovered a solution that made my game work:

    1. Uninstall game from any hard drive managed by Microsoft Storage Spaces.
    2. Create an Ubisoft directory on 😄 drive (even if it's an SSD) OUTSIDE OF PROGRAM FILES.
    3. Install game in the Ubisoft directory you just created.

    This both avoids the game's incompatibility with Microsoft Storage Spaces and the well-known problem with WIndows and games installed in the Program Files directory.

    No, I do not know why any modern game would be designed to be incompatible with Microsoft Storage Spaces, but @Ubi-Woofer recommended this as a solution, and when I tried it, it worked.

    I'm glad that worked for you. But I don't use Microsoft Storage Spaces, and the game will not launch.

  • Yukiyoroi
    9 posts

    In other words, there's more than just its incompatibility with MSSD that's at play. I already knew about how Windows doesn't play nice with games in the Program Files directories, which is why I created an Ubisoft directory to install it in, but it sounds like there's as many launch bugs with this as there are total bugs in a Bethesda game.

  • HawkSE
    9 posts

    @yukiyoroi Yes, exactly.

    I have Uplay installed on my C drive, and games get installed to one of my three other drives (all four are SSDs). I've moved Valhalla to C, moved Uplay to another drive. Nothing works so far.

  • Ubi-Baron
    Ubisoft Support Staff 788 posts

    Thank you for contacting us, we're sorry to hear that's been the case.

    Just to confirm, which exact screen are you not able to get past? Could you provide us with a screenshot of that?

    Does the game crash or just not continue loading?

    Official Response
  • Lundhusen
    1 posts

    Hi guys

    I finished my download of the game yesterday and I sadly cannot start my game.

    Each time i try to open it, i get the splashscreen.png image (the one with the 2 axes, which is also located in the game folder).... and then nothing happends.. ?

    I have tried starting the game via the Ubisoft Connect, updating my drivers and verifying the game files.. but no difference..

    Any suggestions to what more i can do?

  • INeedM0neyy
    5 posts

    @lordphoenix82nd Du bist so ein opfer viel zu lustig

  • TheMadRat1473
    1 posts


    I believe he/she means the first popup screen with the AC logo i jade green.
    I have that exact problem myself.

  • emmaj95
    66 posts

    I, like many others, still cannot start the game after 24hrs of troubleshooting with no solution and no promise of a patch to fix this issue. Things I have tried:

    • reinstall the game
    • reinstall uplay/ubisoft connect
    • verify game files
    • change install path
    • update graphics and windows 10
    • reinstalled microsoft visual c++
    • renamed the file
    • ran in offline mode
    • reinstalled on different storage drives
    • checked windows defender
    • sfc/runnow in command prompt
    • high performance graphics setting in windows
    • run as administrator

    Still the same thing-- crash error every time I try to load up the game. Why isn't this crash issue listed on the "known issues" thread?

  • Whiskey_Boi
    3 posts

    @themadrat1473 I'm in the same boat as well

  • Neato-11
    1 posts

    i have the same problem

  • CptUlfhednar
    1 posts

    same here as well. happend to me yesterday and to day cant play

Suggested Topics

Community Details