Welcome to discussions

Quick Suggestions

  • Spinx2K
    1 posts

    Same here.

    Taskmanager show nothing but eating RAM

  • Ubi-Borealis
    Ubisoft Support Staff 3625 posts
    Best Answer

    Hello there!

    I'm sorry to hear that you're encountering trouble when launching Assassin's Creed: Valhalla, and that the game freezes on the splash screen. This issue was marked as resolved by the development team following TU 1.1.1. Thanks to those who have taken the time to share how they were able to resolve their freeze-on-launch issues in this thread!

    If you are still encountering issues when launching the game, please ensure that you have first tried these basic PC troubleshooting steps, as these help to resolve common issues behind freezing and crashing. Please note that there can be multiple causes behind a crash or freeze, so we would recommend trying all of these steps as a first step.

    Additionally, if you have the game installed on a Microsoft Storage Space Drive, we would recommend moving the game to an alternative ha soft Storage Space Drives, and we recommend installing the game on a hard drive that also has the OS installed. rd drive (ideally the same drive that your OS is installed on). It is important to note that most of our games do not support Microsoft Storage Space Drives, and this can cause problems when launching the game.

    If the issue still persists after trying these steps, please can you open a support ticket so our team can take a closer look at your system files. You can open a support ticket via the Ubisoft Support website or by starting a live chat. When opening a support ticket, please have the following ready to include in your support ticket:

    • An MSinfo and a DxDiag
    • The troubleshooting steps you have already tried
    • If this issue has persisted since installing the game, or if it only started after a specific event (such as a game update or a system update)


    If you purchased the game from the Ubisoft Store and would like to seek a refund, you are also welcome to open a support ticket to submit a refund request. These requests are considered against our digital and physical refund policies on a case-by-case basis. If you do not meet the eligible criteria, we are unable to guarantee that a refund will be granted.

    @Thunderchild_UK - Apologies for the delayed response. Thanks for sharing what troubleshooting steps you have already tried. I'm glad to hear that you've been able to resolve the issue. Thanks for sharing what worked for you!

    @skyhawg - I understand that you've been able to resolve this issue after opening a support ticket. If you're still encountering trouble with crashes/freezes, please don't hesitate to update us so we can take a closer look.

    Thanks! 😊

    Official Response
  • drdeath12-uk
    7 posts

    @ubi-spud it shouldent be a harddrive issue if people like my self can play every other game from yourself its obviously a mess on your end am getting annoyed its been 2 days of waiting to get past a splash screen

  • xdxphatx
    2 posts

    same here,
    updated graphic cards
    even tried installing in different drives
    Day 2, no luck

  • CrazyDonkey88
    100 posts

    @drdeath12-uk

    they truly don't give a f*** about this issue
    if they don't fix this i go for refund

  • xdxphatx
    2 posts

    At least give us who're waiting with stuck on splash screen with a progress announcement?

  • NemesisSovL
    1 posts

    Yeah please mine doesn't work too. I have deinstalled and installed Uplay and AC:Valhalla nothing works. Yes everything is up to date too.

  • RedLighting1815
    4 posts

    @hawkse Same here

  • Nalletuoppi
    1 posts

    This finally worked for me!
    I have the game installed to other storage (F) than windows (C).

    Follow this links orders: https://www.reddit.com/r/assassinscreed/comments/jrc7pu/fix_for_infinite_splash_screen/

    NO need for me to do that first fix which "works for Origins"

    Just follow the steps below that steamcommunity link..

    And yeah run as adminstrator, just for sure.

    Takes max 5 minutes!

  • CrazyDonkey88
    100 posts

    @nalletuoppi don't work for me, i tried all of this

  • HawkSE
    9 posts

    @nalletuoppi I don't use MS Storage Spaces, so this is not my issue

  • CrazyDonkey88
    100 posts

    @hawkse Same here. I'm so frustrated about this game right now.

  • CrazyDonkey88
    100 posts

    I found these in ubi launchers logs. I don't this this has something to do with MSSD. I believe problem is in UbiConnect. I get this error all day : AC:V stopped working and this pop up only via Ubi Connect


    [12812] 2020-11-11 23:33:30   [11536]   INFO    GameStartPipe.cpp (81)              Accepted connection.       
    [12812] 2020-11-11 23:33:30   [11536]   INFO    GameStartPipe.cpp (82)              Starting game session.      
    [12812] 2020-11-11 23:33:32   [11536]   INFO    CloudSaveSyncGameStart.cpp (311)         Migrate to new cloud save system.
    [12812] 2020-11-11 23:33:33   [11536]   INFO    CloudSaveMigration.cpp (157)           There's no savegames to migrate.
    [12812] 2020-11-11 23:33:34   [11536]   INFO    ApiProcessConnection.cpp (121)          Game with process id 1188 connected.
    [12812] 2020-11-11 23:33:34   [11536]   INFO    ApiProcessConnection.cpp (132)          Game with process id 1188 has been started with product id 13504 (branch: 'default').
    [12812] 2020-11-11 23:33:35   [11536]   INFO    UplayGameConnectionHandler.cpp (363)       Game with process id 1188 connected (API version: 2.3.0).
    [12812] 2020-11-11 23:33:35   [11536]   INFO    UplayGameConnectionHandler.cpp (363)       Game with process id 1188 connected (API version: 2.3.0).
    [12812] 2020-11-11 23:33:35   [11536]   INFO    UplayGameConnectionHandler.cpp (363)       Game with process id 1188 connected (API version: 2.3.0).
    [12812] 2020-11-11 23:33:37   [11536]   INFO    ApiProcessConnection.cpp (289)          Game with process id 1188 disconnected.
    [12812] 2020-11-11 23:33:37   [11536]   INFO    UplayGameConnectionHandler.cpp (316)       Game with process id 1188 disconnected.
    [12812] 2020-11-11 23:33:37   [11536]   INFO    UplayGameConnectionHandler.cpp (316)       Game with process id 1188 disconnected.
    [12812] 2020-11-11 23:33:37   [11536]   INFO    UplayGameConnectionHandler.cpp (316)       Game with process id 1188 disconnected.
    [12812] 2020-11-11 23:34:10   [ 9316]   ERROR   DataStatistics.cpp (573)             Account ID are empty.      
    [12812] 2020-11-11 23:34:11   [ 9316]   ERROR   DataStatistics.cpp (573)             Account ID are empty.      
    [12812] 2020-11-11 23:34:58   [ 9316]   ERROR   DataStatistics.cpp (573)             Account ID are empty.      

  • WoodyDaOcas
    3 posts

    @lundhusen I'd like to know also, I am not able to start the game since launch. Happened in Odyssey ocassionally, game starts (taskbar) but is stuck, some 8% cpu load and nothing happens. I can put focus into the "window", mouse disappears, alt shift to fullscreen but this white "quarter" of screen is maximized and that's it

    undefinedundefined

  • WoodyDaOcas
    3 posts

    same here 😞 Really frustrating, thing is, I've seen this when I played odyssey like a month ago.. might be something HW specific, also the games are real copied if it's anything in the core :))

  • CrazyDonkey88
    100 posts

    @woodydaocas refund is there only option for now. many ppl have the same issue

  • HisN
    11 posts

    First Sugesstion: Instead of opening 1000 Threads with the same topic, you should read the 1000 Threads.
    Some are holding solutions.

    Really


    https://discussions.ubisoft.com/topic/76984/can-t-get-past-the-ac-valhalla-start-before-the-game-launches/67?_=1605136842424

  • CrazyDonkey88
    100 posts

    @dzhei_di_si

    I have this too! All day long

  • Willbold
    1 posts

    Is it possible that Valhalla doesn't like being installed on NVME drives? I moved the install folder off of my C (w/ operating system) onto a non-nvme drive. After that it loaded and works fine. Until now I got infinite splash screen and nothing else. This was after trying every other suggestion I could find.

    The only other difference I can think of between the drives is the C (nvme - didn't work) has 4k sectors while the D (m.2 SATA - works) has 512 sectors.

    Hopefully this helps someone

  • CrazyDonkey88
    100 posts

    @hisn none of them are working so... 😉

  • CrazyDonkey88
    100 posts

    @hisn Not worked for me tho "ACV stopped running" all day long
    undefined

Suggested Topics

Community Details

159
Online
193.3k
Users
32.6k
Topics
163.2k
Posts