ubisoft discussions

Quick Suggestions

  • 0 Likes/1212 Replies/20366 Views
    LordPhoenix82nd
    11 posts
  • PilgriM_71
    9 posts

    @flixn0x I have run Odyssey and Origins on a second drive fine, can't with Valhalla, it appears to be because the game doesn't like Windows Storage Spaces being used for the game files. Which is a feature that has been in Windows since version 8, yet this game cannot handle, poor coding methinks...

  • BTOWNxo
    2 posts

    @hisn yeah screw that. dont want to play it on my C drive and shouldnt have to.

    might try get refund this is a joke and games not even on steam [censored].

  • TheZenWalker
    4 posts

    All I see is this.

    undefined
    https://gyazo.com/98e8d1c9c3ea240492f169ef4c4d0630: (https://gyazo.com/98e8d1c9c3ea240492f169ef4c4d0630)

    Nothing happens after that, it just stays there.

    I have the recommended specs on my rig.

    I ran installation repair.

    I tried this on Uplay client as well as epic games. No change.

    I closed unnecessary background applications.

    I also closed the RGB handler on my rig because sometimes that trips easy anti cheat or similar cheating violations with a false positive.

    It just simply refuses to get past the loading logo.

    I use Windows 10.

  • PilgriM_71
    9 posts

    ISSUE WORKAROUND CONFIRMED: So if you have room on your C drive (needs around 47GB) free, copy the whole game folder to a folder there, shut down Ubisoft Connect, change one character in the name of the original game directory, restart Ubisoft Connect, go to Valhalla game properties, it will have an option below download for you to look for game files, click this, select the game directory name on the C drive (I made Ubisoft\Assasin's Creed Valhalla), it will scan the files and then play.

    Absolutely ridiculous that the game cannot handle being on a separate drive (I think its more to do with Microsoft Storage Devices), also its performance for me is terrible, so I can barely play anyway, I got an average of 5 fps in the benchmark, my system is an i7 and I have two GTX 970's in SLI, not that recent but it chews up and spits out all the previous Assasin's Creed games...

  • arcane_eclipse
    2 posts

    @ubi-spud it works

  • krvpt.
    63 posts

    @arcane_eclipse not for all, still not starting up

  • TheZenWalker
    4 posts

    Tried uninstalling and reinstalling the game. No change.

  • AccelStardust
    3 posts

    @boggo3 what exactly do you have to download? Only the first 2 files vcredist x64 and x86? Cause I did and still not working.

  • krvpt.
    63 posts

    @thezenwalker same is happening to me.. literally just talked to a support agent, we're gonna have to wait for a patch..

  • AccelStardust
    3 posts

    @pilgrim_71 doesn't even work for me, I have a 2070 super RTX, i9 cpu so idk how the hell it works for some and not for others.

  • emmaj95
    66 posts

    @accelstardust I also have a rtx 2070 super and am having the same issue. Ive tried three different hard drives— c drive ssd with the OS, a hhd drive, and an nvme drive. None worked. Sort of wondering if its a graphics issue, but I’m no expert.

  • PilgriM_71
    9 posts

    @accelstardust Damn, sorry to hear it didn't work, I also tried the symlinking option, that worked too, so for me it hates the D drive, the graphical performance I saw was also a worry, never had a Creed game play that poorly before, maybe the issue is deeper thank just where the game is...

  • StewedSummer72
    4 posts

    @skybluesmith so supposedly that some banks denied the transaction after purchasing it even thats what Microsoft told me after ubisoft said to go to Microsoft cause its there issue so check with your banks again on the status there & your order history's on your consoles or pc to confirm its purchase

  • Vihu123
    8 posts

    Does anyone have fix for the game crashing after ubisoft logo appears
    I preordered damn thing, so come on ubisoft I want my game to work!

  • TheZenWalker
    4 posts

    @krvpt Of course we are.

  • Yukiyoroi
    9 posts

    @crazydonkey88
    Sure looks like it. I checked my logs and saw something similar. Meanwhile, Task Manager and Cacheman were both showing that the executable was loaded in memory, but using zero CPU while taking up about 630MB of RAM. So just based on the logs, it looks as if Ubi Connect is disconnecting the game after it loads, but before it gets far enough for the game to start, but at the same time, it's leaving it in memory so the player is expecting it to DO something, instead of realizing that it's crashed until the splash screen doesn't proceed to the start menu.

  • Darlisz
    1 posts

    Its a driver problem guys xd. Just uninstall drivers start the game.do your graphical settinngs then download drivers

  • Sir-Sejami99
    4 posts

    Hello :

    I was unable to play for three days before i found a rather strange solution (which worked for me) So you can try it too, i hope it will work for you as well.

    For the record, my game always crashed at launch (game icon with double axes, or at the "seizure" warning). And my game is currently on the same directory as launcher + windows

    The solution I found :

    • Plug your main display/screen to the HDMI port of your graphical (here is a link that can help you ( https://appuals.com/fix-nvidia-display-settings-are-not-available/#:~:text=The%20error%20message%20%E2%80%9CNVIDIA%20display,attached%20to%20an%20NVIDIA%20GPU.&text=msc%E2%80%9D)%20and%20disable%20your%20GPU,disabling%20it%2C%20enable%20it%20again.: (https://appuals.com/fix-nvidia-display-settings-are-not-available#:~:text=The%20error%20message%20%E2%80%9CNVIDIA%20display,attached%20to%20an%20NVIDIA%20GPU.&text=msc%E2%80%9D)%20and%20disable%20your%20GPU,disabling%20it%2C%20enable%20it%20again.) )
    • in the Nvidia control panel set anti-aliasing to off


    Did that and relaunched the game and it worked perfectly on the first try !! now it launches every time. No more crash/freeze at "seizure" screen

    Tell me if it works for you too !

  • Sir-Sejami99
    4 posts

    Hello :

    I was unable to play for three days before i found a rather strange solution (which worked for me) So you can try it too, i hope it will work for you as well.

    For the record, my game always crashed at launch (game icon with double axes, or at the "seizure" warning).Oh and since it was recommended : my game is currently on the same directory as launcher + windows

    Here's the solution :

    • Plug your main display/screen to the HDMI port of your graphical (here is a link that can help you ( https://appuals.com/fix-nvidia-display-settings-are-not-available/#:~:text=The%20error%20message%20%E2%80%9CNVIDIA%20display,attached%20to%20an%20NVIDIA%20GPU.&text=msc%E2%80%9D)%20and%20disable%20your%20GPU,disabling%20it%2C%20enable%20it%20again.: (https://appuals.com/fix-nvidia-display-settings-are-not-available#:~:text=The%20error%20message%20%E2%80%9CNVIDIA%20display,attached%20to%20an%20NVIDIA%20GPU.&text=msc%E2%80%9D)%20and%20disable%20your%20GPU,disabling%20it%2C%20enable%20it%20again.) )
    • in the Nvidia control panel set anti-aliasing to off


    Did that and relaunched the game ==> worked perfectly on the first try, now it launches every time. No more crash/freeze at "seizure" screen

    Tell me if it works too !

Suggested Topics