Welcome to discussions

Quick Suggestions

  • TheZenWalker
    4 posts

    Tried uninstalling and reinstalling the game. No change.

  • Ubi-Borealis
    Ubisoft Support Staff 3625 posts
    Best Answer

    Hello there!

    I'm sorry to hear that you're encountering trouble when launching Assassin's Creed: Valhalla, and that the game freezes on the splash screen. This issue was marked as resolved by the development team following TU 1.1.1. Thanks to those who have taken the time to share how they were able to resolve their freeze-on-launch issues in this thread!

    If you are still encountering issues when launching the game, please ensure that you have first tried these basic PC troubleshooting steps, as these help to resolve common issues behind freezing and crashing. Please note that there can be multiple causes behind a crash or freeze, so we would recommend trying all of these steps as a first step.

    Additionally, if you have the game installed on a Microsoft Storage Space Drive, we would recommend moving the game to an alternative ha soft Storage Space Drives, and we recommend installing the game on a hard drive that also has the OS installed. rd drive (ideally the same drive that your OS is installed on). It is important to note that most of our games do not support Microsoft Storage Space Drives, and this can cause problems when launching the game.

    If the issue still persists after trying these steps, please can you open a support ticket so our team can take a closer look at your system files. You can open a support ticket via the Ubisoft Support website or by starting a live chat. When opening a support ticket, please have the following ready to include in your support ticket:

    • An MSinfo and a DxDiag
    • The troubleshooting steps you have already tried
    • If this issue has persisted since installing the game, or if it only started after a specific event (such as a game update or a system update)


    If you purchased the game from the Ubisoft Store and would like to seek a refund, you are also welcome to open a support ticket to submit a refund request. These requests are considered against our digital and physical refund policies on a case-by-case basis. If you do not meet the eligible criteria, we are unable to guarantee that a refund will be granted.

    @Thunderchild_UK - Apologies for the delayed response. Thanks for sharing what troubleshooting steps you have already tried. I'm glad to hear that you've been able to resolve the issue. Thanks for sharing what worked for you!

    @skyhawg - I understand that you've been able to resolve this issue after opening a support ticket. If you're still encountering trouble with crashes/freezes, please don't hesitate to update us so we can take a closer look.

    Thanks! 😊

    Official Response
  • AccelStardust
    3 posts

    @boggo3 what exactly do you have to download? Only the first 2 files vcredist x64 and x86? Cause I did and still not working.

  • krvpt.
    63 posts

    @thezenwalker same is happening to me.. literally just talked to a support agent, we're gonna have to wait for a patch..

  • AccelStardust
    3 posts

    @pilgrim_71 doesn't even work for me, I have a 2070 super RTX, i9 cpu so idk how the hell it works for some and not for others.

  • emmaj95
    66 posts

    @accelstardust I also have a rtx 2070 super and am having the same issue. Ive tried three different hard drives— c drive ssd with the OS, a hhd drive, and an nvme drive. None worked. Sort of wondering if its a graphics issue, but I’m no expert.

  • PilgriM_71
    8 posts

    @accelstardust Damn, sorry to hear it didn't work, I also tried the symlinking option, that worked too, so for me it hates the D drive, the graphical performance I saw was also a worry, never had a Creed game play that poorly before, maybe the issue is deeper thank just where the game is...

  • StewedSummer72
    4 posts

    @skybluesmith so supposedly that some banks denied the transaction after purchasing it even thats what Microsoft told me after ubisoft said to go to Microsoft cause its there issue so check with your banks again on the status there & your order history's on your consoles or pc to confirm its purchase

  • Vihu123
    8 posts

    Does anyone have fix for the game crashing after ubisoft logo appears
    I preordered damn thing, so come on ubisoft I want my game to work!

  • TheZenWalker
    4 posts

    @krvpt Of course we are.

  • Yukiyoroi
    9 posts

    @crazydonkey88
    Sure looks like it. I checked my logs and saw something similar. Meanwhile, Task Manager and Cacheman were both showing that the executable was loaded in memory, but using zero CPU while taking up about 630MB of RAM. So just based on the logs, it looks as if Ubi Connect is disconnecting the game after it loads, but before it gets far enough for the game to start, but at the same time, it's leaving it in memory so the player is expecting it to DO something, instead of realizing that it's crashed until the splash screen doesn't proceed to the start menu.

  • Darlisz
    1 posts

    Its a driver problem guys xd. Just uninstall drivers start the game.do your graphical settinngs then download drivers

  • Sir-Sejami99
    4 posts

    Hello :

    I was unable to play for three days before i found a rather strange solution (which worked for me) So you can try it too, i hope it will work for you as well.

    For the record, my game always crashed at launch (game icon with double axes, or at the "seizure" warning). And my game is currently on the same directory as launcher + windows

    The solution I found :


    Did that and relaunched the game and it worked perfectly on the first try !! now it launches every time. No more crash/freeze at "seizure" screen

    Tell me if it works for you too !

  • Sir-Sejami99
    4 posts

    Hello :

    I was unable to play for three days before i found a rather strange solution (which worked for me) So you can try it too, i hope it will work for you as well.

    For the record, my game always crashed at launch (game icon with double axes, or at the "seizure" warning).Oh and since it was recommended : my game is currently on the same directory as launcher + windows

    Here's the solution :


    Did that and relaunched the game ==> worked perfectly on the first try, now it launches every time. No more crash/freeze at "seizure" screen

    Tell me if it works too !

  • CrazyDonkey88
    100 posts
  • Pozmex74
    1 posts

    When i try to start the game it stops att the first loading pic.
    Pc spec
    Cpu I7 6700
    Gpu Gtx 980 ti 6gb
    Ram 32gb
    Op Win 10 x64bitundefined

  • CrazyDonkey88
    100 posts

    @pilgrim_71 Don't work

    undefined

  • myspulin001
    1 posts

    @ubi-spud Well that is nice but my OS is on different disk from some reason. I don´t have space on disk where my OS is for 50 GB game, that´s in the first place the main reason why I want to have it on another disk than my OS. That´s not a solution. It just means that I can´t play it before it is fixed.

  • karthikram93
    2 posts

    @ubi-spud My game still refuses to go past the splash screen! I've done everything from verifying game files to uninstalling and reinstalling to restarting windows over a dozen times. NOTHING WORKS. I was playing the game just fine this morning and when i went to play in the afternoon it just wouldn't launch.

    NOW I CAN'T EVEN INSTALL UBISOFT CONNECT. It says the Ubisoft game launcher.exe cannot be opened when I try to install! Please Help!!!

  • trolsopol
    31 posts

    Hi guys, I just got the game on Uplay, but can't start it at all. I get the splash screen and then the game crashes 2 seconds after with this very helpfull error:
    undefined

    I'm running Ryzen 1800x, 32 GBs Gskill FlareX ram, 2080 TI GPU. I've updated to the latest nvidia drivers 457.30 with a clean install, installed the latest VC++ redistributable version (it's newer than the one the game installs, but neither version works). Tried to remove overclocking as some people suggested that online, but it didn't work.
    I verified the game files and everything was "fine". Saw that people were reporting problem with previous assassin's creed games (Origins, Odysey), where the games are not on the main(system) drive, or on an SSD, tried to move the files around nothing helped. I've not had problems with other Ubisoft titles on this machine (to be honest I don't think i've had problems with any games), i have wildlands and breakpoint (i think this one is on the same engine

  • karthikram93
    2 posts

    I had AC Valhalla installed and it was working fine till this afternoon when the game refused to go beyond the launch splash screen. Then I verified all files were good, still won't launch. Then i tried uninstalling and reinstalling, didn't work. Then, because Ubisoft connect had crashed due to some "Unrecoverable Error" I decided to uninstall it and try to reinstall it. Except now I can't even install the launcher because it says its not able to write the Ubisoft Game launcher.exe. I have no idea what to do now.

Suggested Topics

Community Details

174
Online
193.4k
Users
32.6k
Topics
163.2k
Posts