Welcome to discussions

Quick Suggestions

  • CrazyDonkey88
    100 posts

    @ubi-swaggins u will lose a lot of players due to yr incompetence as a company. But u don't care i know.
    If anyone of u care this game would look differently

  • Ubi-Borealis
    Ubisoft Support Staff 3625 posts
    Best Answer

    Hello there!

    I'm sorry to hear that you're encountering trouble when launching Assassin's Creed: Valhalla, and that the game freezes on the splash screen. This issue was marked as resolved by the development team following TU 1.1.1. Thanks to those who have taken the time to share how they were able to resolve their freeze-on-launch issues in this thread!

    If you are still encountering issues when launching the game, please ensure that you have first tried these basic PC troubleshooting steps, as these help to resolve common issues behind freezing and crashing. Please note that there can be multiple causes behind a crash or freeze, so we would recommend trying all of these steps as a first step.

    Additionally, if you have the game installed on a Microsoft Storage Space Drive, we would recommend moving the game to an alternative ha soft Storage Space Drives, and we recommend installing the game on a hard drive that also has the OS installed. rd drive (ideally the same drive that your OS is installed on). It is important to note that most of our games do not support Microsoft Storage Space Drives, and this can cause problems when launching the game.

    If the issue still persists after trying these steps, please can you open a support ticket so our team can take a closer look at your system files. You can open a support ticket via the Ubisoft Support website or by starting a live chat. When opening a support ticket, please have the following ready to include in your support ticket:

    • An MSinfo and a DxDiag
    • The troubleshooting steps you have already tried
    • If this issue has persisted since installing the game, or if it only started after a specific event (such as a game update or a system update)


    If you purchased the game from the Ubisoft Store and would like to seek a refund, you are also welcome to open a support ticket to submit a refund request. These requests are considered against our digital and physical refund policies on a case-by-case basis. If you do not meet the eligible criteria, we are unable to guarantee that a refund will be granted.

    @Thunderchild_UK - Apologies for the delayed response. Thanks for sharing what troubleshooting steps you have already tried. I'm glad to hear that you've been able to resolve the issue. Thanks for sharing what worked for you!

    @skyhawg - I understand that you've been able to resolve this issue after opening a support ticket. If you're still encountering trouble with crashes/freezes, please don't hesitate to update us so we can take a closer look.

    Thanks! 😊

    Official Response
  • CrazyDonkey88
    100 posts

    @amidream I just applied for refund

  • CrazyDonkey88
    100 posts

    @trolsopol nothing change so far. I constantly try to reinstall game and still the same

  • lesvannes
    4 posts

    @trolsopol Bummer! I hope the issue is fixed for everyone soon.

  • emmaj95
    66 posts

    @sir-sejami99 this did not work in my case

  • LeGueiz
    4 posts

    @mreclypse thx! this worked for me.

    my problem was that i got stuck at the loadingscreen after the intro vid.

  • trolsopol
    31 posts

    @crazydonkey88 tried that on tuesday, still no response...

  • Mdill6
    1 posts

    Whenever I try to launch the game from Ubisoft or Epic, it brings up the small box with the AC logo like it would be launching and then doesn’t proceed past that. I’m on PC with a 2080 and a R7 2700X. I don’t get any errors at all. I’ve verified game cache on each separate launcher, deleted and redownloaded, updated all drivers, and it won’t launch.

  • CrazyDonkey88
    100 posts

    @mdill6 plenty of ppl have this since game started, ubisoft don't care about this so all we can do is wait

  • HawkSE
    9 posts

    Okay so I have gotten the game to launch now.

    But it only works as follows, and that's if: Windows + Ubisoft Connect + AC Valhalla are all installed on the same SSD.

    This was a temporary solution for me, as I barely had enough room to move AC Valhalla onto this drive to test. I suspect this is not viable for lots of users, but it is worth checking.

    I've asked Ubisoft in my Support ticket to find a proper solution to this problem since I have: Anno 1800, AC Odyssey, The Crew 2, and Watch Dogs Legion all installed without this requirement.

  • CrazyDonkey88
    100 posts

    @legueiz lucky u

  • CrazyDonkey88
    100 posts

    @hawkse i tried this many times my friend...

  • ScorpionDK27
    14 posts

    @mdill6 i have the same issue. my pc is way better than the requirements and i tried EVERY step i could find and i reinstalled the game 2 times bu nothing works. and there is no answer from ubisoft and even the support told me just to do the steps i already knew and tried. i mean i just want to play the game i paid 90$ for a game that doesnt even lauches

  • CrazyDonkey88
    100 posts

    @jsjordache1 I know that feeling, i'm stuck with this error since game starts. It just show me how ppl in ubisoft don't care about this

  • ScorpionDK27
    14 posts

    @crazydonkey88 yea and i have the issue since release. i tried it every day and there is still just nothing. i am very disappointed

  • CrazyDonkey88
    100 posts

    @jsjordache1 and other players are playing the game right now...

  • cemtasan
    2 posts

    when I press the play button , ac valhalla iconic screen pops up and vanishes after few seconds , I have noticed something that I cannot install verdict 1/5 files after the game installization and when I press the play button game is trying to install them but rapidly it pass to cloud files sync but game cant open !!! please help me!!! UBİSOFT!!!! you took my money but I cant even play the game !!!!!

  • CrazyDonkey88
    100 posts

    @cemtasan not only u having this problem. Trust me. For now, there's no fix for that. Or maybe some solutions which you can find here, will help you.
    If not, we need to wait and pray to Odin for solution.

  • CloakedDrifter
    3 posts

    @charleye30 Same crashes (mostly at title "click to continue" screen). Very similar build.

    Win10
    AMD 3700x
    AMD RX 5700xt
    32G ram
    1TB NVMe SSD (single drive - Win and AC:V installed on same drive)

    Windows and GPU drivers fully updated to stable builds (NOT preview, beta, experimental)
    All GPU/CPU settings set to standard/default - no overclocking

  • cemtasan
    2 posts
    @crazydonkey88 And also I have reinstall the game 2 times and  do every solution options in this forum except installing the game  to a different drive than The one with Windows installed but I have only C drive in my computer !!!! what kind of  professionalism is that!!!! They took our money by pre oerder nonsense and there are many many bugs after the release


Suggested Topics

Community Details

101
Online
192.1k
Users
32.3k
Topics
161.9k
Posts