Welcome to discussions

Quick Suggestions

  • dtrexninja
    3 posts

    @max-_-33 no I was told I was getting a full game good job I did not get collectors edition my figure would of been an empty box with a loading Icon

  • Ubi-Borealis
    Ubisoft Support Staff 2812 posts
    Best Answer

    Hello there!

    I'm sorry to hear that you're encountering trouble when launching Assassin's Creed: Valhalla, and that the game freezes on the splash screen. This issue was marked as resolved by the development team following TU 1.1.1. Thanks to those who have taken the time to share how they were able to resolve their freeze-on-launch issues in this thread!

    If you are still encountering issues when launching the game, please ensure that you have first tried these basic PC troubleshooting steps, as these help to resolve common issues behind freezing and crashing. Please note that there can be multiple causes behind a crash or freeze, so we would recommend trying all of these steps as a first step.

    Additionally, if you have the game installed on a Microsoft Storage Space Drive, we would recommend moving the game to an alternative ha soft Storage Space Drives, and we recommend installing the game on a hard drive that also has the OS installed. rd drive (ideally the same drive that your OS is installed on). It is important to note that most of our games do not support Microsoft Storage Space Drives, and this can cause problems when launching the game.

    If the issue still persists after trying these steps, please can you open a support ticket so our team can take a closer look at your system files. You can open a support ticket via the Ubisoft Support website or by starting a live chat. When opening a support ticket, please have the following ready to include in your support ticket:

    • An MSinfo and a DxDiag
    • The troubleshooting steps you have already tried
    • If this issue has persisted since installing the game, or if it only started after a specific event (such as a game update or a system update)


    If you purchased the game from the Ubisoft Store and would like to seek a refund, you are also welcome to open a support ticket to submit a refund request. These requests are considered against our digital and physical refund policies on a case-by-case basis. If you do not meet the eligible criteria, we are unable to guarantee that a refund will be granted.

    @Thunderchild_UK - Apologies for the delayed response. Thanks for sharing what troubleshooting steps you have already tried. I'm glad to hear that you've been able to resolve the issue. Thanks for sharing what worked for you!

    @skyhawg - I understand that you've been able to resolve this issue after opening a support ticket. If you're still encountering trouble with crashes/freezes, please don't hesitate to update us so we can take a closer look.

    Thanks! 😊

    Official Response
  • Max-_-33
    13 posts

    @dtrexninja haaaaa MVP comment love it

  • ShenoXDfug
    15 posts

    i just got an error while reinstalling the game. Error: "Microsoft Visual c++ Runtime Libary". Im not sure if it has something to do with the Game but after that, i reinstalled also supporting software like they mentioned in this post https://support.ubisoft.com/en-gb/faqs/25596/Reinstalling-Supporting-Software/ but it did not help me and im still stuck in infinity loading screen. Maybe it helps someone to figure out the problem

  • CLONAKU
    1 posts

    Redlight- you are the best!! its works perfectly!!

  • S1qh
    3 posts

    @redlight This fixed it for me, thanks dude!

  • hugRmunR_
    7 posts

    As the topic states, I'm stuck on the splash screen. Lovely logo and all, but I would like to be able to play 😄

    All drivers are up to date, restarted the PC a few times, did the repair install etc.

  • Max-_-33
    13 posts

    @s1qh how u do it im no good when it come to Edit stuff

  • Acdcwrocker
    3 posts

    @redlight I don't understand the whole creating symbolic link files. Is there a video that explains it. Or can you give me a very basic 101? Apologies I didn't expect to have to do this but I appreciate you posting to help everyone

    Edit: and to clarify its more that I don't understand if symbolic links replace the original files in the installation folder and then you keep the originals on the main drive.

  • Dx2.LFT
    38 posts

    if u release finished game it should be atleast working and not getting stuck in logo pop-up
    this is last game what i will ever buy from ubisoft, this not how u do customer service, always major issues and u charge 100+e for premium game
    only premium again is just the price like with many other games before, never smooth launch

  • Acdcwrocker
    3 posts

    With the files and folders within the video and sound folders do i need to link each file separately or can i just create a single link for the sound folder and a single link for the video folder?

  • Captain_Kayn
    3 posts

    Hi there,
    I have encountered some dificulties playing the latest game. This is what I have tried so far:

    • Restarting my pc
    • Updating my drivers
    • Opening the exe. file using administrator
    • Disabeling all overlays
    • Controlling files

    Is there anything else I can do to make this game work?
    My game get's stuck on the splash art screen which pops up when the game tries to load.

    I just tried to run Assasins Creed Odyssey and that works from which I presume that my required settings should be ok.

  • Acdcwrocker
    3 posts

    Ok, so i got it to work, for those who are confused try this.

    • Download and install the file included in @Redlight post


    • In your OS drive (usually your C : drive) create two folders one for the videos and one for the sound files.


    • Open the ACV folder and keep them next to each other.


    • Drag all the files and folders from the video and sound folder in the corresponding C : folder (cut and paste don't copy them.)


    • Right click the sound folders and select "pick link source" then in the empty original ACV folders right click and "Drop as" - "Symbolic Link" (make sure you do this for every file, and yes you can batch it with selecting all the files.)


    • Do the same again with the files in the video folder. Note Do not try to batch link the folders as it wont work and you have to do each one individually but instead select "drop as" - "Junction"


    • You can delete any language files you don't want in order to save some space.


    If you make a mistake don't worry just delete the .sym file or the junction and do it again.

    Launch the game and give it a min or two and you should be good to go. 🙂

    Thanks again @Redlight for the post. I'm gonna put on a brew now. Got a long night ahead!

    If you are stuck just mention me i will have it open on my phone but i'm not techy so i was free balling it but can parrot what i figured out 😛


    Edit: The C : was coming up as a emote aha

  • MicR0Mat1C
    2 posts

    @captain_kayn im having the same problem ? Found any other fixes?

  • Freddygoldie
    1 posts

    I'm having the same problem. After the first intro when beginning a new game, the loading screen is loading forever. any fix on this issue?

  • Max-_-33
    13 posts

    @acdcwrocker i sent u a PM

  • Captain_Kayn
    3 posts

    @freddygoldie
    @MicR0Mat1C

    I found this article that I used to try and fix my problem: https://quoramarketing.com/fix-assassins-creed-valhalla-crash-on-startup-loading-screen-or-crashing-after-splash-screen/

    Let me know if some of you guys found a fix. Much gratitude in advance.

  • VictusKristus
    8 posts

    @acdcwrocker Hey! Thanks for clarifying, and thank you @Redlight for providing a possible solution! I'm curious, when you launch the game after completing this setup, what is on the screen? And do you launch from the folder as administrator, or do you just press play in the Ubisoft client? I just get the Ubisoft connect, with the rainbow colors as a background. No sign of the AC logo if I only press "Play".

  • Dx2.LFT
    38 posts

    even re-downloaded game and re-installed on same drive where is uplay/ubisoft connect and still stuck in small screen of valhalla logo

  • Max-_-33
    13 posts

    i can not see pick link sorce

  • kardeon77
    5 posts

    Same problem here. 'My game get's stuck on the splash art screen which pops up when the game tries to load'.
    I have tried everything but i have not found a solution.
    All my assassin creed games launch correctly. Only Valhalla crashs

Suggested Topics

Community Details

19
Online
138.5k
Users
24.2k
Topics
125.7k
Posts