Welcome to discussions

Quick Suggestions

  • 0 Likes/1211 Replies/15910 Views
    MrFactorX
    2 posts

    Update:

    @ryanhowls @emmaj95

    I was able to contact support for a refund and they actually took care me after explaining the situation for a full refund to my credit card used, all within an hour. I am still interested in playing the game. I may try back in 6 months or so.
    Good luck guys.

  • assassin4EVERS
    4 posts

    @ubi-ginge should it be using GPU on start up? looking at task manager, the game is running at 12-13% CPU and 0 GPU. This may be an error on my system if this is the case...

  • Andrepisa89
    9 posts

    @mrgausser

    So the vhd must be in bootcamp? I also play with bootcamp. I try

  • Ubi-Spud
    Ubisoft Support Staff 702 posts

    Hey there, we are still looking into this but have identified that it can happen due to the game being installed on a Microsoft Storage Space Device. Please see this FAQ to resolve. If it isn't on one of these drives, please go through this guide. Thanks for your patience!

    Official Response
  • AdamMayhem
    1 posts

    @vihu123 The solution to the problem is to update Windows to the latest version

  • Ubi-Spud
    Ubisoft Support Staff 702 posts

    Hey folks, we're looking into this at the moment, however some have gotten around this by installing the game on the same drive as their OS, and disabling MSI Afterburner if installed. Thank you for your patience!

    Official Response
  • ScorpionDK27
    14 posts

    @ubi-raziel i dont get an error message im just stuck at the splash screen and when i look in the task manager the game does nothing. i tried every troubleshooting step and reinstalled the game several times but nothing works

  • gnowitzki
    2 posts

    It also freezes on the benchmark.
    In the main game, it freezes after a few minutes.
    The WD Region works fine, but it won't play unless you get a patch that you can play normally.
    GTX1660S 6GB
    Corei7 10700 2.9Ghz
    16GB

  • ScorpionDK27
    14 posts

    @ubi-spud will there be an update or a patch for this issue because its unlikely that thousands of players have problems with their pc

  • ScorpionDK27
    14 posts

    @adammayhem i did it but it still doesnt work

  • narot23
    7 posts

    @crazydonkey88 Simply go to NVIDIA's website, download the prior driver (it will show on the list), then run the installer, select Custom Installation, tick Clean Installation, and you should be good to go. One caveat, it will remove any custom settings you've made in NVIDIA Control Panel or GeForce Experience.

  • narot23
    7 posts

    @ubi-spud I was able to resolve the issue by reverting to the previous NVIDIA driver (457.09). The new "Game Ready" driver was causing my Spash Screen lockup.

  • narot23
    7 posts

    @narot23 EDIT AND NOTE: I was able to resolve the issue by reverting to NVIDIA Driver 457.09... I'm not sure why but the "Game Ready" driver was causing the issue on my PC.

  • ALHITCH87
    19 posts

    @ubi-spud

    Hello

    I have been posting on a forum to try and get help and tried doing a support ticket to no avail as the option has been turned off.

    Like many other gamers on here I have encountered the splash screen to crash error.
    I have tried numerous work arounds to no joy. I am aware games come with bugs and have to be optimized. I just want to know who I can talk to and submit the specs of my machine dxdiag and msinfo32 files to so I can get some professional help ... (not a joke about my state of mind either lol)

    I love the Assassins Creed games, the books, the characters, the lore. I have spent so many hours in AC Unity - I love the work you guys do, but Valhalla has left such a sour taste in my mouth I honestly doubt I'll preorder another Assassins Creed game again - not saying it as a threat, but as a passionate gamer who loves The Creed.

    Not angry at you guys at all, I have no idea how much work goes into the game but I fully appreciate it.

    Just disappointed that I cannot get this game to run.

  • Andrepisa89
    9 posts

    @mrgausser

    Ok the game start with the VHD. Another question, I also have iMac and I play in bootcamp. in "full screen" mode, the game is not in "full screen", but the game is only in a central line. I must play in "window" mode for play in "full screen", but in this way I cannot set the resolution correctly. Have you this problem? if you haven't, how can I resolve it? Thanks!

  • NeldorAmnell
    1 posts

    @simtty This absolutely WORKS when you're stuck on the Valhalla logo before the game itself opens.
    It looks like a voodoo magic, but honestly it works. The whole fix took about 2 min to do. Thanks man!

  • Yoga030391
    2 posts

    I also have same issues here
    My Spec

    CPU : i5 6500 @3.2 Ghz
    RAM : 32 GB
    GPU :GTX 1060 6gb
    all drivers already updated

    still freezing and not open when loading
    I'm starting to stream but cancelled , so frustating,!!!!!!

  • rookitru
    1 posts

    Hi there. Any news how to launch game if it crash on splash screen ?
    Tried to reisntall, rename, move audio vidio files, and otheres was wrote on forum - none of these helped.

    Thanks

  • Exaudio
    19 posts

    @rookitru Not yet. Ubi has yet to confirm this issue and release a quick patch. We have to wait I'm afraid

  • Lomig_1983
    8 posts

    @ubi-raziel Hello,
    Funny that you mention it : yesterday, for the first time, I had the crash error message. And for the first time too, the splash screen remained (freezing)... (I just "killed" lots of background apps beforehand). In general, the splash screen just pops up for a few seconds. And it got back to this popping routine today...

    I don't have any overlay/overclocking software, but just to be sure, I'll check my Nvidia settings now. Then, I'll get back to you...

Suggested Topics