Welcome to discussions

Quick Suggestions

  • 0 Likes/1211 Replies/15063 Views
    4 posts


    The problem has persisted whether I have the game installed on the same drive as my operating system, or not. I have tried installing it to either OS drive or non-OS drive, no change... link sourcing the audio and video files to a separate drive or OS drive during both installations. Nothing changed it.

    Additionally, I don't use MSI afterburner. That's no factor.

    I don't think it's a problem with people's systems. I can run Odyssey, and even Origins just fine, and in fact, I've been playing Odyssey in the interim. I'm pretty sure this is a software product issue and will require a patch to correct it.

    I don't know what happened with the development team with Valhalla, but this product is NOT ready for launch. It needs at least another few months of testing and patching.

  • Yukiyoroi
    9 posts

    Weird thing is, I had to move my game to an SSD to make it work.
    That's what's so weird about this start screen problem. There's no telling what causes it or what fixes it, and customer support fixating on the MSSD thing as the cause is not helping all the people who don't even have MSSD installed on their systems.

  • prmax007
    3 posts

    I have the same issue. My system meets all specs (Ryzen 3900X, RTX 2080, 32GB Ram, DX12, Win 10 pro with all updates) and I have done the recommended troubleshooting, no MSI burner and all background apps not running. ACO, Ghost Recon Breakpoint ran fine. I have uninstalled game and installed on C:, same issue. Removed uconnect which in turn removed my other games 😞 and installed uconnect again and currently downloading ACV (third time) again and putting it back on my game drive SSD. Do not expect it to work and now I will have to redownload ACO and GRBrekpoint again 😞 What a cluster...Please fix this...

  • Anavalx93
    1 posts

    Wont load after starting game just shows me the AC symbol(in minimized window) and nothing else

  • Invisible-Gun
    1 posts

    latest drivers/admin rights/installed on ssd/overkill system what's the issue ubisoft?

  • emmaj95
    66 posts

    @yukiyoroi Yep I have tried installing it on a SSD, an HDD, and an NVME drive and not been able to fix it.

  • bramarts
    1 posts

    if I want to start my game the logo of the game gets stuck and then does not continue I have already downloaded the game again but that does not work who knows what works

  • emmaj95
    66 posts

    @emmaj95 By the way-- I did uninstall EVGA Precision to see if that was the problem but I am still having the problem.

  • HawkSE
    9 posts

    I have had an ongoing Support Ticket, though nothing I've tried has worked EXCEPT one thing, which is not viable:

    Install Ubisoft Connect + AC Valhalla onto the Windows SSD. This doesn't work for me due to my Windows SSD being *just* for that, and nothing else. I immediately ran out of space testing this.

    This is what Support told me today, and I could not be more upset at this response:

    Thank you for contacting Ubisoft Customer Support. I will be assisting you today.
    We apologize for the inconvenience.
    If the game works when it is installed on the drive with windows then at this time we would have no further troubleshooting as we recommend the game be installed on the same drive to have the best communication with the operating system.

  • il.cirozse
    1 posts

    i've tried to run ac valhalla but the game is stuck in mini window,can someone help me??

  • Shiftys
    1 posts

    I have the game Via Ubisoft+ whenever I hit the play it comes up with this screen :undefined

    I timed it and it takes almost 4 minutes for the game to launch. Its so annoying. The game is installed on an SSD i don't understand this is the only game this is happening with. Once I'm actually in game everything runs fine. Anyone know a way to fix this? I've tried verifying integrity of the files it didn't fix anything.

  • Chefster_
    4 posts

    I have had this issue multiple times,

    Before it would crash once or twice and then i could play, but now its constant cant open the game
    Tried verifying and redownloaded it.

    I paid 100 euro's for a game that i cant open nor can find a solution to. is this really what ubi has turned into? I always played your games with love but this is absurd.

    Does someone have a fix? if so please let me know. otherwise i would like to see or know how i can get a refund


  • draakelord
    2 posts

    I was finally able to get valhalla to launch by installing an old sata ssd into my pc and moving the valhalla installation to said ssd.

    For more background, I was able to play valhalla fine on launch day on a 1tb nvme (which was my os boot drive). A few days later I upgraded it to a 2tb nvme and reinstalled windows and moved all of my data over, and was then getting stuck on the splash screen indefinitely. The only notable difference in these windows installs was:

    1) I set my 2tb drive to 4kb sector size, while the old nvme was 512e.
    2) I had to update to the newest windows version (I originally wasn't being served the option to update to 20h2).

    Please note that none of these drives were microsoft storage spaces. I hope this helps someone.

  • Tomzu88
    4 posts

    Actually found the fault from my system, my ssd was for some reason a windows storage device. Found that info by making DxDiag file from command promp. Had to Format drive via BIOS and after that I could make it as new drive in windows. After this my drive was labeled as Samsung SSD instead of microsoft storage device. I was in contact with ubisoft support and their only advice was to try launch game with 2 screens off 😂

  • Clumpybug
    6 posts

    @themadrat1473 So do I. Hopefully, we can get an answer soon. Have you had any luck?

  • Clumpybug
    6 posts

    @cptulfhednar I am having the exact same issue. I would really like a fix so that I can play the game I bought.

  • Clumpybug
    6 posts

    @ubi-baron I have the same problem. ACValhalla.exe shows as running in the task manager, then it just goes away, along with the screen showing the jade green AC logo.

  • Clumpybug
    6 posts

    @thezenwalker I have a similar problem, except that it gets to that screen and then it just goes away. No error message or anything, it just vanishes and that's it.

  • TheSettlerIV
    2 posts

    same problem here. Tried everything, the last thing i will try is to install it on C drive.

  • Chefster_
    4 posts

    @thesettleriv Let me know if that does something !

Suggested Topics

Community Details