Welcome to discussions

Quick Suggestions

  • TheCatsMeowzer
    1 posts

    When I try to launch the game It gets stuck on the splash creen but I have no warnings or anything it's just stuck. I've tried a number of fixes that I've found but none of them have worked. I built my PC 2 months ago and it's more than capable of playing the game. Has anyone had this issue and fixed it?

  • Ubi-Borealis
    Ubisoft Support Staff 3625 posts
    Best Answer

    Hello there!

    I'm sorry to hear that you're encountering trouble when launching Assassin's Creed: Valhalla, and that the game freezes on the splash screen. This issue was marked as resolved by the development team following TU 1.1.1. Thanks to those who have taken the time to share how they were able to resolve their freeze-on-launch issues in this thread!

    If you are still encountering issues when launching the game, please ensure that you have first tried these basic PC troubleshooting steps, as these help to resolve common issues behind freezing and crashing. Please note that there can be multiple causes behind a crash or freeze, so we would recommend trying all of these steps as a first step.

    Additionally, if you have the game installed on a Microsoft Storage Space Drive, we would recommend moving the game to an alternative ha soft Storage Space Drives, and we recommend installing the game on a hard drive that also has the OS installed. rd drive (ideally the same drive that your OS is installed on). It is important to note that most of our games do not support Microsoft Storage Space Drives, and this can cause problems when launching the game.

    If the issue still persists after trying these steps, please can you open a support ticket so our team can take a closer look at your system files. You can open a support ticket via the Ubisoft Support website or by starting a live chat. When opening a support ticket, please have the following ready to include in your support ticket:

    • An MSinfo and a DxDiag
    • The troubleshooting steps you have already tried
    • If this issue has persisted since installing the game, or if it only started after a specific event (such as a game update or a system update)


    If you purchased the game from the Ubisoft Store and would like to seek a refund, you are also welcome to open a support ticket to submit a refund request. These requests are considered against our digital and physical refund policies on a case-by-case basis. If you do not meet the eligible criteria, we are unable to guarantee that a refund will be granted.

    @Thunderchild_UK - Apologies for the delayed response. Thanks for sharing what troubleshooting steps you have already tried. I'm glad to hear that you've been able to resolve the issue. Thanks for sharing what worked for you!

    @skyhawg - I understand that you've been able to resolve this issue after opening a support ticket. If you're still encountering trouble with crashes/freezes, please don't hesitate to update us so we can take a closer look.

    Thanks! 😊

    Official Response
  • emmaj95
    66 posts

    @thecatsmeowzer Seems to be a very common problem with no universal fix right now. Ubisoft has said its a Microsoft Storage Spaces problem but not everyone uses those so hopefully they have a fix on the way.

  • draakelord
    2 posts

    @ubikoality  13267071

  • brt.klly
    1 posts

    @willbold Same problem. Would sit at the splash screen forever. Moved the game files off my NVMe C drive and I could finally get into them game.

    Thanks for the tip.

  • TRINITARION_ST
    1 posts

    @n7_nairobi
    I pre-ordered a digital version I'm having this exact same problem but on the Xbox One S I have uninstalled reinstalled I have reset everything on my system and I still cannot get it to work on the Xbox store it says the only thing I own is the season pass

  • Fov_Way
    4 posts

    I got my game to work by moving the game folder to an external HDD.
    I guess an SSD or a NvME drive is too fast or something.

  • Abhi_TheGamer
    7 posts

    Still not even a single response ! I guess i was not the only one who had issues with it !

  • TheZonk88
    57 posts

    Hello there,

    Stuck at the splashscreen trying to start AC Valhalla? Maybe you're trying to start the Game as Administrator. DON'T
    Remove the "Run Program as Administrator" Flag from the Game.exe

    Navigate to ACV Installation folder, right-click "ACValhalla.exe", open "Properties", one card to the right "Compatibility" and remove the flag of "Run Program as Administrator" -> click OK

    If there wasn't a Flag, i am sorry, you still may be unable to start the Game 😞
    if you had that flag, are you able to start the Game now? Leave your Feedback...



    HD soon

  • TheZenWalker
    4 posts

    @ubi-spud

    The problem has persisted whether I have the game installed on the same drive as my operating system, or not. I have tried installing it to either OS drive or non-OS drive, no change... link sourcing the audio and video files to a separate drive or OS drive during both installations. Nothing changed it.

    Additionally, I don't use MSI afterburner. That's no factor.

    I don't think it's a problem with people's systems. I can run Odyssey, and even Origins just fine, and in fact, I've been playing Odyssey in the interim. I'm pretty sure this is a software product issue and will require a patch to correct it.

    I don't know what happened with the development team with Valhalla, but this product is NOT ready for launch. It needs at least another few months of testing and patching.

  • Yukiyoroi
    9 posts

    @fov_way
    Weird thing is, I had to move my game to an SSD to make it work.
    That's what's so weird about this start screen problem. There's no telling what causes it or what fixes it, and customer support fixating on the MSSD thing as the cause is not helping all the people who don't even have MSSD installed on their systems.

  • prmax007
    3 posts

    I have the same issue. My system meets all specs (Ryzen 3900X, RTX 2080, 32GB Ram, DX12, Win 10 pro with all updates) and I have done the recommended troubleshooting, no MSI burner and all background apps not running. ACO, Ghost Recon Breakpoint ran fine. I have uninstalled game and installed on C:, same issue. Removed uconnect which in turn removed my other games 😞 and installed uconnect again and currently downloading ACV (third time) again and putting it back on my game drive SSD. Do not expect it to work and now I will have to redownload ACO and GRBrekpoint again 😞 What a cluster...Please fix this...


  • Anavalx93
    1 posts

    Wont load after starting game just shows me the AC symbol(in minimized window) and nothing else

  • Invisible-Gun
    1 posts

    latest drivers/admin rights/installed on ssd/overkill system what's the issue ubisoft?

  • emmaj95
    66 posts

    @yukiyoroi Yep I have tried installing it on a SSD, an HDD, and an NVME drive and not been able to fix it.

  • bramarts
    1 posts

    if I want to start my game the logo of the game gets stuck and then does not continue I have already downloaded the game again but that does not work who knows what works

  • emmaj95
    66 posts

    @emmaj95 By the way-- I did uninstall EVGA Precision to see if that was the problem but I am still having the problem.

  • HawkSE
    9 posts

    I have had an ongoing Support Ticket, though nothing I've tried has worked EXCEPT one thing, which is not viable:

    Install Ubisoft Connect + AC Valhalla onto the Windows SSD. This doesn't work for me due to my Windows SSD being *just* for that, and nothing else. I immediately ran out of space testing this.

    This is what Support told me today, and I could not be more upset at this response:

    Thank you for contacting Ubisoft Customer Support. I will be assisting you today.
    We apologize for the inconvenience.
    If the game works when it is installed on the drive with windows then at this time we would have no further troubleshooting as we recommend the game be installed on the same drive to have the best communication with the operating system.


  • il.cirozse
    1 posts

    i've tried to run ac valhalla but the game is stuck in mini window,can someone help me??

  • Shiftys
    1 posts

    I have the game Via Ubisoft+ whenever I hit the play it comes up with this screen :undefined

    I timed it and it takes almost 4 minutes for the game to launch. Its so annoying. The game is installed on an SSD i don't understand this is the only game this is happening with. Once I'm actually in game everything runs fine. Anyone know a way to fix this? I've tried verifying integrity of the files it didn't fix anything.

  • Chefster_
    4 posts

    I have had this issue multiple times,

    Before it would crash once or twice and then i could play, but now its constant cant open the game
    Tried verifying and redownloaded it.

    I paid 100 euro's for a game that i cant open nor can find a solution to. is this really what ubi has turned into? I always played your games with love but this is absurd.

    Does someone have a fix? if so please let me know. otherwise i would like to see or know how i can get a refund

    Thanks!

Suggested Topics

Community Details

116
Online
193.0k
Users
32.5k
Topics
162.8k
Posts