Welcome to discussions

Quick Suggestions

  • 0 Likes/1211 Replies/15976 Views
    sixstarfool101
    2 posts

    @dragon_arcane83 im still having this same issue

  • lesvannes
    4 posts

    I'm having the same problem--small splash screen with logo, then it crashes. I've also followed all the troubleshooting steps, and submitted a support case.

    For me, booting in safe mode allows the game to start (although it gets stuck in the title sequence and is unplayable due to the disabled drivers). I'm curious if that's the case for you?

  • Meaglev
    3 posts

    @ubi-swaggins it didnt work😠

  • CrazyDonkey88
    100 posts

    Hey
    I bought ult edition of the game but can't play it. After i press "play" button i got splash screen with AC Valhalla logo and then pop up message "Ac Valhalla stop working and will be closed" and that's it. Nothig more. I tried everything but still nothing works

    Anyone have this?

  • ODINN321
    2 posts

    after 8 hours of searching for a solution, and frustration levels i can't describe.
    I finally found a solution that worked for me.

    original source: https://www.reddit.com/r/assassinscreed/comments/jrc7pu/fix_for_infinite_splash_screen/?utm_medium=android_app&utm_source=share

    "I am using Bootcamp and had the same issue. Create a virtual drive (https://www.windowscentral.com/how-create-and-set-vhdx-or-vhd-windows-10) and copy your entire AC folder to this drive. It now works for me (the fix above did NOT work)."

    P.S. i contacted Ubisoft support 2 days ago, i haven't heard from them yet.
    I don't understand that ubisoft isn't getting in touch. because this is a problem for many people.

    UBISOFT S*CK A D*CK!
    looks like they only care about money and not their customers.

  • X-man_HD
    1 posts

    Referenznummer 13179035 same problem as the others.

  • Abhi_TheGamer
    7 posts

    So, i was excited to play an AC game after long time but to my surprise , it is broke as initial launch of Odyssey was. In short, the game just freezes at the boot screen, at the menu or at the start of benchmark. The sound is continuing to play in the back ground. As per system , my pc has Ryzen 7 2700X and GTX 1060 6 GB version for now. i tried to set the game graphics to low and medium or vice versa. Either the game don't lets me or it just freezes. FIX THE GAME.

  • ZeroXtraUK
    10 posts

    Hi there, I don't know if this is worth trying, but I haven't heard anything from Ubisoft support and I'm beginning to give up to be honest. I recently purchased the Ultimate Edition of AC Valhalla, and for some reason my game, no matter what drive it's installed on, will not surpass the splash screen. I've tried near enough everything. From updating my graphics drivers, reinstalling them completely, updating windows, reinstalling Ubisoft connect and the game itself twice. I've even added it to the list of permitted files through windows anti virus nonsense and all that sort of stuff... But nothing, the closest I got was to do what a few people mentioned on some of the older AC titles, by moving the sound files to my :C drive and linking them back to the folder for the game, I managed to get past the splash screen and through the first 2 logo animations... and that was it, then crashed every time. I just don't know what to do, and at this point I've spent an entire day trying to solve this problem, that I shouldn't have to do in the first place. Can someone help in any way? Ubisoft seem to not even respond to any customer service messages, apart from one of the games amazing devs.

  • CrazyDonkey88
    100 posts

    I have the same issue. Those r*** from support don't want to give me my money back cuz game was used {[censored]}
    Honestly i don't know what to do now. I want my money back so hard.

  • kenneth0917
    1 posts

    I press the "start game " in Ubisoft Connect and then the small logo appeared on my screen. And then nothing happen, cannot access to the game. Please help!

  • ZeroXtraUK
    10 posts

    @crazydonkey88 I know... Just frustrating that I've spent money on this game and I can't even get past the splash screen... Why do I feel like this is a consistent problem throughout all of the AC titles at launch, won't be making this mistake again.

  • N1xx0
    5 posts

    Similar issues, what type of graphic card you have?

  • CrazyDonkey88
    100 posts

    Like in the topic. Many of us have this but Ubi is just ignoring this.
    Post below all of u who have the same issue. Maybe we can force them to see this.

  • Tomzu88
    4 posts

    I have same issue and just read updated issue list from today, and this problem wasn't even on the list. I think i've been watching that [censored] splash screen for hours now that i've tried everything to get game launch

  • N1xx0
    5 posts

    My problem is that game freeze on splash screen, sometimes at ryzen intro. Then minimalize itself on taskbar and it is over.) Alt-tab or Alt-enter dont work.

  • ZeroXtraUK
    10 posts

    @n1xx0 GTX 1060 6gb

  • N1xx0
    5 posts

    @zeroxtrauk I have RX 5700 . So it is not a graphic card or driver problem i think.

  • DerEchteJogi
    2 posts

    @zeroxtrauk I have a similar Problem, but my game just straight up crashes. So I'm not even stuck on the "Ubisoft" screen. I only made it past like maybe two times, but then it immediately crashed during the secound logo animation.

  • ZeroXtraUK
    10 posts

    @derechtejogi Yeah like I mentioned, similar thing happened when I linked my audio files through my :C drive (the one with my OS on it)

  • DerEchteJogi
    2 posts

    @kenneth0917 I get past the small logo screen, but after that my game just crashes. Just know that you're not the only one

Suggested Topics