Welcome to discussions

Quick Suggestions

  • 0 Likes/1211 Replies/15061 Views
    4 posts

    @trolsopol Bummer! I hope the issue is fixed for everyone soon.

  • emmaj95
    66 posts

    @sir-sejami99 this did not work in my case

  • LeGueiz
    4 posts

    @mreclypse thx! this worked for me.

    my problem was that i got stuck at the loadingscreen after the intro vid.

  • trolsopol
    31 posts

    @crazydonkey88 tried that on tuesday, still no response...

  • Mdill6
    1 posts

    Whenever I try to launch the game from Ubisoft or Epic, it brings up the small box with the AC logo like it would be launching and then doesn’t proceed past that. I’m on PC with a 2080 and a R7 2700X. I don’t get any errors at all. I’ve verified game cache on each separate launcher, deleted and redownloaded, updated all drivers, and it won’t launch.

  • CrazyDonkey88
    100 posts

    @mdill6 plenty of ppl have this since game started, ubisoft don't care about this so all we can do is wait

  • HawkSE
    9 posts

    Okay so I have gotten the game to launch now.

    But it only works as follows, and that's if: Windows + Ubisoft Connect + AC Valhalla are all installed on the same SSD.

    This was a temporary solution for me, as I barely had enough room to move AC Valhalla onto this drive to test. I suspect this is not viable for lots of users, but it is worth checking.

    I've asked Ubisoft in my Support ticket to find a proper solution to this problem since I have: Anno 1800, AC Odyssey, The Crew 2, and Watch Dogs Legion all installed without this requirement.

  • CrazyDonkey88
    100 posts

    @legueiz lucky u

  • CrazyDonkey88
    100 posts

    @hawkse i tried this many times my friend...

  • ScorpionDK27
    14 posts

    @mdill6 i have the same issue. my pc is way better than the requirements and i tried EVERY step i could find and i reinstalled the game 2 times bu nothing works. and there is no answer from ubisoft and even the support told me just to do the steps i already knew and tried. i mean i just want to play the game i paid 90$ for a game that doesnt even lauches

  • CrazyDonkey88
    100 posts

    @jsjordache1 I know that feeling, i'm stuck with this error since game starts. It just show me how ppl in ubisoft don't care about this

  • ScorpionDK27
    14 posts

    @crazydonkey88 yea and i have the issue since release. i tried it every day and there is still just nothing. i am very disappointed

  • CrazyDonkey88
    100 posts

    @jsjordache1 and other players are playing the game right now...

  • cemtasan
    2 posts

    when I press the play button , ac valhalla iconic screen pops up and vanishes after few seconds , I have noticed something that I cannot install verdict 1/5 files after the game installization and when I press the play button game is trying to install them but rapidly it pass to cloud files sync but game cant open !!! please help me!!! UBİSOFT!!!! you took my money but I cant even play the game !!!!!

  • CrazyDonkey88
    100 posts

    @cemtasan not only u having this problem. Trust me. For now, there's no fix for that. Or maybe some solutions which you can find here, will help you.
    If not, we need to wait and pray to Odin for solution.

  • CloakedDrifter
    3 posts

    @charleye30 Same crashes (mostly at title "click to continue" screen). Very similar build.

    AMD 3700x
    AMD RX 5700xt
    32G ram
    1TB NVMe SSD (single drive - Win and AC:V installed on same drive)

    Windows and GPU drivers fully updated to stable builds (NOT preview, beta, experimental)
    All GPU/CPU settings set to standard/default - no overclocking

  • cemtasan
    2 posts
    @crazydonkey88 And also I have reinstall the game 2 times and  do every solution options in this forum except installing the game  to a different drive than The one with Windows installed but I have only C drive in my computer !!!! what kind of  professionalism is that!!!! They took our money by pre oerder nonsense and there are many many bugs after the release

  • CrazyDonkey88
    100 posts

    Mine is:

    Win 10
    Z370 Tomahawk
    GeForce 1080
    16GB ram
    250 SSD 970 Evo
    1 TB WD

    still nothing changed after couple of reinstall for today

  • moog500
    7 posts

    I got a response after submitting my ticket. They told me to run the game in administrator mode and disable non-ms system services and start up items. That didn't work (ofcourse). I have asked for a refund. I've had enough.

  • HawkSE
    9 posts

    @crazydonkey88 I'm sorry to hear that.

    As I said, this doesn't work for me. I couldn't keep the game on that same drive. I was immediately running out of space just testing it.

Suggested Topics

Community Details