Welcome to discussions

Quick Suggestions

  • Bizwiz2006
    4 posts

    @ubiwan Why do you need a clip? The quiver is upgraded fully but the arrow capacity is back to 12/12 20/20 5/5. Do you really need a clip for that? You have hundreds or more people complaining about the same thing. I'm one of them! Please fix this!

  • Ubi-Borealis
    Ubisoft Support Staff 3626 posts
    Best Answer

    Hello all!

    As shared by @Jubilee64, this issue has been marked as resolved following TU 1.1.2. Thank you for your patience at the team took a closer look at this.

    If your arrow capacity is still reset to minimum capacities following TU 1.1.2, please don't hesitate to update this thread so we can take a closer look. Thanks! 😊

    @longjohn119 - Thanks for sharing your feedback about being able to quickly switch bows. If I recall, you should be able to see how many arrows are left within the HUD, to the bottom-left of the screen (above your health and abilities icons). I do personally agree, though - it would be a lot more convenient if you could switch between bow types without going into the menu. I've passed on this feedback for you.

    Official Response
  • gingerbredboy21
    1 posts

    Xbox one - my arrow supply has been reset to the beginning level amount even after upgrading it, it still remains the same. and the quiver model has also disappeared leaving the arrows to float on Eivors belt.

  • opium_cake
    2 posts

    You Sir, are my hero.
    It worked for me !

  • BlueFang008
    3 posts

    @turkmax just tried it. Still doesn’t work 😞

  • MerkinAllDay247
    1 posts

    Have 114 hrs still not even close to beating it maybe half way I love it but with the new update I went from 30 arrows to 12. Please fix the bug thanks.

  • SpaceInvader73
    1 posts

    Same problem here since the 1.1.0 patch. I’m playing on Xbox Series X.

  • muomtazkalo
    1 posts

    Hello, I’m having the same issue, I noticed it started after being in a restricted area in jotunheim then powered off the PS5 from the PS button, after powering back on and starting the game, this happened. My quiver is updated to the max and have only 12 hunter arrows!! And the 3 skills that were previously added are now not showing!

  • password1234xxx
    17 posts

    Assassin's Creed Valhalla, XBox One, digital Version (one of the expensive ones, don't know which one know)

    Bug:

    Upgraded my quiver 3x on Level 4. It didn't work and my warrior can still carry the same amount of arrows.
    The resource used is about 33% - 50% as those contained in a "small resource pack"/"Animus-Shop". This means that I get in addition around 150 Helix-Points now; because I am not able to use my upgraded quiver at the moment.

    I am a very busy person and I still play the main quest. One primary target escaped because I was out of arrows while using the (bugged) Lvl 4 quiver; plus: I had to use even more time and ressources to destroy the whole hostile outpost (... since young people might be here, I do not give any details.)

    Please fix the problem and send me the compensation as soon as possible.

    Thanks and have a good day.



  • natesac69
    4 posts

    I am also having this same issue, and quiver sometimes appears to be invisible, just arrows floating on belt. This needs a quick fix, I rely on the arrows lol.

    Playing on Xbox series X

  • natesac69
    4 posts

    Same issue here on Xbox Series X

  • Jillexie
    2 posts

    Luckily I caught this big early and was able to reload to a previous save without losing much. Upon testing it, it appears my quiver degrades whenever I loot arrows from a soldier in the Saxon camp with the ale cask during the Ale Yuletide quest. I tried looting arrows from soldiers in other locations and my quiver was unaffected.

  • RichterBeyond
    5 posts

    Ditto. Playing on Xbox Series X

  • Bizwiz2006
    4 posts

    @ubiwan You really need people to upload save files!? What?! It's happening to everyone and you can't replicate this yourself? This is crazy. Typical Ubisoft BS!

  • jayywpee
    1 posts

    I have upgraded my quiver to the max but since the new patch my arrow numbers have gone back to the minimum number. I can't reload an old save because the closest one is 70hrs back. Can this be fixed?

  • iTzI3OBBY
    56 posts

    @jayywpee This is an issue that I'm experiencing as well. Reloading a save doesn't work either.

  • swedishviking83
    4 posts

    @swift_pint you're awesome thanks.

  • raze81808
    1 posts

    I have a suggestion cuz I found some thing on Reddit. Travel to Vinland then travel back to Ravensthorpe. It fixed the bug for me

  • N3p7une
    1 posts

    Same issue here. As well as the overall upgrade being reduced I was maxed out on the quiver now I'm less than half and reupgrading does nothing for the count.

  • devilrmarines
    2 posts

    Hello sorry to bug but i have this glitch when i upgraded my quiver my arrow are staying the same is now and also it drop my arrows count back to 12 for hunter bow 20 for light arrow and 5 for predators and I almost have it fully upgraded i have reset my game and reload a old file thank you for reading

  • Joennes89
    2 posts

    Same here fully upgraded. I can only carry a maximum of 12 arrows

Suggested Topics

Community Details

58
Online
194.0k
Users
32.8k
Topics
163.9k
Posts