ubisoft discussions

Quick Suggestions

  • Locked Solved [RESOLVED] Quivers reset to minimum arrow capacities even if upgraded following TU 1.1.0 | POST HERE

    1 Likes/584 Replies/9524 Views
    1 posts

    Hello, I’m having the same issue, I noticed it started after being in a restricted area in jotunheim then powered off the PS5 from the PS button, after powering back on and starting the game, this happened. My quiver is updated to the max and have only 12 hunter arrows!! And the 3 skills that were previously added are now not showing!

  • password1234xxx
    27 posts

    Assassin's Creed Valhalla, XBox One, digital Version (one of the expensive ones, don't know which one know)


    Upgraded my quiver 3x on Level 4. It didn't work and my warrior can still carry the same amount of arrows.
    The resource used is about 33% - 50% as those contained in a "small resource pack"/"Animus-Shop". This means that I get in addition around 150 Helix-Points now; because I am not able to use my upgraded quiver at the moment.

    I am a very busy person and I still play the main quest. One primary target escaped because I was out of arrows while using the (bugged) Lvl 4 quiver; plus: I had to use even more time and ressources to destroy the whole hostile outpost (... since young people might be here, I do not give any details.)

    Please fix the problem and send me the compensation as soon as possible.

    Thanks and have a good day.

  • natesac69
    4 posts

    I am also having this same issue, and quiver sometimes appears to be invisible, just arrows floating on belt. This needs a quick fix, I rely on the arrows lol.

    Playing on Xbox series X

  • natesac69
    4 posts

    Same issue here on Xbox Series X

  • Jillexie
    2 posts

    Luckily I caught this big early and was able to reload to a previous save without losing much. Upon testing it, it appears my quiver degrades whenever I loot arrows from a soldier in the Saxon camp with the ale cask during the Ale Yuletide quest. I tried looting arrows from soldiers in other locations and my quiver was unaffected.

  • RichterBeyond
    5 posts

    Ditto. Playing on Xbox Series X

  • Bizwiz2006
    4 posts

    @ubiwan You really need people to upload save files!? What?! It's happening to everyone and you can't replicate this yourself? This is crazy. Typical Ubisoft BS!

  • jayywpee
    1 posts

    I have upgraded my quiver to the max but since the new patch my arrow numbers have gone back to the minimum number. I can't reload an old save because the closest one is 70hrs back. Can this be fixed?

  • iTzI3OBBY
    67 posts

    @jayywpee This is an issue that I'm experiencing as well. Reloading a save doesn't work either.

  • swedishviking83
    4 posts

    @swift_pint you're awesome thanks.

  • raze81808
    1 posts

    I have a suggestion cuz I found some thing on Reddit. Travel to Vinland then travel back to Ravensthorpe. It fixed the bug for me

  • N3p7une
    1 posts

    Same issue here. As well as the overall upgrade being reduced I was maxed out on the quiver now I'm less than half and reupgrading does nothing for the count.

  • devilrmarines
    2 posts

    Hello sorry to bug but i have this glitch when i upgraded my quiver my arrow are staying the same is now and also it drop my arrows count back to 12 for hunter bow 20 for light arrow and 5 for predators and I almost have it fully upgraded i have reset my game and reload a old file thank you for reading

  • Joennes89
    2 posts

    Same here fully upgraded. I can only carry a maximum of 12 arrows

  • smcinturf
    53 posts

    Any updates on this? Knowing Ubi it will be fixed late 2021...or not at all. Devs really aren't very good nowadays. No accountability anymore. [censored] do they care? They made their millions. I'm sick of broken [censored] games after years of delays, incompetent devs, and condescending and useless support. It's become a stressful hobby anymore with too much time spent fighting to get at least a reasonable version of the product we paid for. Screw these companies!

  • B00MSIE
    400 posts

    Going go to and from Vinland temporarily fixes it.

  • B00MSIE
    400 posts
    This post is deleted!
  • xtralag
    7 posts

    @UbiWan: I really don't understand what is going on in your game. Before sending a save game file, I wanted to test once more today. However, in contrast to yesterday when it happened 4 times I could not reproduce the problem anymore (in about 1 hour playtime). But there are more strange things going. I have no idea whether they can be of relevance. 

    Before I stopped playing due to the bug, everytime I opened the skill tree 1 new skill popped up next to the 3 new symbols (upper left, upper right, bottom, white border like the central one) with the camera/screen moving to each of them (like an animated introduction). I could not do anything there and ignored them.

    Now today the first new thing I encountered was the Yule notification (haven't seen it before), but also these 3 skills I mentioned above are no longer there. They do not pop up anymore when I move to the skill tab. After that I tried to reproduce the quiver bug but could not do so yet. Is something changing in your game "behind the scenes" without a proper patch?

    I have no clue what is going on and will now try to get the PS5 version running with the most recent save game file.

  • benzy4792
    30 posts

    Quiver is bugged. Went from 30 to 12 arrows...
    Any fix besides loosing a few hours of gameplay?

  • benzy4792
    30 posts

    @lillysdad1120 same here...
    30--- 12
    15 ----- 2
    All arrows reduced....

Suggested Topics