Welcome to discussions

Quick Suggestions

  • Zegotron2.0
    1 posts

    There must be other people who are experiencing this issue after the update. Before the update I had 30 arrows in my quiver. Now I have 12 arrows maximum. Also my character does not seem to have a quiver my arrows are just sitting next to my player at all times with no quiver.

  • Ubi-Borealis
    Ubisoft Support Staff 2906 posts
    Best Answer

    Hello all!

    As shared by @Jubilee64, this issue has been marked as resolved following TU 1.1.2. Thank you for your patience at the team took a closer look at this.

    If your arrow capacity is still reset to minimum capacities following TU 1.1.2, please don't hesitate to update this thread so we can take a closer look. Thanks! 😊

    @longjohn119 - Thanks for sharing your feedback about being able to quickly switch bows. If I recall, you should be able to see how many arrows are left within the HUD, to the bottom-left of the screen (above your health and abilities icons). I do personally agree, though - it would be a lot more convenient if you could switch between bow types without going into the menu. I've passed on this feedback for you.

    Official Response
  • diver_gr
    7 posts

    @b00msie

    tried going back yo Vinlad, empty all arrows as suggested at reddit, remove bow, went back to main map , it almost fix it because while quiver is max upgraded it still missing arrows for example hunter arrows is now 26 when they should have been 30.

  • Rlytle97
    1 posts

    My quiver was almost maxed out and now it is stuck at a maximum of 12 Hunter arrows only. I have been looking up solutions, and found that very many players are experiencing the same issue across all platforms. I believe it happened after the last update, but I am not entirely sure when it started. I can no longer pick up arrows once I have 12, and I cannot upgrade my quiver anymore. Could someone please look into it and provide a patch?

  • Nick_Too
    3 posts

    @lillysdad1120
    Same here, quiver level 4, from 18 before patch to 12 arrows after.... very frustrating.

  • Nick_Too
    3 posts

    @ubit00n Hi, thank you, please fix it soon please 😖

  • Brader03991
    4 posts

    @zegotron2-0 I still have my quiver, but also had my maximum decreased to 12

  • Brader03991
    4 posts

    @ubit00n same here max is down to 12....

  • xtralag
    7 posts

    I just want to add to my previous post that I moved to PS5 today and transfered my most recent save game. I played about 5 hours and have not encountered the bug again so far. But I also want to stress again the strange observations I made in the skill tree menu (see above). Very weird....

  • JMetch
    59 posts

    @benzy4792 The fix will be an increase Arrow EX booster that you can buy in-Store for $9.99.

  • LittleYanYay
    7 posts

    @swift_pint Did what you put, it increased me to 22 H/30 L/10 P which is better but still not back to normal. Thanks for a little help, hope they fix this and many other issues soon.

  • bassposaune
    1 posts

    @ubiwan Totally agree with this statement. BTW, if you're on ps5 you can't save save files on USB to send to you guys.

  • dunkalars
    9 posts

    Marker after Beowulf quest still there after quest completion.

    Fasttravel point in norway mountain unusable.

    Quiver invisible and arrowcount reset.

    Plus a few before mentioned bugs. (Yule n bla bla, hickup)


    I will upload all my savegames. (zipfile)

    Here: https://filebin.net/rsdile751tueiu0u


    P.S. Mainsave 4 chould be clean;er than the rest, bug vise.

    Hope it helps.

    knudalars.

  • remtana926
    2 posts

    Hello. Since the last patch/update, by arrow number has decreased to 12; I was up to the totally upgraded amount. Also, the quiver is missing, and arrows are just floating. The quiver missing isn't an issue for me, but missing half the arrows is an issue, since I run out so fast in the higher level missions. Thank you!

  • GRiZ-LiVeS
    2 posts

    @benzy4792 same here

  • GRiZ-LiVeS
    2 posts

    Quiver bug after doing the spinning target challenge at the yule festival.

    Fully upgraded quiver reduced to a maximum of 12 hunter arrows, 5 predator arrows, 20 light arrows.

  • Mr_raDius
    3 posts

    @b00msie Not for me it didn't. Still missing my arrows and the three skill points at 403.

  • theBlaspheMAY
    2 posts

    @jenny4466 yes. It appears that the quivers have been downgraded.
    I am not pleased.
    -BMay

  • B00MSIE
    332 posts

    @mr_radius

    I am also max level. If I use and pick up new arrows in Vinland, I can temporarily use more arrows (after using and refilling) when back in England.

  • B00MSIE
    332 posts

    @diver_gr

    For me it is the same (max level and max quiver capacity) and it is also temporarily. So the amount of arrows will decrease after some time.

  • benzy4792
    30 posts

    @benzy4792
    A work around that partially solves the problem: (runs around the web)
    Travel to Vinland
    Shoot all arrows
    Unequip bow
    Go back to settlement and buy arrows.

    For me it worked partially gone up to 22 max hunter quiver (max was 30).
    I guess we'll wait for a patch

Suggested Topics

Community Details

44
Online
143.1k
Users
25.3k
Topics
131.4k
Posts