Welcome to discussions

Quick Suggestions

  • SOLVED [RESOLVED] Quivers reset to minimum arrow capacities even if upgraded following TU 1.1.0 | POST HERE

    1 Likes/583 Replies/8776 Views
    JCar4327
    627 posts

    @fronzizzle I have multiple saves on Xbox, one for the female and one for the male. The female save I already completed the game and the male save I am currently playing. I have the quiver bug on the male save but not the female save. So, yeah it is interesting. Now I haven't scienced it out yet, but someone said if you let your arrows drop below 12 the bug will kick in.

  • tinyissscute92
    7 posts

    @fireforkts Thank you for that glad I'm not the only one but ya the skills they added I don't even see them in my skill tree and it sucks I normally had 30 arrows since upgrading the quiver fully now I can only hold 12 😞

  • Fixthebugpls
    2 posts

    @gingerbredboy21 Ive been dealing with the same issue, any fixes?

  • Crossedpens
    1 posts

    Ubisoft. Having your quiver glitch back to base level in the middle of a mission is SERIOUSLY ANNOYING. I'm sick of running through your crap workarounds every time need to fight a tough enemy... FIX YOUR GLITCH.

  • jandraelune
    119 posts

    Body same as the title

  • guest-pu3zw6WF
    4 posts

    Sounds like this is pretty common, how do we get Ubisoft to look at it? Haven't played in 3 days, every time I do I look at that arrow capacity and just quit lol. I love sneaking through a camp and picking off everyone with arrows, hard to do with only FIVE arrows. 😞

  • Gy2fly4u85
    7 posts

    @zebatov so my quiver should be at 28. The bug put me down to 8 because I upgraded it when it said 12. I did the big fix and when I got back to my town, I lost all quiver upgrades down to 20. On top of that, the arrows you carry in England and Norway have nothing to do with Vinland since you have to go back as a native. Big fix makes no sense and only set me back.

  • Gy2fly4u85
    7 posts

    Mind you, when it read 12 or 8, my quiver upgrades were still visible as being upgraded to 28.

  • Kreisso
    1 posts

    Hi, my stock of arrows is broken. despite upgrading my choke to the penultimate level, I can only carry 5 arrows with me. Game version PS5

  • guest-Pa5PVvuK
    3 posts

    I saw somewhere that the quiver bug was mentioned as rare. It does not seem rare and seems like one of the most pressing issues for the game. Ive tried the "fix" but every time I fast travel the capacity resets and I am not going back and forth to Vineland and my settlement watching 10 mins of reloads screens every time I want to play (and even then can only get up to 20 arrows - not 30 as it should be). I cannot do any boss fights on high difficulty with 12 arrows. This bug is a game breaker for what seems like many people. When will it be patched UBISOFT?

  • D0NT_PANICK
    9 posts

    @theeelf don’t hold your breath. They have some horrible bugs in this version of AC. It’s making Unity look like cake walk. It’s frustrating. Especially when people shell out money for these games and get a world of bugs when Ubisoft lets their kids do the coding.

  • TheeElf
    262 posts

    @d0nt_panick I've enjoyed it. Fortunately the Jotunheim key bug I worked around but lost 3 hours of progress that had to be re-done. So far 1000/1000g on achievements, every single gold speck (the small ones) collected on all maps, and just got all armor in my inventory (115 pieces minus Bayek's) to mythic grade. Now just worked on powering them (about 1/4 done) but so much iron ore haha. I've enjoyed it and looking forward to the expansions. Now just to grind daily for Opals to collect other rare items not in the world.

  • ScTman
    2 posts

    Since the new update my quiver is not right. Before update I had 20 plus hunter arrows. Now I am fully upgraded and I only have 12 arrows max. Also when I start the game I am always drunk. Has anyone had this issue and were you able to correct it.

    I don’t know if anyone else has this issue with their quiver. I have totally upgraded my quiver and my arrow limits are 12 hunter, 20 light and 5 predator. This cannot be right. Before the update I had 20 plus arrows in my quiver with 2 upgrades left. Am I the only one with this issue I have not seen any other posts on this.

  • XHUGOxDERxJUGOX
    3 posts
    The bow quiver upgrade doesn't work for me. With you too? I have already improved it 7 times, but I can only take a maximum of 15 arrows with me


  • DaveThanatos
    2 posts

    I had a problem with my internet & lost connection before playing but I decided to play with no internet connection which should not be a problem but after a few hours I wondered why I was using my arrows up very quickly

    eventually I had a close look to realise even though i had upgraded the quiver to have the maximum amount of arrows (30/40/25) it had reset the quantity back to the original amount (12/20/5)

    when I realised this I closed the program and had to manually log on? but when i loaded my latest save it will not update the arrow quantity and can find no way of doing this

    I have a save from yesterday but have wasted several hours of my life playing the game (not for the 1st time because of crashing & bugs) which I will never get back

  • Nabby2012
    1 posts

    @davethanatos A lot of us are having this problem. A few people have gotten a temporary fix with a fast travel to Vinland trick but it doesn't work for me and some others. Haven't heard anything about it yet from Ubi.

  • DaveThanatos
    2 posts

    Cheers for that Nabby2012

    I have not done Vinland yet so it will be a risk to go through all what's needed to find out it might not work
    my best option is probably to reload the early save (if I can be bothered)
    But at least Ubisoft know about the problem

    I love the game but this is might be the straw that breaks the camels back
    Having probably lost 1/2 a day of play due to crashes during missions and having to play them again because you cant save during them
    Also i have probably lost 150+ opals because the bug
    And I cant give Octavian my Roman artefacts





  • IQuackersI
    1 posts

    Ran into an issue where I got 3 new skills on the skill tree, selected them, and reloaded an old save, lost the 2 skills, and my quiver maximum was reset to 5 predator arrows and can't get any past that, also Im stuck with 2 skill points that are unusable because the three new skills are not showing up as well (not mastery points, those are showing up, but three skills off new white nodes stretching between each tree)

  • ScTman
    2 posts
    This post is deleted!
  • forgotten_blue
    2 posts

    @kairimacedonia
    I have the same problem, but my max amount of arrows are 12 for hunnish bow, 5 for predator bow and 20 for light bow. I also have the same problem with the drunken state, but only when I desynchronize and restart from a previous save.

Suggested Topics

Community Details

75
Online
196.3k
Users
33.2k
Topics
166.1k
Posts