Welcome to discussions

Quick Suggestions

  • MarsMuseMan
    8 posts

    Really sick of this glitch, I've been playing the last 20 hours of the game with 12 freakin arrows when I should have 30. PLEASE FIX NOW. It's ruining the game experience

  • Ubi-Borealis
    Ubisoft Support Staff 3626 posts
    Best Answer

    Hello all!

    As shared by @Jubilee64, this issue has been marked as resolved following TU 1.1.2. Thank you for your patience at the team took a closer look at this.

    If your arrow capacity is still reset to minimum capacities following TU 1.1.2, please don't hesitate to update this thread so we can take a closer look. Thanks! 😊

    @longjohn119 - Thanks for sharing your feedback about being able to quickly switch bows. If I recall, you should be able to see how many arrows are left within the HUD, to the bottom-left of the screen (above your health and abilities icons). I do personally agree, though - it would be a lot more convenient if you could switch between bow types without going into the menu. I've passed on this feedback for you.

    Official Response
  • ziggurcat
    167 posts

    Also, it would be super great if I could load into my game, and not have the drunk effect active.

  • Nilleholm73
    4 posts

    what skill is this ”Arrow Dropper” skill that is mentioned in here ? Cant find that one.

  • Eleuther_OS
    1 posts

    The quiver capacity drop to 12 and the fix (going back to vinland, shoot all arrows, get back to Raventhorpe, etc.) proposed all over the net is not working ...

  • Nilleholm73
    4 posts

    There are hundreds that are facing this Arrow bug that decreasing the amount of arrows that you can carry. WHY dont you announce this bug in your Mega list ????

    I Will not play befors this is solved and when can we expect a patch for this ?? It ruin the gameplay alot.

  • Syke80
    9 posts

    Same problem for me

  • X_Niels1905_X
    1 posts

    I have my quiver at level 5 now, yet my arrow capacity went down from 18 to 12 and i cant seem to fix it (restarting doesnt work and upgrading it once more doesnt either).

  • BlueLupe
    7 posts

    @nilleholm73 I'm having this problem and I'm on the verge of stopping play until it's resolved cos I'm down to 12 arrows after upgrading capacity twice. So annoying.

  • taiby_g
    2 posts
    This post is deleted!
  • Spiral-Kamina
    4 posts

    Hello everyone
    After reading here, on reddit and many other places on the internet that a lot of people are having issues with the reduced arrow bug and or missing quiver (including myself), i decided to roll back my save to investigate where the bug may have come from.
    My first idea was the Yule Festival, so i skipped it and continued playing for a few hours, did many quests, both main and sidemissions, but the quiver remained normal and so did the arrow capacity.
    Until i reached the quest The Walls of Templebrough.
    As Aethelswith was fleeing, i jumped on a small boat to follow. When reaching the spot where Aethelswith went on land, i shot her guard with my hunter bow while still standing on the boat. After going on land myself i noticed the reduced arrow count and the quiver was missing (arrows where just floating on the hip without quiver)
    I reloaded the game once, replayed the section up to the same moment, but this time i did a jump assassination at her guard from my boat. Which immediately caused the same outcome.
    I reloaded my savegame again, however this time i did not follow by boat but took the horse and followed her by land. I killed the guards on land by bow from horseback and captured Aethelswith. Low and behold, the quiver remained and the arrow capacity was still intact.
    It is puzzling as to what could have caused the interference in the moment with the guard. I am certain it has nothing to do with the boat per se, as i tested the boat-ride outside of the mission without any results.

    Regardless, i thought i’d share my investigations here so people can possibly avoid it and the developers may have a chance to find the issue faster.

  • Carnatus2
    4 posts

    I have had the same problem multiple time now. Even if you go back to a previous save the game seems to lead to the same issue again. I think I am now going to have to shelve the game until it gets fixed; I lost several hours once due to going back to previous, I am not likely to do it again. Too bad, been loving the game so far.

  • jmalkin177
    43 posts

    A number of players are reporting an issue where the quiver at max upgrades is only holding a count of 12 hunter arrows. It seems to be connected to the Yule update. Some have reported traveling to Vinland, using all your arrows, unequipping the bow and returning to Ravensthrope to fill up at Yanli's shop is a solution; however it is not a universal solution and many players are stuck with a reduced arrow count in their quiver. This is putting a heavy damper on the community and causing tons of frustration, please fix ASAP.

  • ClaySands
    2 posts

    Hi there. I have been having an issue where the number of my arrows are cut in half and my quiver is missing
    It started when the three new upgrades appeared, went to unlock them, then I got the bug. A lot of people are experiencing the same thing. I have tried every method, but it did nothing. I would like to know when the next patch to update this will come out. Please and thank you.

  • cababe07
    4 posts

    Traveling to Vinland, where you lose all your equipement, and then coming back to England, fixed it for me.

  • cababe07
    4 posts

    Traveling to Vinland, where you lose all your equipement, and then coming back to England, fixed it for me.

  • Spiral-Kamina
    4 posts

    Short Update as I saw the questions mentioned in other threads:

    • Arrow Dropper Skill is / was not active
    • Rebooting doesn’t do anything, the missing / reduced quiver seems baked into the save file
  • Jvoreis
    2 posts

    So im at power 147 and my quiver was at 18 hunter arrows but now locked at 12. Haven't bothered upgrading further as it remains locked at 12 also been to vinland and back didnt fix it for me please fix asap

  • Luvbeers7
    15 posts

    I am confused about this Vinland fix... they say travel back to Vinland, empty your arrows and travel back to Ravensthorpe and buy them again at the shop. However I find that you have two different inventories, so if you leave England with a full quiver, you have it when you get back and Same for Vinland. Doesn't seem to make any difference what I do, if I fast travel from the atlas or docks, having bows unequipped, quivers empty. No combination fixes this glitch. This is really the worst bug, everything else I can live with, but grinding to max out your quiver for nothing really stinks to Helheim.

    This Yuletide festival seemed to ruin everything. Ubisoft please whoever came up with this idea, don't let them move to Bioware to mess up the new Mass Effect anymore than usual.

  • Jvoreis
    2 posts

    @luvbeers7 same i totally agree man its made me want to stop playing for now

  • videopixels
    6 posts

    @jimbo-davis Sigh. Same here, more than half way upgraded and can only hold 12 arrows. The Yule festival addition is definitely broken! Starting from a drunk state is also getting exceptionally irritating now!

Suggested Topics

Community Details