Continue your odyssey

Welcome to discussion

Quick Suggestions

Hello! These new forums are an open beta and we welcome your feedback in this section.
  • Flik2stik
    2 posts

    @flik2stik Photo below since I waited to long to edit my original post;

    undefined

  • Ubi-Borealis
    Ubisoft Support Staff 1451 posts
    Best Answer

    Hello all!

    I've merged together several threads about being unable to proceed in "The Case of the Missing Ale" together, so we can keep all this information in one place. Apologies if any ongoing discussions were disrupted by this.

    This issue was marked as resolved following the end of the Yule Festival. I will now be locking this thread.

    If you require help with any other issues, please check out our megathread list, or open up a new thread.

    Keep an eye out for future events within our News & Announcements forum, as well on the official website.

    Thanks all! 😊

    Official Response
  • larrykop1967
    65 posts

    Yeah i've got the same problem, why do i have to take the ale to glowcester or whereever and there is nothing there, when i get there

  • eladath01
    5 posts

    @eladath01 Also the quest Cow Catcher directs me to the same point to return to after killing the cows, 1.7 km west of Ravensthorpe.

  • Tomse0008
    2 posts

    just got to the same quest, and same problem.
    read in several other forums, and found that plenty of people have the same problem. not just a few.

    There are loads of bugs in this patch. It seems it's a rushed job.

  • psi2000
    2 posts

    @flik2stik @UbiWan

    Got the same issue here.. After the fist fight I met a zealot, of whom I made mince meat. My fist fight opponent (cant remember his name) got hurt during the zealot match. Then after mincemeating the zealot I got the Ale, and my bring back icon is 4000m away as described by others..

  • psi2000
    2 posts

    @UbiWan I even tried to bring the ale bak to Teklas hut, where the quest started, but alas, no progress..:/

  • aMINDxJOKEx
    4 posts

    @hypersnapshot I have the same issue. The entire event seems to be messed up. I had glitches in every single quest but fortunately I managed to complete them. This one is the most annoying bacause it doesn't let me do anything. Hope they fix it soon.

  • Paradonas
    9 posts

    I dropped the beer to go grab two nodes of metal and turned around, now the barrel has gone 240 meters underground. It has also teleported north

  • Jokah.D
    2 posts

    @benzy4792 Had that problem too. I solved it by using the eagle to mark Aka after fighting him. That way you can see where he went. It's not far from where you get the ale.

  • GhostAgent14
    28 posts

    @Spartabunny08
    I think mine is bugged because I can go up to him by the water there, but there is no way to interact with him. I got to the point in the quest where we have our brawl and then heads to that location. But I don't see anything about picking up any ale nearby. I just get the quest marker going completely off the map.

  • Miralie39
    5 posts

    What a surprise ANOTHER bug.

  • Xans_Othala
    1 posts

    With the Yule festival came 2 bugs in quests. The one with the cows. I killed 4 and only got meat from 3. The other one is not lootable. 

    The one with the mead. Marker is glitched and no boat to be found. By the time this is read i might have lost the locations of both the cow corpses and the barrel. Please make it possible to reset these quests.

  • ChuckKatse
    174 posts

    Think it is pretty pathetic to introduce the Yule Festival and have its quest bugged. Get on YouTube and key in the Missing Ale quest and watch the walk thru. It will show you exactly were to go. Hey Ubisoft, do you test any of your content before adding it to the game? or is it just thrown in?

  • Kormac67
    508 posts

    Well they were talking about the bandits having stolen the ale so you should search the nearby camp.
    But after you found it the target point is broken. Just head south and it will fix itself.
    Same with the cow quest, it says "return to cow farmer" in the end but points to the same wrong point 1200m westward.Just return to Ravensthorpe.

  • diggerbarnz1
    3 posts

    I'm lost in "looking for it"! Can't recall where I started or where bandit camp was

  • ajscott819
    9 posts

    @diggerbarnz1
    Utbech in Grantebridgescire. In the marshes.

  • Finalflash07
    19 posts

    @kormac67 No fun in doing broken quests, quit raged earlier today

  • USMCtracker1833
    1 posts

    @ubiwan every time I reload also because the keg disappears or falls in water. The loaded game starts me out drunk for some reason.

  • PandaQueen666
    1 posts

    HIYA,

    Every time I go back to Ravensthrope, I am drunk, like insanely can't see straight drunk.

    Also for the Quest for getting back the barrels of ale that Ake lost to bandits it sends me to a far distant like land that has a curse on it but no ale. It also does the same thing for the Farm that you need to build.

  • Ragna-san
    3 posts


    undefinedundefined
    Same here. The quest shows me this location. I was there but it seems its under the Map.

Suggested topics

Community details

34
Online
124.7k
Users
21.5k
Topics
110.9k
Posts