Welcome to discussions

Quick Suggestions

  • MiniSpaceBeast
    3 posts

    I've also got a marker in Sciropescire and no ale cask. I set it down to fight some bandits and it disappeared.

  • lowonc10h12n2o
    3 posts

    On ps5 I had the marker being set incorrectly in the same way. I completed the mission by jumping onto a small fishing boat with the ale, and following the river to the quest marker - Eivor actually went to the correct location, not the one indicated by the buggy marker.

    Happened again, in the mission where you kill the cows for the feast, after collecting all the meat the marker for "Escort Bertham back" showed up far away, in the exact same spot it did for the ale quest. But again, just going onto the small boat with Bertham and dismounting in Ravensthorpe reset the marker correctly and I was able to finish the quest.

  • Ubi-Wan
    Ubisoft Support Staff 631 posts

    @sven_170 Hello there! Thanks for reaching out. I'm sorry to hear about this issue! A few players who have experienced the same kind of issue have mentioned being able to walk to the proper quest location by following the river about 150m southeast of the quest's starting point. Please give this a try! 

    Official Response
  • eladath01
    5 posts

    @ubiwan I'm having the same issue. I tried taking a screenshot but I can't find where it's saved. The bandit camp is about 1km east of Ravensthorpe, once you get the keg of special ale the next waypoint is about 1.7 km west of Ravensthorpe. When I get there it says it's still 240 m below me. Also it says something about getting the ale to the apprentice's boat, but there's no waypoint for it and once you pick the keg up it just says to bring it back, nothing about a boat.

  • MiniSpaceBeast
    3 posts

    My cask respawned back in the center hut and I followed the above instructions to finish the quest.

  • Scalle.
    1 posts

    got a simular bug, was suposed to deliver the ale but it send me 4000m away and i lost the ale, unable to recover it...

  • Flik2stik
    2 posts

    @ubiwan But once the ale is picked up, the next step for "Bring back the secret brew" puts the quest icon in southeast Sciropescire. When I take the boat all the way there and run to the icon, it says it's way below me. If I bring the Ale back Ravensthorpe, there's no indicator for someone I should take to or someplace I should set it to complete the quest.

  • XenoviousSora
    2 posts

    @ubiwan undefinedsome other bugs I've encountered after this
    So at first I thought it wasn't a bug so I went to my longship n traveled there however my ship sail mass didn't get lowered for the low pass bridges even tho theres dialogue n sound for lowering it.
    Another bug i found was after I reload a save from this quest eivor spawns in very drunk.

  • HyperSnapShot
    3 posts

    Hi Team,

    Great work with the game so far! However need to report a bug in the latest release of the 'Yule Festival'. Mission one named 'The Case of the Missing Ale' Once you've retreived the barrel from the bandit camp the mission icon for 'Bring back the Brew' isnt found in Ravensthorpe but located west in Sciropescire (where the curse land icon is) the icon displays in the same area but underground see images below. I've tried bringing it back to the brewery in Ravensthorpe but still does nothing see Nothing see images below. also after carrying the barrel for say 10 minutes the textures have broken on them see images below.undefinedundefinedundefined
    Well excited for the yule festival its a great idea to do them as seasonal events 🙂 however I am unable to progress this further 😞 due to the above, please fix this as soon as you can. Hopefully you aren't far from releasing a hotfix update.

  • Arsenal660
    1 posts

    @buff_pizza This work around fixed my issue, thanks for sharing.

  • Flik2stik
    2 posts

    @flik2stik Photo below since I waited to long to edit my original post;


  • larrykop1967
    66 posts

    Yeah i've got the same problem, why do i have to take the ale to glowcester or whereever and there is nothing there, when i get there

  • eladath01
    5 posts

    @eladath01 Also the quest Cow Catcher directs me to the same point to return to after killing the cows, 1.7 km west of Ravensthorpe.

  • Tomse0008
    2 posts

    just got to the same quest, and same problem.
    read in several other forums, and found that plenty of people have the same problem. not just a few.

    There are loads of bugs in this patch. It seems it's a rushed job.

  • psi2000
    2 posts

    @flik2stik @UbiWan

    Got the same issue here.. After the fist fight I met a zealot, of whom I made mince meat. My fist fight opponent (cant remember his name) got hurt during the zealot match. Then after mincemeating the zealot I got the Ale, and my bring back icon is 4000m away as described by others..

  • psi2000
    2 posts

    @UbiWan I even tried to bring the ale bak to Teklas hut, where the quest started, but alas, no progress..:/

    4 posts

    @hypersnapshot I have the same issue. The entire event seems to be messed up. I had glitches in every single quest but fortunately I managed to complete them. This one is the most annoying bacause it doesn't let me do anything. Hope they fix it soon.

  • Paradonas
    9 posts

    I dropped the beer to go grab two nodes of metal and turned around, now the barrel has gone 240 meters underground. It has also teleported north

  • Jokah.D
    2 posts

    @benzy4792 Had that problem too. I solved it by using the eagle to mark Aka after fighting him. That way you can see where he went. It's not far from where you get the ale.

  • GhostAgent14
    96 posts

    I think mine is bugged because I can go up to him by the water there, but there is no way to interact with him. I got to the point in the quest where we have our brawl and then heads to that location. But I don't see anything about picking up any ale nearby. I just get the quest marker going completely off the map.

Suggested Topics

Community Details