ubisoft discussions


  • locked topic_solved [RESOLVED] Unable to progress with "Milk of Humankind" | POST HERE

    15 likes/454 replies/18739 views
    ubisoft:x-posts, 3

    Cant understand why this is still not being acknowledged on the mega thread, clearly a common issue! It was first reported back in November and nothing! Really frustrating!

  • slanitis
    ubisoft:x-posts, 6

    Thank you.

    It would be great to know an eta?

    You could just alter the quest and give the mystery completion if the player just goes in that area. Then fix it when you can.. it hasn't been fixed for 4 months, very very concerning.

    Stay safe, stay lucky

  • Freddy69
    ubisoft:x-posts, 2

    I tried to do the asgard mystery "cow milk of humankind" too early. Now the cow is halfway across asgard and won't move. Can't complete quest, its a little upsetting

  • Polecatsfan
    ubisoft:x-posts, 2

    @usrhlp I have that EXACT same problem! I go to the marker... no damn cow! Audumbla has already gone!

  • Polecatsfan
    ubisoft:x-posts, 2

    @usrhlp woah! Scrub that! I fixed it!
    Ok so if you have no cow.... your cow has up and left and wont respawn!

    Go to the starter pen, smash the fence, push the block in the next pen all the way forward, smash the next fence, and finally smash ALL of the final fence, walk Eivor up through the exit and wait! After standing still for about 3 minutes it should pop up saying Milk of Human Kind complete.

    Hope this works for you aswell dude!

  • edocat88888
    ubisoft:x-posts, 7

    UP!!! C'mon man! Any news?? Please put it in the mega thread and Fix it! @UbiKobold.

  • MrX220
    ubisoft:x-posts, 4

    I have a similar issue in Lolingestone Bandit Camp. I moved the boulder to a position where it’s stuck and Ubisoft support told me to to go to the forums. I’m absolutely livid with their “support” on these kinds of issues.

  • Shaggyolive24
    ubisoft:x-posts, 4

    Please add the Milk of Humankind mystery to the list of known issues. The moveable stone is stuck and the cow won’t move from the second area. All walls are broken and tried numerous suggestions but nothing. It’s the last thing I need for the platinum trophy. Numerous people have reported this but it is still not showing on the mega thread.

  • lordvader_01
    ubisoft:x-posts, 1

    Cow won’t move past second area (PS5 for me). It’s a known issue on Reddit etc and stopping people from getting platinum.

  • Ubi-Orion
    Ubisoft Support Staff ubisoft:x-posts, 1363

    Hey there folks.

    This issue is still under active investigation at the moment. I can only apologise for any inconvenience caused whilst we're working on getting this resolved.

    I have also raised whether we can get this issue added to the megathread as it is indeed a known issue, thanks for bringing that to our attention.

  • edocat88888
    ubisoft:x-posts, 7

    @Ubi-Orion 129 Replies/1988 Views since 11/17 and still not in the megathread. I can't understand why is so difficult to fix this simple quest.
    We waited for a long time, i need this quest to achive platinum like most of us. Please hurry up!

  • OldManRob64
    ubisoft:x-posts, 2

    Yes this one and the talking pig is also an issue for me

  • Mufty1
    ubisoft:x-posts, 2

    please please can someone look into this now been months and stuck for 100% progress cow won't move even doing a sync I have seen alot of other people with same issue yet all I see is fixes for other things just delete the rock haha

  • ElMadre1
    ubisoft:x-posts, 93

    Looks like it is FINALLY in the megathread. Now we just need that fix! I caught my last fish yesterday, so this is literally the only thing keeping me from Platinum. Also, the only thing keeping me from spending another penny on this game.

  • fenukii
    ubisoft:x-posts, 7

    It got added!!! Thank you Ubi 🙂

  • edocat88888
    ubisoft:x-posts, 7

    Next update more or less?! @Ubi-Orion thanks man appreciate your effort!!

  • Barton6435
    ubisoft:x-posts, 4

    ahhh im not alone, put so many hours into this but just cant bring myself to play since i hit this glitch. I tried to do the fishing trophy but theres no fish in the sea either LOL so frustrating

  • jay-burrat
    ubisoft:x-posts, 1

    The moveable rock is stuck inside the wall and can not be moved so the cow doesn't move from the second area.

  • Khaledshafic
    ubisoft:x-posts, 4

    @ubi-ginge thank you for your feedback, but i cant see this bug in the "known issues" topic, is there is any update regarding it?

  • guest-V3Kze9nF
    ubisoft:x-posts, 1

    Running patch 1.1.1 and got the cow at Milk of Humankind stuck. After smashing the first wood barrier instead of pushing the stone forward, I pulled it back and towards the wall, now it's stuck there. Finished everything else in the game (well, still missing one ymir's tear stone) so this is really annoying. Any ideas of a workaround or maybe how to reset the mistery?

Suggested Topics