Welcome to discussions

Quick Suggestions

  • ElMadre1
    84 posts

    Looks like it is FINALLY in the megathread. Now we just need that fix! I caught my last fish yesterday, so this is literally the only thing keeping me from Platinum. Also, the only thing keeping me from spending another penny on this game.

  • fenukii
    7 posts

    It got added!!! Thank you Ubi 🙂

  • edocat88888
    7 posts

    Next update more or less?! @Ubi-Orion thanks man appreciate your effort!!

  • Barton6435
    1 posts

    ahhh im not alone, put so many hours into this but just cant bring myself to play since i hit this glitch. I tried to do the fishing trophy but theres no fish in the sea either LOL so frustrating

  • jay-burrat
    1 posts

    The moveable rock is stuck inside the wall and can not be moved so the cow doesn't move from the second area.

  • Khaledshafic
    4 posts

    @ubi-ginge thank you for your feedback, but i cant see this bug in the "known issues" topic, is there is any update regarding it?

  • guest-V3Kze9nF
    1 posts

    Running patch 1.1.1 and got the cow at Milk of Humankind stuck. After smashing the first wood barrier instead of pushing the stone forward, I pulled it back and towards the wall, now it's stuck there. Finished everything else in the game (well, still missing one ymir's tear stone) so this is really annoying. Any ideas of a workaround or maybe how to reset the mistery?

  • GrossAuge27
    1 posts


    Cow mission in asgard: stone is not moving or cow just stays in place.

  • superomega34
    1 posts

    Same here playing on PS5. 😞

  • Adamerica1
    3 posts

    In asgard, the cow is stuck. The stone that you have to move is not in the right spot and other players have reported the same issue since launch. When will this be fixed?

  • scottymcv
    2 posts

    I'm playing it now and it is frustrating because it is literally the only thing standing between me and 100% completion. If its been know to exist since release why hasn't it been fixed yet? The recent patch didnt fix it and it wasnt listed on the list of issues rectified. Please fix it.

  • slanitis
    6 posts

    Any update on this?

  • slanitis
    6 posts

    @ubi-ginge hello, any update on this?

  • guest-Enj9qrCF
    1 posts

    Yep. Having same problem. Stone block stuck and cow won't go past. Same issue in Lunden with smelly jar mystery; stone block stuck and guy won't leave.

  • Rajna_
    1 posts
    This post is deleted!
  • edocat88888
    7 posts

    Did anyone tried new patch? Stille bugged? Thanks

  • stripedg1nger
    1 posts

    Still happens after today's tilte update.

    I didn't think there is more annoying bug than fabric bug.

    Please, fix it.

  • ElMadre1
    84 posts

    Can confirm that this is STILL. NOT. FIXED.

    Makes it even more infuriating that I have to spend 20 minutes to get to the location just to check. No Season Pass money coming from me until this is fixed.

  • Ubi-Borealis
    Ubisoft Support Staff 3625 posts

    Hello all!

    I would like to provide you all with an update on the status of this investigation. I can confirm that this issue was not addressed in TU 1.1.2. I apologise for any disappointment caused by this. I can reassure you that the development team have been able to reproduce this during testing, and they are still looking into this mystery further. At this moment in time, we have no further information to share, including an ETA for a resolution. I would recommend checking out our News & Announcements forum for further updates.

    Thank you for continuing to update this thread with your experiences of the issue. Once we have any further news to share it will be posted within the forums, so please keep an eye out.

    Thanks all! 😊

    Official Response
  • FencerJEC
    6 posts

    Unfortunately, it is still NOT fixed with the 2.20 update for the PS4. For me, this is the only mystery remaining that prevents me from the Completionist trophy (hence, the Viking legend trophy). I have contacted multiple times Ubisoft via "Support Tickets". This is a programming error. Once you push the moving stone inwards to enter, you game is bugged. At least, the issue is on the list...

Suggested Topics

Community Details

46
Online
192.8k
Users
32.5k
Topics
162.6k
Posts