Welcome to discussions

Quick Suggestions

  • scottymcv
    2 posts

    I'm playing it now and it is frustrating because it is literally the only thing standing between me and 100% completion. If its been know to exist since release why hasn't it been fixed yet? The recent patch didnt fix it and it wasnt listed on the list of issues rectified. Please fix it.

  • slanitis
    6 posts

    Any update on this?

  • slanitis
    6 posts

    @ubi-ginge hello, any update on this?

  • guest-Enj9qrCF
    1 posts

    Yep. Having same problem. Stone block stuck and cow won't go past. Same issue in Lunden with smelly jar mystery; stone block stuck and guy won't leave.

  • Rajna_
    1 posts
    This post is deleted!
  • edocat88888
    7 posts

    Did anyone tried new patch? Stille bugged? Thanks

  • stripedg1nger
    1 posts

    Still happens after today's tilte update.

    I didn't think there is more annoying bug than fabric bug.

    Please, fix it.

  • ElMadre1
    81 posts

    Can confirm that this is STILL. NOT. FIXED.

    Makes it even more infuriating that I have to spend 20 minutes to get to the location just to check. No Season Pass money coming from me until this is fixed.

  • Ubi-Borealis
    Ubisoft Support Staff 2812 posts

    Hello all!

    I would like to provide you all with an update on the status of this investigation. I can confirm that this issue was not addressed in TU 1.1.2. I apologise for any disappointment caused by this. I can reassure you that the development team have been able to reproduce this during testing, and they are still looking into this mystery further. At this moment in time, we have no further information to share, including an ETA for a resolution. I would recommend checking out our News & Announcements forum for further updates.

    Thank you for continuing to update this thread with your experiences of the issue. Once we have any further news to share it will be posted within the forums, so please keep an eye out.

    Thanks all! 😊

    Official Response
  • FencerJEC
    6 posts

    Unfortunately, it is still NOT fixed with the 2.20 update for the PS4. For me, this is the only mystery remaining that prevents me from the Completionist trophy (hence, the Viking legend trophy). I have contacted multiple times Ubisoft via "Support Tickets". This is a programming error. Once you push the moving stone inwards to enter, you game is bugged. At least, the issue is on the list...

  • ringhio1942019
    2 posts
    @ubi-ginge new update and you still haven't fixed anything. We buy your games for 70 euros and you don't care about anything. this is my last ubisoft game. I can't even make platinum because of this mission


  • edocat88888
    7 posts

    Oooh c'mon Ubisoft 😢 😥 Still waiting platinum since 2 months.

  • rgcoco
    1 posts

    The cow in Asgard doesn’t follow and the moveable wall/stone is blocked by the wood on the ground.

    Dismayed that this hasn’t been fixed in the latest update as I can’t get the platinum. Please fix this. 🙏

  • DonutActualTTV
    4 posts

    HOW is this still not fixed, haven't played this game in 2 months, just logged on, and it still isn't fixed. I might not understand how games are coded and built, but I can't imagine a multi-million dollar game developer CAN'T figure out how to remove a piece of wood. Not buying any DLC until it's fixed, if I can't 100% the base game, not starting any new content. Unreal, just unreal.

  • ACLAWMAN
    3 posts

    Asgard glitch’s have still not been fixed can’t complete the cow challenge or delivering paint to the builder. It’s the only missions I have left to do very frustrating!!!!!!!

  • DarthBateman
    1 posts

    This has me demented now it's the only thing stopping me getting 100% on the game and is playing havoc with my OCD!!

  • Aerial_Arts
    29 posts

    it's Nice to see that this glitch hasn't been fixed in about 3months as well... but my hopes are high for the 3.17 update in feb 2022 to give us all an option to pay helix credits to finish quests!

  • Kaziko27
    1 posts

    I was doing some stuff in Asgard, i found this cow "Shut in", I was trying to free it but it's not moving at all, I think the game had a moveable interactable that wanted me to move, but I believe it's positioned incorrectly, check out this video on the issue.

  • JessicaHelen
    3 posts

    Hi

    I have played the game for roughly 150hours and on 97% trophies. The only one I am missing is 100% completing each area, however, the last and only mystery I am unable to complete is this one named in title. I have tried everything but the cow doesn’t move, I don’t have an older save and I know this is a bug. Looking online this has been ongoing since November? It’s disappointing that regardless of multiple patches this bug has still not been fixed and is stopping me from completing W Perfect Game Save.

    Is there going to be a patch that will sort this to enable me and many other players to finally complete this mystery quest and enable the platinum trophy? I contacted Ubisoft Live Chat and they stated to post on this forum as the developers overlook it as they had no idea or any updated information?

    Kind regards

  • AlphaGoose46219
    157 posts

    @jessicahelen Found 8 posts of this bug in player support, didn't found it "addressed" on the 1.1.2 update list!
    Ubisoft has given response on one of the posts in player support so they are aware of it.

Suggested Topics

Community Details

25
Online
138.8k
Users
24.3k
Topics
125.8k
Posts