Continue your odyssey

Welcome to discussion

Quick Suggestions

Hello! These new forums are an open beta and we welcome your feedback in this section.
  • Ubi-Borealis
    Ubisoft Support Staff 1402 posts

    Hello there,

    @ElMadre1 - Thank you for updating us and letting us know that you've been able to complete "Milk of Humankind." Thank you for sharing how you were able to do this, including the steps you took leading up to attempting the world event again.

    I would like to assure players that are still affected by this issue that the development team are still investigating further. We don't yet have any new updates to share from the investigation. We have forwarded the reports that have been shared within this thread for a closer look.

    @SteveCross95 - Thank you for sharing this video in the forum. I've passed this along to the development team as part of the ongoing investigation.

    @LordSkempe - I'm sorry to hear that you're unable to progress with "Milk of Humankind." I can see that you have a support ticket open and have been in touch with a member of the team. They will reach out to you with an update as soon as they are able to.

    @JurassicJew03 - Thank you for sharing your report with us. I've passed this along to the development team for further investigation.

    @Link_FTW - Thank you for updating us. I'm sorry to hear you're still unable to progress with "Milk of Humankind." The development team are still investigating this issue further. Once we have any new information to share, it'll be posted within the forums.

    Thank you ๐Ÿ™‚

    Official Response
  • AbandonedCart
    9 posts

    How the investigation going? Has the development team figured out how to insert the disk yet?

  • fenukii
    6 posts

    Oh my God, I literally can't believe it but it's finally worked for me and I have been able to achieve my platinum ๐Ÿ˜ฎ I didn't even do anything spectacular either. I just spawned into the room where Alhambra is right next to the rock where I must have saved from the last time I played, whenever that was and it let me move the rock to the right place and 30 seconds later, platinum trophy obtained! No idea what's happened since the last patch but whatever it is, it worked. Thank you Ubi ๐Ÿ™‚

  • Toeryn
    7 posts

    Since the last patch I have been able to move the stone a little, it's no longer stuck in the wall. But it still trapped between the wood on the floor and the stone blocks to the right.

    It's quite frustrating. If the planks on the floor were not there (or allowed you to move the rock over them) I could finish this mystery and get my platinum trophy. This is literally the last thing I have left to do in the main game.

  • UlsterBear
    1 posts

    This is crazy that this still bug isnโ€™t fixed. Weโ€™re in May 2021 now. Iโ€™m another with the rock stuck between the planks and boulders on the right.

    Last time I tried (around 6 weeks back) the moveable stone was stuck against the wall. Today itโ€™s free from the wall but stuck between planks and boulders on right. This is my last mission to 100% the game so far, until this is fixed Iโ€™m refusing to purchase any DLC or other Ubisoft software on my series X. Ive 100% complete the previous 2 Layla based games including all DLC so far but the way this has been handled is enough to put me off one of my favourite franchises.


    Mightily disappointed in the development team. The amount of people that have been stating this issue from November and the fact it is still not addressed shows what really matters to Ubisoft and itโ€™s not the fans of the series, most of which paid top dollar for their latest instalment of this series. Seems like the franchise is now a busted flush

  • LordSkempe
    8 posts

    @UlsterBear, I've already made an official complaint against Ubisoft with the Better Business Bureau (BBB) as this has now crossed the boundary into a clear violation of the Consumer Rights Act (CRA) that they can handle for us. While bugs are both expected and allowed upon release of digital products, the company that produces the product is liable to fix it if the consumer(s) can prove that the item/content that is being paid for is faulty. If this game were free, Ubisoft would not be obliged to respond and we would be stuck. They also have a generous window to fix the issue, however with no action taken or progress made on a fix some 6+ months and counting, it now puts them well within the boundaries for us to take action

    I HIGHLY recommend you either sign onto my public complaint with the BBB or use the link I'll include at the end of my post to create your own complaint with Ubisoft over the very same issue. If enough complaints are received by the BBB, Ubisoft will either have to provide the fix we've all been asking for or face a lowered business rating and possibly further action too

    The link to file a complaint is https://www.bbb.org/file-a-complaint

    P.S. Personally, my situation hasn't changed with all the updates. My rock is still inside the wall all these weeks and bodies thrown later and won't budge whatsoever no matter what I try

  • Ubi-Borealis
    Ubisoft Support Staff 1402 posts

    Hello there,

    @AbandonedCart - I appreciate that you would like some more information from the investigation. Please note that the player support team currently has no further information to share from the ongoing investigation. We are unable to speculate on fixes or potential ETAs for an update when these have not been provided to us. I understand that this may not be the update you were all hoping for, and I would like to reassure you that we will continue working with you all to try and get this issue resolved.

    @fenukii - Thank you for updating us, and for letting us know that you've been able to resolve the issue. Congratulations on unlocking your platinum! ๐Ÿ‘

    @Toeryn - I apologise for any frustration that has been caused by "Milk of Humankind." The development team are still taking a closer look at this mystery. Once we have any news to share with you all, it will be posted within this thread.

    @UlsterBear - Thank you for taking the time to share your feedback with us. I'm sorry to hear that this has caused you disappointment. I would like to assure you that the development team are treating reports of this issue seriously, and that they are still investigating what could be potentially causing this issue in-game. If you haven't already, I would recommend checking out the recent Dev Blog, as this gives more insight into the internal development processes, and how investigations are carried out by the team.

    Thanks! ๐Ÿ˜Š

    Official Response
  • guest-xa0EdmaP
    2 posts

    Well at least I can finally move the rock now... All we're asking for is for you guys to remove the collision from the wood planks on the floor. There's no way it can be that hard or take that long. Here's a link to what I'm seeing:

  • LordSkempe
    8 posts

    @guest-xa0EdmaP, the left side of my rock is still glitched partially inside the wall the wood planks are standing against in addition to also being behind the wood planks on the floor also blocking it. The wood handle on the left side of the rock is not even visible for my character to attempt to grab it's so far in the wall. I need the rock to respawn to its original position for me to have any chance of fixing this quite frankly, so there's more to be fixed than just removing the wood planks, although that definitely will help

    This is all after already spending 6-7 hours assassinating the nearby enemies and throwing their bodies at the rock one after the next. While this did allow me to move the rock a few feet collectively at first, it's now officially dead-stuck inside the wall unable to move anywhere in any direction whatsoever no matter what I do/try, even after the most recent update(s). As I was saying, I don't think there's any fix for me asides from the rock moving back to its original location. Not wasting another 140 hours to 100% the game all over again over a rock they so obviously screwed up creating

  • Ubi-Borealis
    Ubisoft Support Staff 1402 posts

    Hello there,

    @guest-xa0EdmaP - Thanks for sharing your experience with us, and for providing a video that shows what you're encountering in-game. I've passed this along to the development team for further investigation.

    @LordSkempe - Thanks for providing us with more information about your experience with "Milk of Humankind." I've added this to the report you have already submitted to the development team.

    Thanks! ๐Ÿ˜Š

    Official Response

Suggested topics

Community details

31
Online
124.1k
Users
21.4k
Topics
110.2k
Posts