Continue your odyssey

Welcome to discussion

Quick Suggestions

Hello! These new forums are an open beta and we welcome your feedback in this section.
  • P3RVISAG3
    3 posts

    So I just came back to the cow after the update and now the cow is in a new spot but still stuck and the rock is still stuck on the wall and can’t be moved.

  • TheDingo92
    1 posts

    Still bugged after update

  • Hchmss
    3 posts

    @floodedmantis same here... Too bad the new patch didn't fix this problem

  • Hchmss
    3 posts

    Same here! Hope for another new patch who fix this bug

  • tblackwell97
    2 posts

    @crimsfyrill I am having the same issue and I even tried to see if the new patch (1.04) fixed this and nothing changed.

  • SimperingTyler
    2 posts
    @crimsfyrill I am having the same issue and I even tried to see if the new patch (1.04) fixed this and nothing changed.

    I am also having the same issue and I’m on xbox.

  • Boomerangman90
    2 posts

    @helensblake This annoys the living [censored] out of me as well; This game has been a clusterfuck of bugs, start to finish. This is one of those that just doesnt seem to fix itself.

    Waiting for a fix.

  • Boomerangman90
    2 posts

    Still bugged. Still annoying.
    Fix this Ubi! the bug-ridden mess this game has been... holy [censored]...

  • HelenSBlake
    21 posts

    @boomerangman90 Me too, they release a patch and don't fix this ffs.

  • Ubi-Swaggins
    Ubisoft Support Staff 340 posts

    Thanks for confirming that the fast travel did not fix this issue.

    It has been passed up to the dev team and they are looking into it further.

    Once we have more information to share, we will do so.

    Official Response
  • DonutActualTTV
    4 posts

    They did a update and this still isnt fixed!

  • azasasyn
    2 posts

    Hi,

    as the topic title says, the cow is stuck. I pulled the stone back and I can not move it anymore. The cow is stuck near the stone.

    It is my last mystery in Asgard and I can not proceede 😞


    I am loving the game though!

    Thanks in advance for your help 🙂

  • memarcustitus
    1 posts

    PS5. There seems to be a glitch where the cow won’t move. It just stand right there, even if breaking all the barriers so it can escape (also tried killing it). Closing the app doesn’t fix the problem. If only I could milk the cow and have a latte while I wait until this gets fixed...

  • slashtor00
    7 posts

    I am in Asgard making the "MILK OF HUMANKIND WORLD EVENT" and my cow run to the ocean.

    What i to do?


  • fish0604
    1 posts

    I'm having the same issue, on PC. If I leave Asgard can I come back, hopefully after this is patched?

  • timmileet
    2 posts

    Same issue here. Second bug that wont let me finish my quest. This one, and "Thor the Fishmonger"..........

  • Qdlat1986
    1 posts

    @tzarak Heya, i have my stone stuck in the same position... Bugiesoft plzzzz

  • HiiiGh3RR
    5 posts

    @carnivor-hippos nope still bugged.

  • Gcarter1607
    3 posts

    @tzarak definitely still bugged after the update.

  • mitchelsmith96
    1 posts

    After breaking the first of the wooden gates, i have moved the stone blockage out of the way ensuring enough room for the cow to move but it wouldnt budge, i searched on youtube and saw everyone moved the stone blockage the opposite way to what i did so i went back but now that wont move, its as if it is stuck to the wall. I have fast travelled away, returned to the main game as Eivor, and retarted the PS5 multiple times but everytime i return the stones/rock blockage is still up against the wall and wont allow me to move it. Does anyone have any other ideas of what i could do ?

Suggested topics

Community details

6
Online
124.0k
Users
21.3k
Topics
110.0k
Posts