Welcome to discussions

Quick Suggestions

  • k3viniz3d
    1 posts

    Hi all,

    I just wanted to add that I also experience problems with this quest. The guy wont move. I broke all the jars, threw bodies at it, but the thin movable part seems to be in the wrong area. Is there any way to reset this?

    If I read this tread, I need to agree with @Damfrallan. It seems like different parts are bugging out for everyone.

  • Ubi-Borealis
    Ubisoft Support Staff 3625 posts
    Best Answer

    Hello there!

    As we have had no further reports of this issue persisting in-game following the release of TU 1.1.2, we will now be locking this thread.

    If you encounter any further trouble with "Demon Odour at the Tithe," please don't hesitate to open up a new thread so we can take a closer look. When opening a new thread, please include as much information about the issue you're encountering as possible. Any images or videos that demonstrate the issue in-game are also helpful for further investigation.

    Thanks! 😊

    Official Response
  • INTERVENTION20
    1 posts

    Can confirm @rothbart96 is correct with his logic. (Nice one dude) as for me....after 30mins of getting [censored] off!! I then realised the small box (single movable stone box) near the NPC was on the wrong guide. As the double box was in its area thus not triggering the NPC.

    so... I left the area ran back so the small box was now raised up and jars, jeet’d a body or 6 at it until it was back on the originally track and boom triggered the NPC, quest completed. (Obv’s make sure all other movable box’s are in the correct place).

  • guest-mhyEljSG
    1 posts

    So, having encountered the Sons is Ragnar bug that won’t let me speak to Ubba and refusing to delete my 58H of progress (I did Grantebridgescire first, and a load of farming/mysteries), I’ve gone to Lunden to start the arc there and found a(nother) bug.

    (Spoiler if you care about the mysteries): There’s a bug for one of the mysteries near the Lunden dock where a merchant is stuck in a warehouse behind a load of moveable objects. He wants you to move them to set him free. Problem is I’ve moved them all and the option to speak to him to complete the quest isn’t there. I’ve moved all the crates/lifted all the jars out of the way (so that I can move freely between him and the outside world by walking), reloaded my save, tried destroying all the jars to trigger a response from him (because he tells you not to), I’ve meditated, fast travelled a few times to the nearby docks and then ran back, but nothing. The moveable objects also often respawn back on top of the jars he tells you not to destroy, making them impossible to move unless you do destroy them, which I’m sure will irk people looking to complete the quest without upsetting the npc. One of the crates also doesn’t move at all, but I’m not sure if this was intentional because I couldn’t move it from the get go. Not sure why it would be, though.

    According to some comments, other people on YouTube have apparently found the same issues, and other issues with this quest that aren’t included here because I didn’t see them myself, but may be of use if you’re looking to avoid getting stuck on this like I am.

    Really hoping these bugs get fixed soon. I can’t progress with the story, and now I have a perpetually incomplete mystery on the map.

  • liveatlast91
    4 posts

    ok so i got everything fixed but the first box. its stuck bodies do nothing. and it spawns IN front of the jars. right by the door. its moved just enough i can get over it, but I cant have him walk past it, which I'm assuming is the issue.

  • SurexPOSEY
    22 posts

    @ubi-baron had multiple bugs on this mystery.

    first time there was nobody in the warehouse.
    I loaded an earlier save and second time I move all the shelves but can't talk to the Norse man and he can't move.

  • ThorGodThunder1
    6 posts

    Im also having an issue with it, however my issue is the smaller movable objected clipped over the wood barrier and cant be put on the spot to allow the npc to walk out of the warehouse.

  • SurexPOSEY
    22 posts

    Update:
    After few reload save for others quests, I come back to the warehouse and the NPC talked.
    I could talk to him but he still don't move...

    + I have one of the shelves that didn't spawn into the right zone


    The little one spawned on the right instead of the left in the "rails".

  • ThorGodThunder1
    6 posts

    @surexposey this is the same issue im having

  • cbantug
    4 posts

    @sparkes24 I had this problem yesterday. I fixed it, in a very strange way... I went outside and killed an npc, took her body and kept throwing it at the shelf while it was still on the pots. After a few tosses it had moved back enough that once I broke the pots underneath it fell into place where I can move it.

  • ThorGodThunder1
    6 posts

    @cbantug Ive tired that the pots break instantly with the first throw

  • ThorGodThunder1
    6 posts

    @surexposey before trying to break any of the jars under it after it spawns see if you can move it, It allowed me to move it over the rail on a jar and complete the mystery

  • Suturewow
    1 posts

    I ran in to this problem as well and I'll be honest, idk what worked. I moved the boxes and jars before the quest was there and the box was standing on top of jars. I tried everything from fast travelling to a viewpoint in another zone, meditating, throwing a body, nothing worked. Eventually, I reloaded at a save right before throwing the body, the box was still on top of the jars, but the norse man was standing outside saying "thanks for freeing me." As I said, idk what I did, but it eventually worked!

  • RoaringKALIDOR
    2 posts

    this guy disappeared and one of the boxes is sitting on top of the jars and cannot move it.

  • Ubi-Baron
    Ubisoft Support Staff 788 posts

    @tajikcze Thanks for providing those screenshots, we'll pass that on to the team.

    We appreciate users providing workarounds to help others, as mentioned though these issues are still being looked into.

    Official Response
  • Hahree
    1 posts

    I also have the exact problem. I want to 100% the game but this will stop me. I've asked xbox for a refund as Ubisoft will not fix it.

    This isn't the only mystery or quest that's broken for me. I've had to reload old save as NPCs from quest wont spawn or you can't start dialogue with them.

  • Wraithclaw
    7 posts

    @sharp2spartacus I agree. I was able to move the buggy shelves (by destroying the jars that somehow got under them...) but the NPC wouldn't spawn for me.

    Poor design. A map marker should not show itself if the player cannot yet actually do it -- just have it appear after the main quest is completed, or make the NPC spawn before that.

  • borracho61
    4 posts

    and left side londinium amphitheatre myseries bug

  • Buur098
    2 posts

    I was doing mysteries in Lunden and the last one I did was the one with some blue stinky jars in a warehouse and the first cart is stuck (I moved it out and then I stopped moving at all) the next on is on top of the jars and when I destroy them it falls on top of the wood line and not on the correct side so that can’t be moved either. Is there anyway to fix it like do I really have to try reinstalling the game?

  • jandraelune
    119 posts

    Lol, running the streets of Lunden after starting the main quest line. I found the said NPC just sitting in the streets next to the river west of the warehouse, talked to him and completed the quest.

    I have the same issue, move the stacks and jars, but no NPC and quest in the warehouse.

  • Ubi-Wan
    Ubisoft Support Staff 631 posts

    @buur098 Sorry to hear you're running into this. First, I want to have you try verifying your game's files. After, if the issue persists, please provide us with a clip of the issue occurring!

    Official Response

Suggested Topics

Community Details

70
Online
193.1k
Users
32.6k
Topics
163.1k
Posts