Welcome to discussions

Quick Suggestions

  • Locked SOLVED [RESOLVED] Unable to move the shelves to free the NPC in "The Demon Odour at the Tithe" | POST HERE

    30 Likes/532 Replies/8889 Views
    22 posts

    @ubi-baron had multiple bugs on this mystery.

    first time there was nobody in the warehouse.
    I loaded an earlier save and second time I move all the shelves but can't talk to the Norse man and he can't move.

  • ThorGodThunder1
    6 posts

    Im also having an issue with it, however my issue is the smaller movable objected clipped over the wood barrier and cant be put on the spot to allow the npc to walk out of the warehouse.

  • SurexPOSEY
    22 posts

    After few reload save for others quests, I come back to the warehouse and the NPC talked.
    I could talk to him but he still don't move...

    + I have one of the shelves that didn't spawn into the right zone

    The little one spawned on the right instead of the left in the "rails".

  • ThorGodThunder1
    6 posts

    @surexposey this is the same issue im having

  • cbantug
    4 posts

    @sparkes24 I had this problem yesterday. I fixed it, in a very strange way... I went outside and killed an npc, took her body and kept throwing it at the shelf while it was still on the pots. After a few tosses it had moved back enough that once I broke the pots underneath it fell into place where I can move it.

  • ThorGodThunder1
    6 posts

    @cbantug Ive tired that the pots break instantly with the first throw

  • ThorGodThunder1
    6 posts

    @surexposey before trying to break any of the jars under it after it spawns see if you can move it, It allowed me to move it over the rail on a jar and complete the mystery

  • Suturewow
    1 posts

    I ran in to this problem as well and I'll be honest, idk what worked. I moved the boxes and jars before the quest was there and the box was standing on top of jars. I tried everything from fast travelling to a viewpoint in another zone, meditating, throwing a body, nothing worked. Eventually, I reloaded at a save right before throwing the body, the box was still on top of the jars, but the norse man was standing outside saying "thanks for freeing me." As I said, idk what I did, but it eventually worked!

  • RoaringKALIDOR
    2 posts

    this guy disappeared and one of the boxes is sitting on top of the jars and cannot move it.

  • Ubi-Baron
    Ubisoft Support Staff 789 posts

    @tajikcze Thanks for providing those screenshots, we'll pass that on to the team.

    We appreciate users providing workarounds to help others, as mentioned though these issues are still being looked into.

    Official Response
  • Hahree
    1 posts

    I also have the exact problem. I want to 100% the game but this will stop me. I've asked xbox for a refund as Ubisoft will not fix it.

    This isn't the only mystery or quest that's broken for me. I've had to reload old save as NPCs from quest wont spawn or you can't start dialogue with them.

  • Wraithclaw
    7 posts

    @sharp2spartacus I agree. I was able to move the buggy shelves (by destroying the jars that somehow got under them...) but the NPC wouldn't spawn for me.

    Poor design. A map marker should not show itself if the player cannot yet actually do it -- just have it appear after the main quest is completed, or make the NPC spawn before that.

  • borracho61
    4 posts

    and left side londinium amphitheatre myseries bug

  • Buur098
    2 posts

    I was doing mysteries in Lunden and the last one I did was the one with some blue stinky jars in a warehouse and the first cart is stuck (I moved it out and then I stopped moving at all) the next on is on top of the jars and when I destroy them it falls on top of the wood line and not on the correct side so that can’t be moved either. Is there anyway to fix it like do I really have to try reinstalling the game?

  • jandraelune
    125 posts

    Lol, running the streets of Lunden after starting the main quest line. I found the said NPC just sitting in the streets next to the river west of the warehouse, talked to him and completed the quest.

    I have the same issue, move the stacks and jars, but no NPC and quest in the warehouse.

  • Ubi-Wan
    Ubisoft Support Staff 636 posts

    @buur098 Sorry to hear you're running into this. First, I want to have you try verifying your game's files. After, if the issue persists, please provide us with a clip of the issue occurring!

    Official Response
  • FirefighterBam
    1 posts

    While trying to complete this mystery near the docks moving the blue jugs and stacks of crates. I broke 2 jugs and the mystery is stuck, tried everything to see if it would reset. No luck on any of the attempts. The stack by the out door is also not moveable. Thanks for the help.

  • Damfrallan
    15 posts

    How long is this gonna take? In the last room, that small pushable object is on the wrong side, and you cant throw a body to make It slide over to the right spot.. wish i could send a picture

  • HayBai
    8 posts

    @killermarcei Yeah somehow that worked, haha thanks!

  • Vergilius91
    1 posts

    I have the same problem. Idiotic quest. npc wouldn't spawn for me. I have just finished main quest in Lunden - still npc doesnt spawn. I cannot start this quest. Ubi fix it, please!

Suggested Topics