Welcome to discussions

Quick Suggestions

  • nsan33
    5 posts
    This post is deleted!
  • Ubi-Borealis
    Ubisoft Support Staff 3529 posts
    Best Answer

    Hello there!

    As we have had no further reports of this issue persisting in-game following the release of TU 1.1.2, we will now be locking this thread.

    If you encounter any further trouble with "Demon Odour at the Tithe," please don't hesitate to open up a new thread so we can take a closer look. When opening a new thread, please include as much information about the issue you're encountering as possible. Any images or videos that demonstrate the issue in-game are also helpful for further investigation.

    Thanks! 😊

    Official Response
  • nsan33
    5 posts

    @ciarasteina I think Roth is right I’ve move all the boxes completely out of the way no jars nothing in the way but his still in there not moving

  • nsan33
    5 posts
    This post is deleted!
  • nsan33
    5 posts

    hope this helps everyone as much as it helped me
    so you main aim as you can see if to make a bridge while the small box in the 2nd room is floating make sure you got enough to drag all the way across

    best of luck !

  • Johnnydeg1234
    3 posts

    @ubi-raziel
    Hello thanks for the advice but it did not work.ive been trying to post pics or videos to show what is happening but it says I don't have permission to do so. Its the mystery to the left of temple of sulis Minerva along the water. I still can not move the large shelve that is blocking the pathway I destroyed all jars around even use an Incendiary shot at it thinking there is something under it, but there is not...not sure how to fix it...I assume if other people are having this problem as I am, there will be a patch in future, I guess I will have to wait for that or play the game again in hopes it fixes itself

  • kilyan82
    11 posts

    same, noone is there to interact with

  • Champix59310
    2 posts

    I have the same problem with the shelf being on the top of the jar... did you find any fix?

  • Champix59310
    2 posts

    @threeinonejdd you both helped me to solved it thanks guys i was so [censored]

  • Camdood10
    3 posts

    @sciss0rman okay thanks ill look into that

  • EngineerJared
    9 posts

    Still broken in 1.04.

  • Spochy
    1 posts

    Still bugged even with the patch, tried everything, the NPC doesn't spawn. I have beaten the game, and this is the only mystery left that I haven't completed. Kinda lame that I don't think I'll ever get to the platinum this game because of this. Oh well

  • sraywing
    8 posts

    Still bugged after the patch 1.0.4

  • ndbteam
    1 posts

    @gutao_com_g Same here tried it again and again. Either the person is missing and even if the person is there. the Crates dont move especially the middle one. UBI soft please fix this bug.
    thanks

  • Ulfhednar7807
    1 posts

    Same here. I guess I'll have to wait for the game to be actually playable to continue my playthrough. That's what we get for buying a Ubisoft game full-price on launch...

  • EsPo_the4th
    1 posts

    @dingdongdank Same issue here.

  • GavinP77
    2 posts

    This is still not working for me as of patch 1.04 either. The NPC is in his starting position with the way clear and is completely unresponsive. Odin’s sight doesn’t even highlight him in blue. I am over 125 hours in, almost finished everything and just wanting the completionist achievement.
    Is there going to be a fix for this soon devs?

  • MJEnterprise
    1 posts

    I have same problem, no one, and moove impossible on the box.

    its my last mistery, please fix it.


  • R4G3Seeker
    1 posts

    @tajikcze yeah got the same issue as you, the first movable object is stuck in the same position as yours, and is now unmovable, I can't free the path anymore and can't complete the quest

  • Vindilator
    8 posts

    So since last patch i had this issue where i moved those boxes abit before there was the man there because i had not complete lunden arc. So i went after the arc to check, tha man was there but all the jars/shelfs were bugged, it appears that once a shelfe is in a location if you reload the jars appear no matter where the shelfs are and i cannot move some at all since they are on top of the "restriction" line. One of the shelfs is in an even different position than its original. I made a case about this some time ago said it was supposed to be adressed but i dont see anything changed here.

    Trying to upload a picture but its too big apparently.

  • PeeKay85
    6 posts

    Same problem by me, the boxes are at the wrong places and don't move anymore. Even the "fix" with throwing corpses to move the boxes don't work.

Suggested Topics

Community Details

122
Online
190.6k
Users
31.7k
Topics
160.3k
Posts