Welcome to discussions

Quick Suggestions

  • o0_xFr34kx_0o
    5 posts



    I also have the problem with the shelf that is on the jar (at the entrance on the left side). This cannot be moved and World Event cannot be figured out 😞

    Current patch is installed!

  • Ubi-Borealis
    Ubisoft Support Staff 3625 posts
    Best Answer

    Hello there!

    As we have had no further reports of this issue persisting in-game following the release of TU 1.1.2, we will now be locking this thread.

    If you encounter any further trouble with "Demon Odour at the Tithe," please don't hesitate to open up a new thread so we can take a closer look. When opening a new thread, please include as much information about the issue you're encountering as possible. Any images or videos that demonstrate the issue in-game are also helpful for further investigation.

    Thanks! 😊

    Official Response
  • SNadrowski
    5 posts

    I have the same issue

  • o0_xFr34kx_0o
    5 posts

    same for me on Series X 😞

  • PeeKay85
    6 posts

    Same for me on series x.

  • Quandarius
    2 posts

    @karnageraz same. I was hoping it would be fixed with 1.0.4 but the movable objects still sit on top of the jars and can't be moved, so the guy won't leave!

  • Quandarius
    2 posts

    @ubi-spud same thing is happening to me. He bugged and wouldn't move because I broke too many jars and now the movable objects spawn on top of the foul smelling jars when I reload or fast travel back. Patch 1.0.4 did not resolve

  • SarcyE
    2 posts

    Same issue for me. I think it’s the first sliding block that won’t fully slide into place as I can’t walk in to the second area I have to climb, tried the throwing bodies at it but no difference. For a triple a game this really has way too many bugs and a lot less communication from the team as we deserve. Tried leaving the area and coming back etc but nope no luck getting the first sliding block to move properly. Whoever signed this game off as complete and tested should be fired

  • Franks360
    13 posts

    Patch 1.0.4 didn't fix this

  • DrumnBassATW
    1 posts



    Above is a link to a video walking you through my problem. Absolutely love this game and I'm just hoping this will help you make improvements and fixes to the game.

    Thank you for making such a great game.

  • EvilWaylander
    7 posts

    The mystery quest to rescue the man from behind the jars is bugged.
    sometimes he is there sometimes he is not.
    before I realised he needed to be there I cleared the path, now each time I return after completing other quests the issue is with one of the moveable walls.
    it is sitting on top of the jars and even if I smash and reset it respawns on top and it can’t be moved.

  • zclang423
    1 posts

    @poesch Same for me

  • jandraelune
    119 posts

    Have any of you just taken a walk west down the river, looked for an NPC with a chat bubble? Just talk to him.

  • h4mx0r
    1 posts

    My game was glitched with the 1x1 box becoming unmovable. I tried the throwing body thing and it nudged the box around but to no avail.

    In my frustration I kept reloading and messing around, but then I went to move the first box (even though it was already out of the way) and as soon as I nudged it, the NPC teleported outside the building and was like "Thanks brah!" and I could talk to him. Gosh I got lucky, just keep fiddling around I guess. Hope they fix this one.

  • Rampage_8
    1 posts

    @evilwaylander This also happened to me, I tried to put back the walls back where they were first, but the small one jump off the track it was in and now there all stuck.

  • kilyan82
    11 posts

    Patch 1.04 solved it for me, i found the npc outside the barn

  • Mirronelli
    1 posts

    @socratic13 not even 1.04 solved this. I have actually tried this in 1.04 the first time. At first there was no person. Later the movables were spawn on top of the pots.

  • DeviateFish
    3 posts

    @sky_sailor92 The 2nd block was stuck on jars for me too, and even if I broke the jars underneath I wasn't able to move it. However, when I moved the 1st block all the way to the stopping point, the event completed, even if the 2nd block was blocking his path. If you're still having issues, maybe check that all the blocks you are able to move are moved all the way to the stopping point.

  • guest-dG2YMauG
    2 posts

    @mirronelli Having same issue. I went in here before starting the quest trying to get to the marker, didn’t realize you could just jump
    over to start the convo with the guy. Then all of the movable objects spawned where I last left them which is on top of the jars. Even if you destroy the jars and the movable objects drop, they don’t move after that so I can’t set the guy free.

  • kurse020390
    1 posts

    @threeinonejdd great thx a lot👍

  • Holymaniac97
    1 posts


    the first shelf stuck and i cannot complete the mystery please fix.

Suggested Topics

Community Details

51
Online
192.8k
Users
32.5k
Topics
162.6k
Posts