Welcome to discussions

Quick Suggestions

  • Gizmo2k
    13 posts

    @ubi-baron Any idea if we can 'force' the man to actually be there? 😞 Literally all I have left to do.

  • Ubi-Borealis
    Ubisoft Support Staff 3570 posts
    Best Answer

    Hello there!

    As we have had no further reports of this issue persisting in-game following the release of TU 1.1.2, we will now be locking this thread.

    If you encounter any further trouble with "Demon Odour at the Tithe," please don't hesitate to open up a new thread so we can take a closer look. When opening a new thread, please include as much information about the issue you're encountering as possible. Any images or videos that demonstrate the issue in-game are also helpful for further investigation.

    Thanks! 😊

    Official Response
  • Draeoth
    27 posts

    There is a warehouse near the river that has a mystery I cannot start. There are movable shelves and blue vases that make Eivor Vomit when they break. There is no one to talk to and the first movable shelf is stuck. I pulled it towards the open door and it is now stuck in the sacks that r on the gound. I cannot move it back into place or any other direction.

    The other mystery im having an issue with is A Rivalry for the Ages. I talked to the girl and she has the guy distracted but there is no key where the key icon is placed.

  • xAimeeAcidx
    1 posts

    So after having a few issues myself..

    1. Make sure to finish the Lunden arc before trying this mystery, he appears after doing so
    2. If you start it before this point (like i did) and the shelves get stuck(after destroying or moving jars), i can confirm that throwing a dead body at the shelves helps unstick them. Theres a guard by the docks you can kill and use.


    if you get stuck on the very last set of shelves like i did where they won’t move fully to the right, keep throwing the body on the smaller edge to force the shelves right, eventually this moved it enough to unstick the shelves so the move option came back up and i was able to finish the mystery.

  • Ubi-Baron
    Ubisoft Support Staff 788 posts

    @gizmo2k Unfortunately I don't believe so at the moment.

    @xAimeeAcidx Thanks for providing that information, hopefully that can help others seeing this.

    Official Response
  • panini_ozolives
    6 posts

    hi,

    I went to Lunden before the main quest line brought me there. On the harbour there is a warehouste with plenty of blue jares and moveable shelves. I moved the jars around the place so as to move the shelves, only to find nothing behind. So I moved on.
    Later, I went back to Lunden during main quest line, and now there's a NPC blocked behind the shelves that I had previously moved, and he asks me to free him. Problem is, some of those shelves have been moved back more or less to their initial positions, and one just sit on some of the blue jars which happen to be roman garum, and they must not be broken because it smells terribly: https://imgur.com/a/eBj4lTp

    That shelve cannot be moved so I cannot free the passage and the NPC stay locked behind, preventing the quest to finish.

  • Xilverix
    8 posts

    @panini_ozolives Can you break the jars underneath the shelf with an arrow? I believe you can break all of them and the quest can still be finished.

  • panini_ozolives
    6 posts

    @xilverix I haven't tried actually as the NPC explicitly ask to not break them, because the smell is terrible (I fear a toxic cloud if some are broken). I'll quick save there and give it a try.

  • Mr.Gerchan
    1 posts

    Talk to him first, you can climb the wall, and then start clearing the path, even with crates on jars, it works just fine, just talk to him before clearing the path.

  • Gizmo2k
    13 posts

    @xaimeeacidx I've tried throwing bodies every which way. I can now move all the moveable crates, the guy's here, but he's still not leaving 😞 😞

  • X-Spiike-18
    7 posts

    Hello after your update which was supposed to correct the mystery bugs, the lunden mystery bug at the ports and still as much bug i do not want to restart the gale because i am already making good progress in the game so please correct yourself. Bug or suppress the mystery of the game because i intend to finish the game at 100% like all the assasin’s creed that i have toyed and the mystery blocks me for my quest for 100%

  • sirmurder
    1 posts

    I'm having the same problem on the Xbox Series X.. The first one is stuck, tried throwing a corpse and it still isn't moving. The second one is spawning on the vases. I've already started the quest and the guy won't talk with me anymore.

    Please help!

  • Mmonk99
    1 posts

    The side quest where you have to solve the puzzle with the man stuck in the store hours with the bottle of bad smelling sauce, i went there before the quest was active and finished the puzzle because I thought there was treasure behind it, now i cant complete the puzzle because one of the sliding walls is spawning on top of these bottle and cant be slid even if i break the bottles.

  • CKEALiddy
    8 posts

    @mmonk99

    I just had that problem if it’s the same one as might and was stuck just next to the open doorway, for me I pressed triangle or Y on the side of the sliding thing closet to the doorway and Eivor managed to just glitched through the tight spot. I wasn’t able to move it but I was in the next area but I cleared the rest of the way by smashing the blue jars and then the man pretty much glitched through the wall and I just had to go outside and speak to him.

  • T-Roach97
    1 posts

    I’ve had the same problem as many of you and resolved it today. The smaller shelf in the back room was in the wrong spot therefore the guy wouldn’t walk out. After an hour or two of going to the fast travel/load a game (so annoying), the small shelf was on top of a vase. You NEED to make sure it respawns on top of a vase. Move the other vases in front of the small shelf making a little bridge type thing towards the spot/tracks where it should be. You should be able to slide it on top of the vases into the correct spot. For me it didn’t even have to drop, all it had to do was slide a tad bit over the correct tracks and the guy spawned outside and it was over. Hope this helps! I thought this mission was hopeless but this worked!

  • Gizmo2k
    13 posts
  • speedynl21
    79 posts

    i hitted the shelf a couple of times with 2x 2h axe, after that i was able to move it, seems for some unknow reason its not 100% in place

  • Pulsar8313
    2 posts

    the PNJ is here but the second mobile case is impossible to move because all pots have respawn
    Blocked for platinium trophy just for that

  • Cesarmrl2
    10 posts

    @pulsar8313 similiar issue with that event cant move the Shelfs but also the NPC is not there

  • Freestepper
    111 posts

    Wait till you do the main story quest in that city. After that, i went to that place with the event and the NPC appeared outside of that warehouse and thanked me for getting him out of there and the event was completed. Yes, it's bugged nevertheless, just like many things in this game.

  • Pulsar8313
    2 posts

    @freestepper i have already completed story line

Suggested Topics

Community Details

117
Online
191.5k
Users
32.1k
Topics
161.3k
Posts